Bug #24459

Repair truck not repair plane after ejecting

Added by Myau over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:09/12/2011
Priority:Normal Due date:
Assignee:zGuba % Done:

100%

Category:Script
Target version:1.12
Component:sys_repair Affected Version:
Close Reason:

Description

If i eject from plane (example Su-25), then i can't enter in him.
This reality, but repair truck not repair plane after ejecting...

Reprolalala.utes.pbo (1.7 kB) Myau, 09/13/2011 07:44

History

Updated by Myau over 3 years ago

If be accuracy, plane repairing, but enter in him impossible.

Updated by rocko over 3 years ago

  • Tracker changed from Feature to Bug

Updated by Sickboy over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to ViperMaul
  • Target version set to 1.13
  • Component set to sys_repair

Updated by ViperMaul over 3 years ago

Please attach a repo mission. Thanks.

Updated by Myau over 3 years ago

ViperMaul wrote:

Please attach a repo mission. Thanks.

1. Ejecting
2. Try enter in plane
3. Try repair
4. Try enter in plane...

Updated by ViperMaul over 3 years ago

Thanks for the mission. It was hard to understand the English.

I was able to reproduce the issue. The mission helped me understand your viewpoint.
The expectation is the repair truck will install a fresh new ejection seat so that the plane can be 100% repaired and usable again by a player or AI.

Updated by rocko over 3 years ago

AFAIK it was done intentionally. Using the ejection seat would render the aircraft useless,when ejecting on ground level, due to destroyed canopy, seats missing, maybe other structural or system damage. Therefore it becomes locked.

Workaround would be to use setvariable on ejecting and adding a menu entry for the ACE repair trucks (re-install ejection seat) with some extended repair time that equals the time used for total destruction, maybe a bit more.

Updated by rocko over 3 years ago

  • Close Reason set to By design/Not a Bug

Updated by zGuba over 3 years ago

  • Category set to Script
  • Status changed from Assigned to Resolved
  • Assignee changed from ViperMaul to zGuba
  • % Done changed from 0 to 100
  • Close Reason deleted (By design/Not a Bug)

Done.

Under 120 seconds penalty ACE repair trucks will now be able to restore aircrafts ability to fly.

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 1.13 to 1.12

Available in the just released ACE for OA 1.12 RC5

Also available in: Atom PDF