Bug #24413

Structure orientation not transferred

Added by Fireball over 3 years ago. Updated about 3 years ago.

Status:Closed Start date:09/11/2011
Priority:Normal Due date:
Assignee:Suma % Done:

0%

Category:Multiplayer
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:84467
Reproduced by another DH user:Yes First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

It seems like the orientation of structures is not transferred over network to newer beta clients.

Observed

All structures are oriented North.

http://forums.bistudio.com/showpost.php?p=2020778&postcount=43

Expected

Structures should have their correct orientation as set by setDir.

Repro

- start attached mission in a host server
- join a second player/client
- place a hesco barrier on host client and compare heading on both clients
- place a hesco barrier on the second client (non-host) and they will always point North
- any other building has the same issue

CIT_24413_strucOrientation.Desert_E.7z (732 Bytes) Fireball, 09/11/2011 15:32

Client.jpg (222.2 kB) kju, 09/15/2011 04:18

Host.jpg (359.7 kB) kju, 09/15/2011 04:18


Related issues

related to ARMA2 Community Issue Tracker - Bug #24368: SetPos broken on dedicated servers Closed 09/10/2011
duplicated by ARMA2 Community Issue Tracker - Bug #24500: [84554] setDir is still broken Duplicate 09/13/2011

History

Updated by Fireball over 3 years ago

Ok, got a small repro mission, multiplayer only, two players/clients required (but DS not needed).

Updated by Fireball over 3 years ago

  • Assignee set to Suma

Updated by Fireball over 3 years ago

  • Description updated (diff)

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

While not exactly the same issue as #24368 (setDir network behaviour is different than setPos, setDir can only be executed for local objects), it is fixed in the same revision (84492)

Updated by kju over 3 years ago

  • Due date deleted (12/11/2011)
  • Status changed from Resolved to Feedback
  • Target version set to 1.60 BETA

Alwarren

SetDir definitely isn't (fixed), it's fine on the server player but the host has everything oriented north-south.

See: http://forums.bistudio.com/showpost.php?p=2021604&postcount=3

Updated by Suma over 3 years ago

Should be fixed in 84554

Updated by Suma over 3 years ago

  • Status changed from Feedback to Resolved

Updated by Fireball over 3 years ago

  • Status changed from Resolved to In progress

Ok, it's not entirely fixed, I just found out how to repro the unfixed situation:

- Start host client with attached repro mission
- Join second client
- Vote second client for commander (or simply let the second client build a defense)
- Select an MG Nest
- Orient the structure East and build it
- Check host client (first) and compare orientation

Host client structure will point North (wrong), while the second client's structure (who built it) points East (correct).

EDIT: Stumbled across #24501 using the same repro mission.

Updated by Suma over 3 years ago

  • Status changed from In progress to Resolved

OK. Another specific case of "static tank based weapons". As it was already too many special cases involved, I see it needs a more systematic approach. The new interpolation position handling now needs to be specifically enabled, which is done only by object types which implement the handling. This should hopefully settle the issue eventually in 84565

Still, testing with setPos/setDir on various object types would be probably a good think once this build is public.

Updated by kju over 3 years ago

Works for me using 84580 both on the DS and client for hesco barriers.

However using the static weapon it is not fixed here.

1) Using the host + client solution, the host's orientation does not get transferred to the client.
The clients orientation is transferred though. See attached screenshots.

2) Using a DS + 2 clients, the orientation is not transferred to the other client.

Suma which build did you fix this?

Updated by Suma over 3 years ago

As I wrote, it was fixed in 84565

This is really strange. I am unable to reproduce the problem on my end. There must be some other circumstance needed for reproduction (network latency? I am running DS and both clients all on the same computer, meaning virtually no latency).

Updated by kju over 3 years ago

Can someone else please test and confirm.

I also used a local DS and two clients on one computer.
I will try with our online dedicated server later today.

Updated by kju over 3 years ago

Ok found the problem. My second client was older than 84565 ...

Sorry for the confusion!

Can be set to resolved again.

Updated by Fireball over 3 years ago

  • Status changed from Feedback to Resolved

Cheers.

Updated by Suma over 3 years ago

  • Status changed from Resolved to Closed

Updated by kju about 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF