Bug #24370

Very loud breath

Added by Myau over 3 years ago. Updated almost 3 years ago.

Status:Closed Start date:09/10/2011
Priority:Low Due date:03/23/2012
Assignee:rocko % Done:

100%

Category:-
Target version:1.14
Component:sys_stamina Affected Version:
Close Reason:

Description

If I escape sharp sprint (LShift+W), beating very loudly on headphones breath.
This is feature?
I'm still a little from my chair about to fall from this sound. Sca-aary....
http://www.youtube.com/watch?v=TS7uTibmFN4

arma2oa_2011-09-10_13-06-48-80.jpg (204.7 kB) Myau, 09/10/2011 09:14

arma2oa_2011-09-10_13-06-57-68.jpg (201.8 kB) Myau, 09/10/2011 09:14

arma2oa_2011-09-10_13-07-04-77.jpg (199.8 kB) Myau, 09/10/2011 09:14

arma2oa_2011-09-10_13-07-13-17.jpg (199 kB) Myau, 09/10/2011 09:14

arma2oa_2011-09-10_13-07-16-53.jpg (200.1 kB) Myau, 09/10/2011 09:14

Bugrep.utes.pbo (1.5 kB) Myau, 09/10/2011 09:49

Bugrep_debug.utes.pbo - Bugrep with ACE_SYS_STAMINA_DEBUG=true (1.5 kB) Dystopian, 03/14/2012 23:26


Related issues

related to A.C.E. for OA - Bug #27673: Unarmed Civilians suffer too much fatigue gain Closed 01/10/2012 03/10/2012

Associated revisions

History

Updated by Myau over 3 years ago

This happened only with serious weith (~30 kg). In video 34 kg

Updated by Sickboy over 3 years ago

  • Status changed from New to Feedback

Updated by Myau over 3 years ago

Sickboy wrote:

http://ace.dev-heaven.net/wagn/Stamina ?

I did read... But it's more like a bug
Sound as I now fall unconscious, but in fact there is no fatigue. Just annoying sound harsh ...
Watch please video - it very short...

If i first press W, after push LShift, then will not this sound

Control setting:

Go forward: "W", "UP"
Run forward: "Left Shift + W"

Updated by Sickboy over 3 years ago

Might be related to the panic button; http://ace.dev-heaven.net/wagn/Stamina+howto
Shift+W is that evasive forward in your key settings?

Updated by Myau over 3 years ago

Sickboy wrote:

Might be related to the panic button; http://ace.dev-heaven.net/wagn/Stamina+howto
Shift+W is that evasive forward in your key settings?

M-m-m-m... maybe evasive... this is sprint (max speed run).
Or you mean ace setting? Now will see...
Just so did default in Flashpoint and i set so in Arma...

Updated by Sickboy over 3 years ago

I think if you're standing still and start running with shift+W (or perhaps double tap) you enter evasive sprint.

Updated by Myau over 3 years ago

Sickboy wrote:

I think if you're standing still and start running with shift+W (or perhaps double tap) you enter evasive sprint.

I can't find action in Ace setting with hotkey Shift+W....
How disable evasive sprint?

Updated by Sickboy over 3 years ago

It's not ACE Keys but game controls, we detect "Evassive Forward" action and use it as Panic mode in Stamina system.
Perhaps the behavior could be improved some, but you'll probably not run into it quickly with less weight.

Updated by Myau over 3 years ago

Sickboy wrote:

It's not ACE Keys but game controls, we detect "Evassive Forward" action and use it as Panic mode in Stamina system.
Perhaps the behavior could be improved some, but you'll probably not run into it quickly with less weight.

Please improve ....
Please set low volume panic sound. Panic sound very very loud....
I can record sound to show, if u want...

Updated by Sickboy over 3 years ago

Already have on the video.

Please attach your test mission with the ~30KG weight already on the soldier, so we just have to start moving to experience the issue.

Updated by Myau over 3 years ago

Sickboy wrote:

Already have on the video.

Please attach your test mission with the ~30KG weight already on the soldier, so we just have to start moving to experience the issue.

Strange, but i can't repeate old procedure bug...

New procedure:

Flee while unit is not tired and does not fall from exhaustion.
Sit down and let it good rest.
And then (preferably standing) abruptly start a sprint.
Breath came shooting out like ...

Updated by rocko over 3 years ago

  • Target version set to 1.12

Updated by Sickboy over 3 years ago

  • Tracker changed from Support to Bug
  • Status changed from Feedback to Assigned
  • Assignee set to Sickboy
  • Component set to sys_stamina

Updated by Sickboy over 3 years ago

  • Target version changed from 1.12 to 1.13

Updated by Sickboy over 3 years ago

  • Assignee deleted (Sickboy)

Updated by rocko over 3 years ago

  • Priority changed from Normal to Low

You probably run constantly in Evasive Forward, which is a slower animation than sprinting.

My controls are
W - Forward
Double W - Sprint
CTRL - W Evasive forward (I use evasive forward only to get up from prone to standing running, then continue to use Double W)

Cannot reproduce it with my settings.

Updated by rocko over 3 years ago

  • Due date set to 09/25/2011
  • Category set to Sound
  • Status changed from Assigned to Feedback
  • Assignee set to Myau

Updated by rocko over 3 years ago

  • Status changed from Feedback to Expired

Updated by Sickboy over 3 years ago

  • Target version deleted (1.13)

Updated by Myau over 3 years ago

rocko wrote:

You probably run constantly in Evasive Forward, which is a slower animation than sprinting.

My controls are
W - Forward
Double W - Sprint
CTRL - W Evasive forward (I use evasive forward only to get up from prone to standing running, then continue to use Double W)

Cannot reproduce it with my settings.

And what i can do for fix?
How disable evasive forward for test?
If see on vote, i am not alone, who have this problem...

Updated by Dystopian almost 3 years ago

Myau wrote:

Flee while unit is not tired and does not fall from exhaustion.
Sit down and let it good rest.
And then (preferably standing) abruptly start a sprint.
Breath came shooting out like ...

I can confirm too using "Bugrep.utes.pbo". I don't use evasive forward.

Updated by HomerJohnston almost 3 years ago

It would be very helpful if you could record a video of this, but first put this in the INIT line of your player:

ACE_SYS_STAMINA_DEBUG = true;

This will display more information on the side of your screen for us to examine.

Updated by Dystopian almost 3 years ago

I'll try to record a video tomorrow, but it really looks like panic button sound.
Repro with "Bugrep.utes" and ACE_SYS_STAMINA_DEBUG==true (pbo is attached):
  1. sprint to the eastern airfield end and ~150m back - unit falls down and can not run
  2. keep lying until Heartbeat == 50 (it takes ~4 minutes - I used 4x time speeding)
  3. stand up
  4. sprint 1-10m. Panic -> true, Breathing -> 5, Heartbeat -> 130.

Updated by HomerJohnston almost 3 years ago

That was enough for me to find it - no need for video anymore, thanks :)

Accurate reproduction:
1) Get character fatigue beyond class-limit and "pass out" ( >1000 fatigue for soldier)
2) Kneel or stand
3) Use "Evasive Forward" key to start sprinting
4) Panic mode is now engaged

Notable behaviour:
1) Panic mode cannot be engaged until you have "passed out" from normal exhaustion at least once
2) Panic mode can be engaged at any fatigue level, including fully rested
3) Panic mode doesn't even work - you still are forced prone at the same fatigue level (1000 for soldiers)

Bearing in mind the above, I would actually like to recommend just simplifying the stamina system by removing the panic feature. I think the base system has enough stamina already for emergency situations. Sickboy (or another dev), could I get your opinion/decision on this and I'll try to fix it as desired tomorrow night?

Updated by rocko almost 3 years ago

I will make some time this evening to check the issue again.

Updated by rocko almost 3 years ago

  • Due date changed from 09/25/2011 to 03/23/2012
  • Category deleted (Sound)
  • Status changed from Expired to In progress
  • Target version set to 1.14
  • % Done changed from 0 to 80

Updated by rocko almost 3 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 80 to 100

Updated by rocko almost 3 years ago

- Panic movement now only lasts for ~20 or 30 seconds, maybe I tune down again
- Panic resets current Fatigue values to 0 to allow building up 'new' fatigue
- Stamina FX are set to max values, max heartbeat, max breathing but no limited vision (will change though, once BIS enables PP effects again)
- Fatigue gained through panic movement is added after panic movement has stopped
- Panic fatigue gain is limited to 75% of CLSMAX fatigue, once reaching that value panic movement automatically stops
- If the 75% value is not reached, panic movement is automatically stopped after the 20/30 seconds timer
- Panic movement can only be triggered once in 10 minutes and only if player has collapsed once by normal stamina fatigue

- The eventhandler used is disabled once time or max level have been reached to prevent trigggering the panic movement while not panicking.

Updated by Sickboy almost 3 years ago

  • Status changed from Resolved to Closed

Available in latest update available on Six Updater.

Updated by Dystopian almost 3 years ago

Not resolved (updated on 29.03.2012). Repro with "Bugrep_debug.utes", "Evasive forward" key isn't set:
  1. sprint to the eastern airfield end until unit falls down and can not run
  2. keep lying as long as you want (I tried for 30 in-game minutes)
  3. stand up
  4. sprint 1-10m. Panic -> true, Breathing -> 5, Heartbeat -> 130.

Updated by rocko almost 3 years ago

  • Status changed from Closed to Resolved

Updated by Dystopian almost 3 years ago

Not resolved (updated on 03.04.2012). Same symptoms. I didn't say that right before unit falls down and can not run at item 1 of my repro Panic == true.

Updated by rocko almost 3 years ago

  • Assignee changed from Myau to rocko

Updated by rocko almost 3 years ago

  • % Done changed from 100 to 90

Updated by rocko almost 3 years ago

  • % Done changed from 90 to 100

Updated by Sickboy almost 3 years ago

  • Status changed from Resolved to Closed

Available as update on Six Updater.

Also available in: Atom PDF