Bug #24235

Physics problem in 84290 compared with 1.59.

Added by Danil-ch over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:09/06/2011
Priority:Normal Due date:
Assignee:Suma % Done:

0%

Category:Game physics
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:83110
Reproduced by another DH user:Yes First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Tanks have problems with collision (or physics?) when running over infantry they bounce also when they ram each other they can turn over or throw each other.

http://www.youtube.com/watch?v=osABxSaKIbs&feature=player_embedded

Repro

- Place a tank
- Place a crowd of soldiers in front of it
- Drive over the infantry
- Do NOT use the turbo (shift)

Observed

- Tank becomes stuck on infantry geometry

Expected

- Infantry or other objects should not affect the tank at all

arma2OA_1.59.avi (11.8 MB) Danil-ch, 09/06/2011 13:52

arma2oa_84290.avi (36 MB) Danil-ch, 09/06/2011 13:56

px.utes.pbo (30.9 kB) Danil-ch, 09/06/2011 13:56

arma2oa_83110.avi (9 MB) Danil-ch, 09/09/2011 08:51

CIT_24235_tankStuckOnInf.Desert_E.7z - OA only repro (3.6 kB) Fireball, 09/09/2011 12:48


Related issues

related to ARMA2 Community Issue Tracker - Bug #18070: Warrior flip on rock Assigned 03/05/2011 12/01/2011

History

Updated by Danil-ch over 3 years ago

Updated by kju over 3 years ago

Danil-ch please add some description.
One has no idea what this is about without watching the video.

Read: How to report a bug?

Updated by Danil-ch over 3 years ago

Tanks have problems with collision (or physics?) when running over infantry they bounce also when they ram each other they can turn over or throw each other.

Updated by Danil-ch over 3 years ago

Repro
1. start px.utes
2. try run over infantry or ram another tank (as on video).

Updated by silvercanary over 3 years ago

Related to Bug #18070 Warrior flip on rock

Updated by Fireball over 3 years ago

  • Description updated (diff)
  • Due date set to 09/20/2011
  • Status changed from New to Feedback

Isn't this a very old bug? Or which beta was the first where the problem was first seen?

Updated by Danil-ch over 3 years ago

83181 was the first where the problem was first seen.
Before in 83110 it was different but still much worse then 1.59.

Updated by Fireball over 3 years ago

  • First affected build set to 83110

What are the repro steps (to the mission or generally)?

Updated by Fireball over 3 years ago

  • Description updated (diff)
  • Status changed from Feedback to Assigned

Ok, thanks for the video.

Updated by Fireball over 3 years ago

  • Description updated (diff)

Updated by Fireball over 3 years ago

New repro for OA only

Updated by Suma over 3 years ago

  • Assignee set to Suma

Updated by admin over 3 years ago

  • First affected ArmA II version set to 1.60 BETA

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

Should be fixed in 85100

Note: this issue description mentions raming tanks as well, which is not included in the repro. I haved tested this briefly as well, not seeing any regressions against 1.59, but not having the exact repro I cannot be sure this really fixes the issue described.

Updated by kju over 3 years ago

  • Due date changed from 09/20/2011 to 10/14/2011
  • Target version set to Upcoming version

Danil-ch please provide a simple demo mission with exact repro steps. Ty.

Updated by Danil-ch over 3 years ago

Seems both issues was fixed in 85101.
I was not able to reproduce it anymore.

Updated by kju over 3 years ago

  • Due date deleted (10/14/2011)
  • Status changed from Resolved to Closed
  • Target version changed from Upcoming version to 1.60 BETA

ty

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF