Bug #24034

Remote objects in MP jump back when stopping

Added by Anunnaki over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:09/01/2011
Priority:Normal Due date:
Assignee:Suma % Done:

0%

Category:Multiplayer
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:A2 1.01.57631 (first final)
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

It is most noticeable:
Shortly after the remote object stops moving, it will jump/beam to adjust its real position.
It looks like constant periodical positional updates are coming in (perhaps about one every second), and correct real position of object on clients/server.
Every-time this occurs, you see jump/beam. When this happens during object is moving, you see jerky motion.

I am referring about problem described by user "alef", it is best shown on this video from him:
http://www.youtube.com/watch?v=yuNajxm7kNs&hd=1

I tested the following versions, in an effort to find out where the BUG occurred for the first time:
BUG A2OA 1.59.84260 (beta)
BUG A2OA 1.59.84156 (beta)
BUG A2OA 1.59.83780 (beta)
BUG A2OA 1.59.79384 (latest final)
BUG A2OA 1.51.71083 (first final)
BUG A2 1.10.80665 (latest final)
BUG A2 1.05.62017 (final)
BUG A2 1.01.57631 (first final)
OK! A1 1.18.0.5281(latest final)

So it looks like somewhere between latest Arma1 and first Arma2! I hope this helps little to localize BUG for BIS.

How I conducted testing:
Two clients, one as host=playerServer, second as client. All settings and config files are "default".
Just move with object (player) in first (host) window, and see result in second (client) window.
Phases:
1. On one signle powerfull computer, clean installation of A1, A2, A2OA (in separate folder). Each client in its own window. A1 was not possible to test in window, this phase was skipped.
2. On two powerfull computers. Clen installation of A1, A2, A2OA (in separate folder). Each client on its own computer in FULLSCREEN. Interconected with 100MBit FD LAN.

CIT24034.Desert_E.pbo - Testing mission for 2 clients. (1.7 kB) Anunnaki, 09/01/2011 18:02


Related issues

related to ARMA2 Community Issue Tracker - Bug #24014: Remote AI ground vehicles at large distance are not updat... Closed 09/01/2011
related to ARMA2 Community Issue Tracker - Bug #24015: Remote AI infantry at beaming back and forth while moving Closed 09/01/2011
related to ARMA2 Community Issue Tracker - Bug #1915: AI warping - especially at distance. Closed 06/08/2009
related to ARMA2 Community Issue Tracker - Bug #24252: Non-local objects (in MP game) are moving jerky. Closed 09/06/2011

History

Updated by Anunnaki over 3 years ago

  • Subject changed from Shortly after the remote (non local object) stops moving, it will jump to adjust its position. to Shortly after the remote (non local object) stops moving, it will jump to adjust (fix) its position.
  • Description updated (diff)

Updated by Anunnaki over 3 years ago

  • Description updated (diff)

Updated by Anunnaki over 3 years ago

Updated by Anunnaki over 3 years ago

  • Description updated (diff)

Updated by Anunnaki over 3 years ago

  • Description updated (diff)

Updated by Sickboy over 3 years ago

Probably introduced between 1.0 and 1.05, I think someone talked about 1.02 once.
Otherwise, things have been pretty much bad even in A1. I dont remember if it was bad in OFP.

Updated by Sickboy over 3 years ago

Ode to you for going through all the versions!
Looking forward to MP love in 1.61 beta ;)

Updated by Anunnaki over 3 years ago

  • Description updated (diff)

Updated by Anunnaki over 3 years ago

  • Description updated (diff)

Updated by Anunnaki over 3 years ago

  • Description updated (diff)

Updated by Anunnaki over 3 years ago

  • Description updated (diff)

Updated by Anunnaki over 3 years ago

  • Description updated (diff)

Updated by kju over 3 years ago

good job

Updated by Anunnaki over 3 years ago

Meanwhile I found work-around to this issue (it is not definitive solution, just temporary work-around):

All clients and server/host must add to ArmA2OA.cfg following line:
MinErrorToSend=0.00050000002;

I strongly recommend, than users should put also following lines there (to prevent flooding servers):
MaxMsgSend=10; // increase this for dedicated server to 128
MaxSizeGuaranteed=1400;
MaxSizeNonguaranteed=1400;
MinBandwidth=450000; // change this to your line upload speed (example is for 450kbps upload line)
MaxBandwidth=512000; // cahnge this to your line maximum upload speed (example is for 512kbit upload line)

Remember, that only clients with those settings can be seen by other smooth!

Updated by kju over 3 years ago

Hm

1)
MinErrorToSend=0.0005; ups the update frequency.
Using the value both for the client and a DS on the same pc,
one can see the units' positions updated more frequently.
But the back and forth beaming (of remote AI) remains.

Default is said to be 0.01.

2)
We need the confirmation from BI that network values actually have an effect
when set for a client.

3)
As said by many people many times we need more specific information,
and better analysis on the network values.

Updated by kju over 3 years ago

From what I can tell, it is a bug in the network engine for sure and not a bad network configuration (default) value.
As said, at least to me, your suggestion only improves it somewhat, but does not fix the actual problem at all.

Sure your testing is certainly very valuable and commendable, but in the end of the day BI has to provide us
with the specific information. Relying on rough analysis is not the prefer way.

Updated by Anunnaki over 3 years ago

  • Reproducible for you changed from No to Yes
  • First affected build set to A2 1.01.57631 (first final)

Updated by Anunnaki over 3 years ago

  • Subject changed from Shortly after the remote (non local object) stops moving, it will jump to adjust (fix) its position. to Remote objects motion in MP is jerky (affected A2/A2OA, not affected A1) ... shortly after the remote object stops moving, it will jump/beam to adjust its real position.

Updated by Anunnaki over 3 years ago

  • Subject changed from Remote objects motion in MP is jerky (affected A2/A2OA, not affected A1) ... shortly after the remote object stops moving, it will jump/beam to adjust its real position. to Remote objects motion in MP is jerky. Affected A2/A2OA, not affected A1. There is work-around ...
  • Description updated (diff)

Updated by Anunnaki over 3 years ago

Consequence also here: http://dev-heaven.net/issues/2279

Updated by Fireball over 3 years ago

  • Due date set to 12/01/2011
  • Status changed from New to Assigned
  • Priority changed from High to Normal
  • Affected ArmA II version changed from Please select... to 1.60 BETA

BIS will set priority, but I agree it would be nice to see this fixed, whatever is the real problem now; I lost track of it, 3 tickets on the same subject.

Updated by Suma over 3 years ago

Please, leave the philosophical / marketing / behind the scenes discussion out of the tracker issues (you can use forum for it). If the tracker is to be usefull, the issues need to strictly be on the topic and contain only the stuff really needed to work on the bug. Once there is a good repro (which seems to be the case in this issue, as the description is good), do not add any more observations, discussions or theories to it, as it clutter the issue, making it longer and making finding relevant and important information harder.

The only thing I am missing in the description is the repro mission used in A1 for comparison.

Updated by Suma over 3 years ago

  • Subject changed from Remote objects motion in MP is jerky. Affected A2/A2OA, not affected A1. There is work-around ... to Remote objects motion in MP is jerky in A2/A2OA

Updated by Suma over 3 years ago

Shortly after the remote object stops moving, it will jump/beam to adjust its real position.

The problem was caused by fine movement starting/stopping control introduced in A2, which was not transferred correctly in MP.

Fixed in 84285

Updated by Fireball over 3 years ago

  • Status changed from Assigned to Resolved
  • Target version set to Upcoming version

Updated by Anunnaki over 3 years ago

I have tested 84290 and problem "Shortly after the remote object stops moving, it will jump/beam to adjust its real position"
is solved. Great thanks.

There is still some jerky motion for some objects (for example when remote AI are running fast to side from observer point of view), but that is another issue.
I have created new ticket here http://dev-heaven.net/issues/24252 .

Updated by Suma over 3 years ago

  • Status changed from Resolved to Closed

Updated by Suma over 3 years ago

  • Subject changed from Remote objects motion in MP is jerky in A2/A2OA to Remote objects in MP jump back when stopping

Updated by Anunnaki over 3 years ago

This BUG reappeared back in build 84467.
More details here: http://dev-heaven.net/issues/24252

Updated by Fireball over 3 years ago

  • Status changed from Closed to Feedback
  • Assignee set to Suma

Updated by kju over 3 years ago

See also the comment here.

It might not be the same source, yet visually it seems the same effect.

Updated by Anunnaki over 3 years ago

Tested 84527, looks fixed.

Updated by Fireball over 3 years ago

  • Due date deleted (12/01/2011)
  • Status changed from Feedback to Resolved

Updated by kju over 3 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by Suma over 3 years ago

  • Status changed from Resolved to Closed

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF