Bug #24015

Remote AI infantry at beaming back and forth while moving

Added by kju over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:09/01/2011
Priority:Normal Due date:
Assignee:Suma % Done:

0%

Category:Multiplayer
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs
Remote AI infantry is beaming back and forth while moving.
Videos:

While local/non remote AI is fine:

Exp
Even the movement of remote AI infantry should be smooth.

Repro
  • DS
  • Connect as client
  • Watch the AI infantry move at different distances
  • Notice how the units beam back and forth

VisualStateInterpolationSP.Zargabad.pbo (22.5 kB) kju, 09/01/2011 06:35

VisualStateInterpolation2.Zargabad.pbo (24.9 kB) kju, 09/22/2011 06:21


Related issues

related to ARMA2 Community Issue Tracker - Bug #24034: Remote objects in MP jump back when stopping Closed 09/01/2011
related to ARMA2 Community Issue Tracker - Bug #24014: Remote AI ground vehicles at large distance are not updat... Closed 09/01/2011
related to ARMA2 Community Issue Tracker - Bug #23555: Interpolation/Animation changes bugged in MP Closed 08/18/2011
related to ARMA2 Community Issue Tracker - Bug #1915: AI warping - especially at distance. Closed 06/08/2009

History

Updated by kju over 3 years ago

While the SP part is now fixed with the interpolation.
In MP the situation has not yet improved unfortunately.

Updated by Suma over 3 years ago

  • Status changed from New to Assigned
  • Assignee set to Suma

Updated by kju over 3 years ago

[84464] Improved: MP: Remote units should move a lot smoother.

Infantry is considerably improved - good job!

However a couple of issues still remain:
  • Some units get a stand animation while moving for a short moment, get still dragged on in the standing anim/stance and change back to run/sprint anim soon after.
  • Especially at distance the "rubber banding" issue can be observed very clearly now. This means an unit gets dragged considerably forward every once in a while.
  • Overall the infantry units seem to beam back a little constantly - it is not much, yet the movement is not fluid.
  • At distance units flicker visually a lot. Yet this is probably not related and #16231.

Updated by kju over 3 years ago

Here is a video of the latest beta with planes:
http://www.youtube.com/watch?v=2DLbHHonSOY

The beaming is gone, yet one can see there also the slight back and forth movement.

Updated by kju over 3 years ago

No changes in 84527 as far as I can tell.

Updated by kju over 3 years ago

With 84580 at mid distance it is a lot better.

That said you still have
  1. at few cases units beam from one position to another with a significant jump (several meters) at times (distance of 500 - 1000 meters)
  2. you do not get the impression that a group of infantry moves smoothly as it seems a bit disconnected from the animation
  3. at large distance (1000 to 2500) you have significant infantry movement lag - means some units of a group are stuck in their animation but do not move and a few seconds later beam to the actual position

Updated by Anunnaki over 3 years ago

I can confirm what KJU have posted here.

Updated by kju over 3 years ago

A lot (more) rubber-banding again in 84689.
Issues 3 of comment #6 still applies. 1&2 seems to be replaced by the rubber-banding.

Rubber-banding:
AI is floating back and forth (too slow movement vs animation and actual speed,
and a little later dragged back in position).

Updated by jaynus over 3 years ago

This is also confirmed to occur on players in dedicated/MP as well. Not just AI.

Additionally, they rubber band when stationary, not just moving.

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

The distant infantry movement should be significantly improved in 84739. Assuming resolved, if anyone disagree, post your observations and change state back to Assigned.

Updated by Sickboy over 3 years ago

  • Target version set to Upcoming version

Updated by kju over 3 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by kju over 3 years ago

  • Status changed from Resolved to Feedback

Unfortunately I still have issues with 84749 for both DS and client.
While for closer infantry (<1000 meters) it seems improved, it is still visible every once in a while.

However for the far (1000-2000 meter) and especially the very far (~2500 meters) infantry
I still get significant issues. Basically the three points from note 6:

  1. At few cases units beam from one position to another with a significant jump (several meters) at times (distance of 500 - 1000 meters)
  2. You do not get the impression that a group of infantry moves smoothly as it seems a bit disconnected from the animation
  3. At large distance (1000 to 2500) you have significant infantry movement lag - means some units of a group are stuck in their animation but do not move and a few seconds later beam to the actual position

Overall it feels like the position updates are sent much too seldom.
Like only every 5-15 seconds for units at large distance. The interpolation leads to large beaming
or rubber banding to correct the unit to the actual position.

Even at closer distances either the position update frequency is too low or the interpolation
system itself has issues. I am unable to judge that though.


Visually the result is okay at close distance but not fluent either.
At distance the visual result is not good unfortunately.

Gameplay wise at close distance I guess it is fine.
At large distance as a sniper or with static weapons/vehicle weapon
the beaming is certainly not satisfying.

I will refresh my experience with 1.59 later tonight and provide feedback.

Updated by kju over 3 years ago

Done the 1.59 situation analysis.

At very large distances 2000-2500+ not much has change from what I can tell.
There the fundamental problems seems to be way too few position updates.
At least you can observe both in 1.59 and 84749 units running on the spot
and getting beamed forward, back to the actual position, in large chunks.
Overall the movement of infantry is/looks very wrong there.

At distances of 1000 to 2000 meters to change from 1.59 is that the unit
no longer zap very frequently from actual position A to actual position B a moment later,
but with the interpolation in 84749 the animation is simulated and smoothed.
This results though in the rubber banding and wrong interpolation (assumed vs actual position).
So it is only a visual tweak rather to address the actual problem.

Which is to be expected and intentional. After all there was no talk about network engine changes.
This seems to be confirmed that you can combine the new betas even with 1.59 clients/server.

Don't get me wrong the interpolation is useful and a good improvement.
Still to me it seems the fundamental problems are to be found elsewhere.

From what I can tell it is:
  1. Too few position updates - especially at large distances
  2. Local position predication/expected movement speed not what is actually happening on remote
  3. Maybe some issues in the network system itself, but that's just a wild guess and I have no means to judge that

Especially 2 might be worth to look into I think.
We have a few tickets that show that both animation speed and movement speed of remote units are not correct.
For some reason local vs remote is different.

See: Bug #13360: Multiplayer animations played at SLOWER speed than they should be

Unfortunately I am unable to find the ticket about "formation cohesion/different unit speed in a formation".
Basically what I can observe is the mission here is:
  1. The group leader sprints (or runs?) straight in on direction without a stop.
  2. The units in his formation change to run (or walk?) at times.
  3. Still the distance between the leader and the units does not change (significantly).
  4. Either the visualization/display is wrong or the units can run faster somehow to catch up quickly again.

Updated by kju over 3 years ago

I've tried to come up with some sensible "repro" and logging to show
the inconsistencies in unit speed and animation of client vs server.

See Bug #24758: AI infantry has different speed and animation on the server/local vs the remote clients

Updated by kju over 3 years ago

Here is a v2 version of the test mission.

The units from 1500 to 2500 meters were used the world area.
So in the infinite terrain area. To remove a potential factor,
the units were moved to a different location.

That said I can still observe the said issues in the v2 version.

Updated by kju over 3 years ago

  • First affected ArmA II version set to 1.60 BETA

Here are a couple of videos showing the different problems Suma:

These are without MinErrorToSend set (aka MinErrorToSend at the 0.01 default).

With MinErrorToSend at 0.001 these are basically gone from what I can tell so far.
Now if to simply change the default of MinErrorToSend to 0.001 is the solution I am unable to judge.

Updated by Fireball over 3 years ago

  • Status changed from Feedback to Resolved

Setting Resolved according to http://dev-heaven.net/issues/24014#note-26.

Updated by kju over 3 years ago

For me the result is very satisfying. Can be closed IMO.

Updated by Suma over 3 years ago

  • Status changed from Resolved to Closed

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF