Bug #23754

CreateVehicle'd Missiles/Shells/Bombs lack collision (pass through objects)

Added by Sickboy almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:08/24/2011
Priority:High Due date:12/24/2011
Assignee:Dwarden % Done:

100%

Category:Weapons
Target version:-
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

http://forums.bistudio.com/showpost.php?p=2008647&postcount=65

This behaviour was not the case before the betas

bug_missiles.utes.rar (1.2 kB) Sickboy, 08/24/2011 12:46


Related issues

related to ARMA2 Community Issue Tracker - Bug #22863: AttachTo causes the object to lag Closed 07/27/2011

History

Updated by Sickboy almost 4 years ago

  • Subject changed from CreateVehicle'd Ammo passes through objects to CreateVehicle'd Missiles pass through objects

Updated by Sickboy almost 4 years ago

  • Subject changed from CreateVehicle'd Missiles pass through objects to CreateVehicle'd Missiles lack collision (pass through objects)

Updated by Sickboy almost 4 years ago

Repro mission by Mandoble

Updated by zGuba almost 4 years ago

  • Due date set to 12/24/2011
  • Category set to Weapons
  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Priority changed from Normal to High

Updated by Mandoble almost 4 years ago

The same happens with shells and bombs.

Updated by Sickboy almost 4 years ago

  • Subject changed from CreateVehicle'd Missiles lack collision (pass through objects) to CreateVehicle'd Missiles/Shells/Bombs lack collision (pass through objects)

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

Caused by 83597 (#22863)

Fixed in 84121

Updated by Sickboy over 3 years ago

It seems this problem is indeed fixed for mentioned types, but still exists for certain types of either CfgAmmo or CfgVehicle.
At least when using createVehicleLocal. Details hopefully coming days.

Updated by zGuba over 3 years ago

So far I have made little video showing the results of the issue. Worth noting that it occurs in MP environment only.
http://www.youtube.com/watch?v=Ae8Zj7sjuKo

There is problematic ammo class that is used for our laser designator replacement (needed due to #12025)
http://browser.dev-heaven.net/cfg_ammos/config/ACE_MissileGuidance_LaserPulse?version=50

Updated by Sickboy over 3 years ago

Repro zGuba?

Updated by zGuba over 3 years ago

Repros time. Working on it

Updated by admin over 3 years ago

  • First affected ArmA II version set to 1.60 BETA

Updated by zGuba over 3 years ago

  • % Done changed from 0 to 100

This one is okay. I think about reporting another issue regarding ACE laser.

Updated by Fireball over 3 years ago

  • Status changed from Resolved to Closed

Closing as per conversation with zGuba.

Also available in: Atom PDF