Bug #2366

No revealing/locking with missiles on turrets

Added by TeRp about 6 years ago. Updated over 5 years ago.

Status:Closed Start date:06/28/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Gameplay
Target version:1.05.62017
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

ok, this one is rather hard to describe, yet this has been a bug since ArmA.
Let's try..

Place an AH1 with you being the gunner and an enemy tank somewhere next to you.
Now switch to the gunner optics and select the Hellfire missiles, then and try to reveal and lock on the target by moving the crosshair on the enemy tank and using the right mouse button ("Lock or Zoom" / "Reveal" in control options); it won't work.
Locking on the target is only possible by using the "Next Target" key (typically tab); and that only works if the target has been revealed earlier.

This makes using mast mounted sights, which are quite common (not only on air vehicles) pretty much useless, as you can't hide behind a hill and reveal / lock targets from there.
The only solution to this problem right now is adding a (machine) gun like weapon to the specific turret, that moves with the mast mounted sight. however, there's a lot of vehicles that don't have such a gun (e.g. the Kiowa, Apache, Tiger, ...) and thus this solution is not practicable.

NoRevealinglockingWithMissilesOnTurrets.utes.7z (687 Bytes) kju, 01/04/2010 17:49


Related issues

related to ARMA2 Community Issue Tracker - Bug #2842: BTR-90 Konkurs 9M113 commander targeting and firing problem Rejected 07/15/2009 08/24/2009

History

Updated by Fireball about 6 years ago

  • Due date set to 09/28/2009
  • Category changed from Gameplay to Controls
  • Status changed from New to Assigned
  • Affected ArmA II version changed from 1.02.58134 to 1.04 BETA
  • Maxmem parameter set to Not set
  • Difficulty set to Not set

Yes, that's indeed a controls problem - the mark target/zoom button (default: hold secondary mouse) should not zoom out when in a zoom vision of a vehicle.

Sorry, I mixed something up here.

Updated by kju about 6 years ago

  • Category changed from Controls to Gameplay

It seems a more gameplay topic and not related to controls.
Missile type weapons can not direct click lock.

This could be even by design. So only tab lock for missiles (for whatever reason).

Updated by kju about 6 years ago

Edit:

The source is actually very different.

RMB direct click lock is based on the cursor position.

For helicopters the cursor for non main weapons is fixed and cannot be moved,
even if it seems different while looking through the topics - the cursor position
is center and fixed.

So RMB lock only works if the target is in the center of the cursor.

Updated by zGuba almost 6 years ago

  • Due date changed from 09/28/2009 to 11/28/2009
  • Operating system deleted (WinXP 64 bit)
  • Affected ArmA II version changed from 1.04 BETA to 1.04.59026
  • Reproduced by another DH user set to Yes

Updated by Dwarden almost 6 years ago

  • Assignee set to Dwarden
  • CPU set to Please specify!

Updated by Dwarden over 5 years ago

  • Status changed from Assigned to Resolved

Updated by Fireball over 5 years ago

  • Due date changed from 11/28/2009 to 01/28/2010

Updated by Fireball over 5 years ago

  • Target version set to 1.05.62017

Updated by kju over 5 years ago

Seems to work fine here.
RMB works.

Compared to OFP the problem is that you have no cursor
during the ALT + mouse view.

Also available in: Atom PDF