Bug #23620

Ambient Civilians lags the game a lot and doesnt work!!!

Added by klubargutan about 4 years ago. Updated about 4 years ago.

Status:Closed Start date:08/20/2011
Priority:Normal Due date:08/23/2011
Assignee:Sickboy % Done:

100%

Category:Config
Target version:1.12
Component:c_vehicle Affected Version:
Close Reason:

Description

ok, i had version 497, had ambient civilians and civilian vehicles on map, chernarus, with code this setvariable ["debug", true, true] in both idnit, everything worked fine, no problems, no lags...now, in version 501, when i run mission, it first 5-10 seconds works good, civilians are here and no lags are here, but then it starts lag so much, 1-2 second lags...and civilians starts to disappear...even without that init code it didnt help...then i restarted game with ace, acex, acex_pla, acex_sm, aces_usnavy and acex_ru
turned off, everything worked properly...

_Ambient_Civlians.Chernarus.7z (749 Bytes) Sickboy, 08/21/2011 07:53

_Ambient_Civlians.Chernarus.rar (748 Bytes) klubargutan, 08/21/2011 12:37

ace_c_vehicle.pbo (480 kB) Sickboy, 08/21/2011 15:45


Related issues

related to A.C.E. for OA - Bug #23619: ACE breaks ALICE Closed 08/20/2011 08/21/2011

Associated revisions

Revision 0027e8cb
Added by Sickboy about 4 years ago

~ FIXED: CargoIsCoDriver property on Car class causes heavy FPS problem, e.g experienced with Civilian/Animal modules. fixes #23620

History

Updated by klubargutan about 4 years ago

  • Priority changed from Normal to Immediate
  • Target version set to 1.12

Updated by rocko about 4 years ago

  • Priority changed from Immediate to Normal
  • Target version deleted (1.12)

Yo

You must be new to this. Check this first: http://ace.dev-heaven.net/wagn/Bug_reporting_feedback_and_suggestions
And also this: RPT

Additionally do not set priority and/or target version, thanks in advance.

Updated by rocko about 4 years ago

  • Due date set to 08/23/2011
  • Status changed from New to Feedback

Updated by Sickboy about 4 years ago

  • Assignee set to Sickboy

A repro mission would be optimal, so we work from a common base.

Updated by Sickboy about 4 years ago

Cannot reproduce with attached repro mission, please supply repro mission and steps that make us experience the issue.

Updated by klubargutan about 4 years ago

rocko wrote:

Yo

You must be new to this. Check this first: http://ace.dev-heaven.net/wagn/Bug_reporting_feedback_and_suggestions
And also this: RPT

Additionally do not set priority and/or target version, thanks in advance.

i read it, but yep, im new...i didnt know how to place file with "error" etc... ill do it

Updated by klubargutan about 4 years ago

Sickboy wrote:

Cannot reproduce with attached repro mission, please supply repro mission and steps that make us experience the issue.

your mission doesnt lag for me, thats good... ill make mine mission where it was laggy, i deleted it before, so i will make it again, stand by

Updated by klubargutan about 4 years ago

i added to mission ambient animals...that made it laggy also, i forgot posting that it happens with animals and civilians together...im placing that mission what i made-it has same name as yours

Updated by Sickboy about 4 years ago

  • Target version set to 1.12
  • % Done changed from 0 to 20

Thanks!
I am able to reproduce the problem. The lag is really bad, in my case like completely locked up, with maybe a frame processing every x seconds :)

Tracing...

Updated by Sickboy about 4 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 20 to 100

Updated by Sickboy about 4 years ago

Problem was caused by CargoIsCoDriver set in the Car base class. Should further inspect the configs for wrong CargoIs*** family properties.
Fix attached.

Updated by Sickboy about 4 years ago

  • Category set to Config
  • Component set to c_vehicle

Updated by klubargutan about 4 years ago

Sickboy wrote:

Problem was caused by CargoIsCoDriver set in the Car base class. Should further inspect the configs for wrong CargoIs*** family properties.
Fix attached.

thanks, gonna try it

Updated by rocko about 4 years ago

  • Status changed from Resolved to Closed

Available in ACE for OA 1.12 RC2

Also available in: Atom PDF