Bug #23490

[83500 - 83657] Helicopters refuse to proceed to next waypoint when enemy anti-air threats nearby

Added by icecain over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:08/15/2011
Priority:Normal Due date:12/15/2011
Assignee:Suma % Done:

0%

Category:AI Issues
Target version:-
Affected ArmA II version:1.60 BETA First affected build:83500
Reproduced by another DH user:Yes First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Observations
  • Helicopters get stuck and refuse to proceed to next waypoint when the crews detect enemy anti-air threats.
  • Waypoint behaviour is set to "Careless" and "Never fire".
Expected behaviour
  • Helicopters should finish their designated routes.

The bug started from beta 83500, the last working version is 83363.
Retro is in the attached file.

Test2.utes.7z - Retro mission file (1.1 kB) icecain, 08/15/2011 18:54

History

Updated by icecain over 3 years ago

Updated by kju over 3 years ago

  • Assignee set to Dwarden
  • Target version deleted (1.60 BETA)

Updated by zGuba over 3 years ago

  • Due date set to 12/15/2011
  • Status changed from New to Assigned
  • Reproduced by another DH user changed from No to Yes
  • Reproducible for you changed from No to Yes

Updated by Suma over 3 years ago

  • Assignee changed from Dwarden to Suma

Very good report, nice and easy to follow repro, tickets contains all information needed and nothing more. Should be a pleasure to fix.

Updated by Suma over 3 years ago

  • Status changed from Assigned to Feedback

The difference between the "last working" and "not working" version is the changed skill behaviour. The units have lower effective skill after bug #4483 was fixed, therefore they are now more prone to "flee". If you need to prevent fleeing, use this allowFleeing 0 in the heli init line.

Updated by Sickboy over 3 years ago

  • First affected build set to 83500

Updated by icecain over 3 years ago

Since "Most units had maximum skill, ignoring values set in the mission" before [83390],
I just tried the repro mission in [83657] (recruit level, skillFriendly = 1, maximum skill value in editor for the helicopter), and the heli flees no more, which is what I expect.
"allowFleeing 0" with default skill value also work well in regular level.
Thanks, Suma.

Updated by Suma over 3 years ago

  • Status changed from Feedback to Closed

Updated by admin over 3 years ago

  • First affected ArmA II version set to 1.60 BETA

Also available in: Atom PDF