Bug #23388

Helicopters don't detect infantrymen (AA units especially) from acceptable range

Added by fabrizioT almost 4 years ago. Updated about 3 years ago.

Status:Closed Start date:08/12/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Config
Target version:1.62.95248
Affected ArmA II version:1.60.87580 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Repro attached.

OBSERVED

  • See the BLUEFOR infantryman detecting the helicopter at about 500-600m.
  • See the OPFOR helicopter (skill=1) detecting the enemy BLUFOR infantryman only when at extremely close distance (around 50-100m.)
  • Now ake the BLUFOR infantryman as AA unit and repeat mission: see the heli easily targeted due to its missing enemy detection;

EXPECTED

  • The helicoper should be able to detect infantry from larger distance in order to avoid being easily downed by AA infantrymen.

bug_heli_cantsee.utes.zip (1.4 kB) fabrizioT, 08/12/2011 17:14

23388.utes.7z (1.7 kB) kju, 08/12/2011 18:03

23388b.utes.7z (1.8 kB) kju, 01/16/2012 07:11

History

Updated by kju almost 4 years ago

  • File 23388.utes.7z added
  • Reproduced by another DH user changed from No to Yes

Here is an improved version of it.

Changes
  • Replaced infantry with AA infantry without ammo
  • Repositioned the AA infantry a little
  • Moved the heli WP further away (otherwise the gunner could not see the inf due to bad cockpit angle when stopping)
  • Shows in chat also the knowsAbout value of heli vs AA inf (and other way round)
  • Radio ALPHA/BRAVO offer camera view of the heli
Obs
  • 50% the cases the chopper does not notice the AA inf at all
  • If it does, it does after it passed the infantry - very strange (eyes in the back?!)
  • KnowsAbout value of the heli about the AA infantry remains low though (0.4-0.6)
  • The AA infantry late reaction on the heli is also questionable

Updated by fabrizioT almost 4 years ago

Thanks kju

Updated by Suma almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Suma

Updated by kotov almost 4 years ago

nice bug - but what situation in real life detect aa infantry ?
These is no weapons or system today able to do it.You can spot emission or start of rocket - but this feature looks like joke.sorry.

Updated by kju almost 4 years ago

kotov the technology is called human eye..
Or even optics that provide zoom in this case.

Once again kotov you show that you only waste our and your time.
If you are not willing to spend a few minutes to look into a ticket,
you better not post and not participate in the CIT.

Updated by CarlGustaffa almost 4 years ago

I think it's best to leave it pretty much as it is. Maybe tech (FLIR) and/or unit (gunner) related but no magical eyes on the pilot without aid. In my mission I simulate simple information sharing. Means that if ground units spot you, they report you to other groups. Depending on your threat level, an MI-24 may choose to engage or ignore you. But put him into suppresFor (think of it as simple AI CAS mission), and you'll regret you ever revealed yourself to the ground unit ;)

Updated by fabrizioT almost 4 years ago

@CarlGustaffa:

Did you run the repro?
We have helicopters flying over AA infantrymen heads without caring, i would prefer not leaving that as is.

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

Currently a soldier can detect enemy soldier at approx. 200-250 m, while a hovering helicopter needs to get under 100 m to detect the same enemy. Given the fact there is a gunner in the helicopter, which has a single task of tracking enemies, and even has optics on his weapons he can use, this looks like a bug to me.

The debugging shows the problem is caused by a config value "sensitivity", which is 3 for soldiers, but 1 for most other vehicles, meaning the vehicles need to get 1.7x (sqrt 3) closer to achieve the same detection.

The sensitivity value is increased to 2.5 in 87768 config. With this value the hovering heli open fire against enemy targets from 210 m.

Updated by Fireball over 3 years ago

  • Category changed from AI Issues to Config
  • Target version set to 1.61 BETA

Updated by Suma over 3 years ago

  • Assignee changed from Suma to kju

Can we confirm it now works reasonably well?

Updated by Sickboy over 3 years ago

Not according to http://forums.bistudio.com/showthread.php?p=2084638#post2084638
hopefully repro mission/details will be provided.

Updated by Fireball over 3 years ago

  • Status changed from Resolved to Feedback
  • Assignee changed from kju to fabrizioT

Updated by kju over 3 years ago

  • Assignee changed from fabrizioT to Suma

Updated by Suma over 3 years ago

  • Assignee changed from Suma to kju

Updated by kju over 3 years ago

  • Affected ArmA II version changed from 1.60 BETA to 1.60.87580
I can see no difference in both provided repro missions here.
  1. In the one of fabrizioT the Mi24 gunner only sees the AI infantry at 50 meter distance.
  2. In mine the Mi24 mostly flies past without noticing the AI infantry at all or only when the Mi24 is already flown by and is 250-300 meter away.

Updated by kju over 3 years ago

Even with the different sensitivity value for the chopper/All I cannot see the chopper notice the infantry earlier :(
The chopper/AI gunner only detects the infantry when he flew past it - at a distance of 150 to 250 meter away from him again.

Can someone else please test and see when the chopper detects the infantry from him please.

Made also a threat in the BIF to get feedback:
http://forums.bistudio.com/showthread.php?t=130070

Updated by kju over 3 years ago

Same test mission, yet it also logs the accuracy value to the rpt, like:

Version 1.60.88027
["Mi24_P",2.5]
["USMC_Soldier_AA",3]
["All",2.5]

Updated by Suma over 3 years ago

The repro includes a soldier on the airport concrete. Placing soldier on a grass would make it more representative. (When evaluating AI spotting, the background texture color / structure is not considered.)

Debugging shows the soldier detection happens when it is 150-200 m from the heli. Given the helicopter speed and position, this does not say unreasonable to me. There is a delay simulating information analysis and response time. In this case, the delay is computed as 2.1 sec. This means when the target is recognized, the heli is already past it. Again, this does not seem unreasonable to me. I have placed myself as the playable gunner in the heli to see whan I am able to notice and identify him a lot earlier and the above seems reasonable to me.

When I have reported the issue as resolved in note 8, I have performed a testing with a hovering helicopter, which is where I achieved the 200 m detection distance.

Updated by kju over 3 years ago

Fair enough.

Personally I am happy with the situation before the change and
also with the higher sensitivity value for class All and therefore most vehicles.

I was just expecting a more noticeable difference by the change. That's basically all.

Feel free to set it as resolved/closed.

PS: The AI infantry is on the airport concrete to be most visible and not have clutter/concealment interfere.

Updated by Suma over 3 years ago

  • Status changed from Feedback to Resolved

OK. Marking as resolved. If anyone has a repro which he thinks shows a behaviour where AI heli is not spotting infantry as it should, feel free to reopen.

Updated by Fireball about 3 years ago

  • Status changed from Resolved to Closed
  • Assignee deleted (kju)

Closing down since no objections surfaced.

Updated by kju about 3 years ago

  • Target version changed from 1.61 BETA to 1.62.95248

Also available in: Atom PDF