Bug #23207

New UAV stops Shift-Click and Alt-Click from working if you do not use the context menu

Added by Telson over 3 years ago. Updated over 2 years ago.

Status:Closed Start date:08/07/2011
Priority:High Due date:
Assignee:Tupolov % Done:

0%

Category:Script
Target version:MSO v4.55
Component:CAS Reproduced by another DH user:No
Close Reason: I am using some Mods:No
Affected Version:

Description

After you use the new UAV scripts( very nice I might add ) you can no longer place JIP markers on the map.

The option returns once you leave and rejoin the mission.

History

Updated by Telson over 3 years ago

Its both Markers and Tasks that no longer work after you use UAV.

Updated by Tupolov over 3 years ago

  • Category set to Script
  • Assignee set to Tupolov
  • Target version set to MSO v4.6

Can you post repro steps?

Is this a dedicated server?

Updated by Telson over 3 years ago

Yes its a dedicated server.
You can place markers and taskes when mission starts.
All other support assets work fine.
If you call in the UAV it gives the count down and it puts you in te UAV as it should.
Onece UAV is finished with ( Escape Key ) you go back to infantry mode and JIP markers and Tasks no longer work.

I think the problem is with the click on map part, I had the same problem with Bon Assets when I tried to use it with the MSO.

I have Norrin Revive on my MSO but as I was at base and did not get injured or die Im sure thats not the issue.

Updated by boxter over 3 years ago

I also had that same problem after calling Air-support for the C-130J. Hotkeys [Alt] or [Alt]+[Shift] and MapClick did no longer work. The menu-items on the self-interact menu despaired. After rejoining MSO on the dedicated server. The menu-items ware still gone - But I did get the dialogues up using Hotkey + MapClick did work.

I was running the ACE version with no changes to the script-files.

Update: Today, after sleeping and more important returning to the MSO (computer turned off while sleeping), The JIP-Markers and Task menu-items have also returned to the self-interact menu... Odd but nice.

Updated by Tupolov over 3 years ago

Guys,

I've just tested this on dedi server.

1. Open Map, use JIP Markers and Task Management to add 1 of each
2. Close Map
3. Call Close Air Support - UAV
4. Open Map, click on map location, close Map, wait for UAV to come online
5. Use UAV, escape out of UAV
6. Open Map, and JIP Markers and Task Management work as before, can add 1 of each.

JIP Marker and Task Mgmt are only available on the map screen.

Please can you confirm you used the steps 1-6 above.

Updated by Tupolov over 3 years ago

  • Status changed from New to Feedback

Updated by Telson over 3 years ago

Hi Tupolov
Yes I can confirmed I followed the steps above and JIP and Tasks were no longer working.

I have noticed that there is a new Zip file for MSO missions uploaded today 08.08.2011
The vertion I have was uploaded on 06.08.2011 2 days ago
Was there a problem with the one uploaded on 06.08.2011?

Updated by Telson over 3 years ago

Well I have tried with the default MSO mission BAF and US on Takistan uploaded 08.08.2011 and same results no JIP or Tasks after useing the UAV.

Updated by Tupolov over 3 years ago

Sorry I can't reproduce on a dedi server. Are you using any add-ons?

Takistan works fine for me.

Updated by Telson over 3 years ago

Yes we have a few addons

@CBA ( Required ), Server and Client side
@DC ( Digital Compass ), Client side only
@Sthud, Client side only
@Stmovement, Client side only
@CSM2BAF ( Sound mod ), Client side only
@Zeus_AI, Server and Client side

I suppose it must be one of the above causing the problem if others are not getting the error.
My money goes on @Sthud being the issue, It displays a little radar hud with the position of you and your squad members in it, As its the only addon that has anything to do with your squad and the MSO is dependant on you being the Squad leader to mark tasks and JIP markers, It makes sence to look at it first.

Has anyone else got an MSO server running with @Sthud on it?

Updated by Telson over 3 years ago

Well I have tried with all adddons off except @CBA and still have the problem
Tupolov what vertion of CBA are you useing?

The VBAU MSO server is running
Arma CO 1.59.79384
CBA v0.7.3.148

Updated by Sickboy over 3 years ago

Try to upgrade to the latest CBA (currently 0.7.6) http://dev-heaven.net/projects/cca/files

Updated by Telson over 3 years ago

Gutted I have updated to latest vertion of CBA but problem is till there.
I can confirm no other mods are running on the server and useing default misison with no editing.

I have noticed that the option to add JIP markers or tasks no longer works after you click on the map to select the location for the UAV or C130j.
whilst waiting for the count down for UAV to be ready, It has to be the map click causing problems.

Updated by Tupolov over 3 years ago

The only time I do not have JIP Markers and Task Management available is when the UAV is active and I'm the player using the UAV. Once I have finished with the UAV and returned to infantry mode the JIP markers and Task Management work fine. Can you post an RPT?

Updated by Telson over 3 years ago

This is the rpt from a quick test I ran, started mission when stated complete on map screen
went to map and placed a JIP marker and set a task, alt-click and shift-Alt-click
selected support and then cas then requested UAV
Countdown timer showed on top right of screen
Went to map and no option to place JIP or Tasks alt-click and shift-Alt-click no longer worked

[23889,1086.36,0,"XEH: PreInit Started. v3.0.7"]
[23889,1086.51,0,"MISSINIT","baf-usa_mso_3-45","Takistan",true,true,false]
[23889,1092.34,0,"XEH: PreInit Finished"]
[23889,1093.63,0,"XEH: VehicleCrewInit: 91"]
[23891,1097.89,0,"XEH: PostInit Started"]
[23891,1098.32,0,"CBA_VERSIONING",["#CBA_HASH#",["cba"],[[[0,7,6,160],-1]],[[0,0,0],0]]]
[23891,1098.76,0,"XEH: PostInit Finished; [true,false,false,true,false,true,false,true,true,true]"]
"CRBSERVERFPS,Time,FPSMax,FPSAvg,FPSMin,UnitsMax,UnitsAvg,UnitsCur,allGroups"
"MSO-0 Nou Caching (SERVER) Starting"
"MSO-0 Weather Sync: Overcast=0.607653"
"MSO-0 Weather Sync: Fog=0"
"MSO-0 Weather Sync: Rain=0.387232"
"MSO-0 Weather Sync: O=[0.607653,0.775084,0,4097.72]"
"MSO-0 Weather Sync: F=[0,0.0154819,0,718.361]"
"MSO-0 Weather Sync: R=[0,0.377316,0,1657.17]"
"MSO-0 Dog Packs # 20"
"MSO-0 Shepherds # 27"
"MSO-0 Nou Caching (SERVER) # 85 Groups 46/4 Active/Cached Units"
"MSO-0 Convoy: destinations(80) spawns(17) convoys(0)"
"MSO-0 Convoys # 0"
"MSO-0 TerrorCells: spawns(17) cells(6)"
"MSO-0 Enemy Population initLocations 420"
"MSO-0 Enemy Population # 0"
"MSO-21.55 Nou Caching (SERVER) # 91 Groups 53/26 Active/Cached Units"
"Log: [ALICE 2]: x16-1 traffic start."
"MSO-32.231 Nou Caching (SERVER) # 92 Groups 58/27 Active/Cached Units"
"Log: [ALICE 2]: x16-2 traffic start."
"MSO-46.118 Nou Caching (SERVER) # 92 Groups 68/21 Active/Cached Units"
"Log: [ALICE 2]: x16-3 traffic start."
"MSO-57.343 Nou Caching (SERVER) # 93 Groups 68/21 Active/Cached Units"
"MSO-70.011 Nou Caching (SERVER) # 95 Groups 69/21 Active/Cached Units"
"MSO-127.531 Nou Caching (SERVER) # 95 Groups 68/21 Active/Cached Units"
"MSO-135.07 Nou Caching (SERVER) # 95 Groups 69/21 Active/Cached Units"
"MSO-144.449 Nou Caching (SERVER) # 96 Groups 67/21 Active/Cached Units"
Wrong color format size #FFFFF
Wrong color format size #FFFFF
Wrong color format size #FFFFF
Wrong color format size #FFFFF
Wrong color format size #FFFFF
"MSO-160.762 Nou Caching (SERVER) # 96 Groups 68/21 Active/Cached Units"
"MSO-197.907 Nou Caching (SERVER) # 96 Groups 67/21 Active/Cached Units"
"MSO-218.421 Nou Caching (SERVER) # 96 Groups 75/21 Active/Cached Units"
Behaviour
"MSO-280.443 Nou Caching (SERVER) # 96 Groups 74/21 Active/Cached Units"
"MSO-289.178 Nou Caching (SERVER) # 96 Groups 75/21 Active/Cached Units"
"MSO-298.858 Nou Caching (SERVER) # 96 Groups 67/21 Active/Cached Units"

does the mission constantly check the mso_uid file on the server when mission is running or just when you join?

Updated by highhead over 3 years ago

alt + click and shift + click no longer working after UAV until you use the menu (with listbutton) once when on map!

1. Open Map, use JIP Markers and Task Management to add 1 of each
2. Close Map
3. Call Close Air Support - UAV
4. Open Map, click on map location, close Map, wait for UAV to come online
5. Use UAV, escape out of UAV
6. open map and do a shift + click on map (not working)
7. use alt + click on map (not working)
8. use context menu (listbutton - menu) to add a task/JIP Marker (working)
9. do a shift + click on map again (working again)

Updated by Telson over 3 years ago

use context menu (listbutton - menu) to add a task/JIP Marker (working)
Having a mental block, where or how do you access the context menu (listbutton - menu) lol

Updated by Tupolov over 3 years ago

  • Subject changed from New UAV stops JIP tasks working after use. to New UAV stops Shift-Click and Alt-Click from working if you do not use the context menu
  • Status changed from Feedback to In progress
  • Target version changed from MSO v4.6 to MSO v5.0

Guys,

You are correct, shift-click and alt-click do not work, but the Windows Key does (to get the menu up).

Updating the bug description.

Updated by Tupolov about 3 years ago

  • Priority changed from Normal to High
  • Target version changed from MSO v5.0 to MSO v4.6
  • Component set to CAS

Updated by Tupolov about 3 years ago

  • Target version changed from MSO v4.6 to MSO v4.4

Updated by Tupolov almost 3 years ago

  • Target version changed from MSO v4.4 to MSO v4.6

Updated by highhead over 2 years ago

UAV excluded due to client-logics passed to server after disconnect.

Updated by highhead over 2 years ago

  • Status changed from In progress to Closed
  • Target version changed from MSO v4.6 to MSO v4.55

Also available in: Atom PDF