Bug #2314

Airplane rotation speed multiplied by each action key pressed

Added by MulleDK19 about 6 years ago. Updated over 3 years ago.

Status:Closed Start date:06/27/2009
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Controls
Target version:1.60.87580
Affected ArmA II version:1.59.79384 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs
If you fly in an airplane (eg. the F-35B), and you hold down the Right Arrow key,
the plane will start spinning around itself with a certain speed.

Now, if you while still holding the Right Arrow key down, and then also hold down another key
configured for this (Default: Right Arrow and D), it'll spin twice as fast.
It seems to apply force for each key pressed.

Exp
Input should not be multiplied.

Repro
  1. Load attached mission
  2. Turn the plane
  3. Look at "HeliCyclicRight" number in the hint box
  4. Or notice the plane turning twice as fast

Note
inputAction shows that more inputs are in added.

oa_2314.Desert_E.7z (883 Bytes) kju, 08/10/2010 10:51


Related issues

related to ARMA2 Community Issue Tracker - Bug #13242: Analogue steering wheel controllers are not supported cor... Assigned 08/24/2010 05/28/2012

History

Updated by Squelch about 6 years ago

  • Status changed from New to Feedback

Please confirm the affected version?

Updated by MulleDK19 about 6 years ago

All versions to this date.

Updated by Squelch about 6 years ago

  • Affected ArmA II version changed from 1.01.57751 to 1.02.58134
  • Maxmem parameter set to Not set

Updated by zGuba about 6 years ago

  • Category changed from Gameplay to Controls
  • Maxmem parameter deleted (Not set)

Updated by zGuba about 6 years ago

  • Maxmem parameter set to Not set

Looks like I've spoiled sth.

Updated by Fireball almost 6 years ago

  • Due date set to 08/27/2009
  • Maxmem parameter deleted (Not set)

Still the case in 1.03?

Updated by MulleDK19 almost 6 years ago

Yup, present in 1.03 too.

Updated by alef almost 6 years ago

  • Subject changed from Airplane rotation speed multiplied to Airplane rotation speed multiplied by more action keys
  • Due date changed from 08/27/2009 to 11/17/2009
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.02.58134 to 1.03.58627

Thank you for reporting.
Just wondering if it happens for other stuff too, like walking or land vehicles.

Updated by alef over 5 years ago

  • Affected ArmA II version changed from 1.03.58627 to 1.04 BETA
  • Difficulty set to Not set
  • Reproduced by another DH user set to Yes
  • CPU set to n/a

Reproduced with build 59928.

Updated by alef over 5 years ago

  • Affected ArmA II version changed from 1.04 BETA to 1.05 BETA

Updated by alef over 5 years ago

  • File Chernarus.sqm added

inputAction shows that more inputs are in added. Repro mission attached. Look at "HeliCyclicRight".

Updated by zGuba over 5 years ago

  • Due date changed from 11/17/2009 to 01/01/2010

Updated by kju almost 5 years ago

  • File oa_2314.Desert_E.7z added
  • Subject changed from Airplane rotation speed multiplied by more action keys to Airplane rotation speed multiplied by each action key pressed
  • Due date changed from 01/01/2010 to 11/01/2010
  • Affected ArmA II version changed from 1.05 BETA to 1.53 BETA
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!
  • I am using some Mods set to No
  • Reproducible for you set to No

Updated by kju almost 5 years ago

  • File deleted (Chernarus.sqm)

Updated by zGuba about 4 years ago

  • Due date changed from 11/01/2010 to 09/14/2011
  • Affected ArmA II version changed from 1.53 BETA to 1.59.79384
  • Reproducible for you changed from No to Yes
  • Language set to Please set for missions

lol

Updated by zGuba about 4 years ago

  • Assignee set to Dwarden

one of these control issues that makes me wonder about tail wagging its dog around :)

Updated by Suma about 4 years ago

  • Status changed from Assigned to Resolved

81286

Updated by zGuba about 4 years ago

  • Target version set to Upcoming version OA

Updated by alef almost 4 years ago

  • Affected ArmA II version changed from 1.59.79384 to 1.60 BETA

Updated by alef almost 4 years ago

  • Due date deleted (09/14/2011)
  • Target version changed from Upcoming version OA to 1.60 BETA
  • Affected ArmA II version changed from 1.60 BETA to 1.59.79384

Updated by Sickboy almost 4 years ago

Please confirm fix, so we can close the ticket.

Updated by kju almost 4 years ago

  • Status changed from Resolved to Closed

Works fine now

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF