Bug #22974

AI Infantry can't shoot very well

Added by F2kSel over 3 years ago. Updated almost 3 years ago.

Status:Closed Start date:07/30/2011
Priority:Normal Due date:
Assignee:Suma % Done:

0%

Category:AI Issues
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Observed In beta patch 82901 through 83261
The AI ability to shoot at close range, about 40 meters is awful.
I've seen a group of four units unable to hit a single unit firing back at them.
When I used player addrating -6000 to have them turn on me they wasted their entire ammo including grenades.

Expected
Four units attacking one in the open should be an almost instant kill.

Example One
This has four units turn on the group leader using addrating to make the leader the enemy. You won't need to do anything other than start the mission and see what happens.

Example Two
In this example you are the leader of BLUFOR, your AI will open fire on the single OPFOR unit, you won't need to do anything just see what happens.

NOTE
You may need to run each example several times as it does vary.
I also feel it got worse in 83261.

bug_AI_Aiming2.utes.7z (947 Bytes) F2kSel, 07/30/2011 22:20

bug_AI_Aiming1.utes.7z (978 Bytes) F2kSel, 07/30/2011 22:22

bug_AI_Aiming1.utes.7z - Added allowDamage false to the demo missions to make the observation easier. (1005 Bytes) kju, 07/31/2011 07:06

bug_AI_Aiming2.utes.7z - Added allowDamage false to the demo missions to make the observation easier. (969 Bytes) kju, 07/31/2011 07:06

History

Updated by F2kSel over 3 years ago

Forgot the first example.

Updated by F2kSel over 3 years ago

A little more info, testing at Veteran level makes the AI a little more accurate but it's not easy to tell and still not right.
If you move you will die but again it's hard to tell if it's the AI targeting more accurately or just that you walk into the bullets.

Updated by kju over 3 years ago

  • File bug_AI_Aiming1.utes.7z added
  • File bug_AI_Aiming2.utes.7z added
  • Due date set to 10/30/2011
  • Category set to AI Issues
  • Assignee set to Dwarden
  • Operating system deleted (WinXP 32 bit)
  • Graphics card deleted (ATI5850)
  • Graphics card driver version deleted (10.6)
  • Affected ArmA II version changed from 1.10.80665 to 1.60 BETA
  • CPU deleted (i5 750)
  • System RAM size deleted (4000)
  • GPU VRAM size deleted (1024)

Very extreme how they miss that much.

Note
  • 1.59 still works fine
  • AI skill is at default (50%)

Updated by fabrizioT over 3 years ago

Beta Build 79384 looks not affected by the accuracy problem.
Possibily introduced in beta 79600?

Updated by F2kSel over 3 years ago

In my tests which I've just re-tested show this particular problem starts in beta 82901

The log for that patch doesn't show anything that you would expect to cause a problem.

Updated by Suma over 3 years ago

  • Status changed from New to Assigned
  • Assignee changed from Dwarden to Suma

Almost certainly a result of
[82654] Optimized: Visual state interpolation fully enabled.
It is caused by the fact the simulation rate is now lower for AI units, comparable to as if the game was running on 10 fps before.

See also http://forums.bistudio.com/showpost.php?p=1991501&postcount=19

I already have a fix planned for this, should be implemented within a few days.

Updated by Suma over 3 years ago

  • Status changed from Assigned to Resolved

Fixed in 83308 (the AI aiming is now done with better precision than the rest of the simulation).

Updated by admin about 3 years ago

  • First affected ArmA II version set to 1.60 BETA

Updated by Suma about 3 years ago

  • Status changed from Resolved to Closed

Updated by kju about 3 years ago

  • Due date deleted (10/30/2011)
  • Target version set to 1.60 BETA

Updated by kju almost 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF