Bug #2291

Placed AI die on/near spawn.

Added by JamesF1 almost 6 years ago. Updated over 5 years ago.

Status:Closed Start date:12/28/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:AI Issues
Target version:1.05.62017
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

When AI are placed in the editor in water, they 'freeze' (i.e. do not fall into the water itself) and die a number of seconds later.
The same behaviour is seen when setPos'ing an AI anywhere (over/in water, or over/on land).

This bug was introduced in 1.02 - prior versions were not affected. I've had a number of people confirm this in the thread on the BIS forum.

StandingOnWater.jpg - Example: Unit standing on water immediately after spawn. (41.4 kB) JamesF1, 06/25/2009 14:59

DeadOnWater.jpg - Example: Unit dead on water a few seconds after spawn. (21 kB) JamesF1, 06/25/2009 14:59

mission.sqm (3.8 kB) Fireball, 10/01/2009 23:01


Related issues

related to ARMA2 Community Issue Tracker - Bug #4628: Animation Transistion -> Swimming Causes Death Assigned 09/18/2009 11/01/2010
duplicated by ARMA2 Community Issue Tracker - Bug #2305: Death spawning AI in water Duplicate 06/26/2009
follows ARMA2 Community Issue Tracker - Bug #5502: AI from vanished parachute not affected by physics Closed 10/27/2009

History

Updated by kju almost 6 years ago

  • Status changed from New to Assigned

Cheers. Good report!

Updated by JamesF1 almost 6 years ago

This can be temporarily fixed by giving the AI a waypoint of some description. This must be a waypoint that requires movement (e.g. it cannot be a SCRIPTED waypoint). It must not be placed on top of the unit (~1m away), and must not be a great distance away (no more than ~10m, from what I've tested briefly).

If you want the unit to just stay where it is, give it a waypoint, and then use 1 _unit disableAI "MOVE";

Updated by alef over 5 years ago

  • Due date set to 09/25/2009
  • Maxmem parameter set to Not set

Updated by alef over 5 years ago

  • Affected ArmA II version changed from 1.02.58064 to 1.03.58627

Videos and repro available at #2305. According to that, still happening on 1.03.

Updated by solrac42 over 5 years ago

STILL NOT FIXED IN 1.04.59026

Updated by zGuba over 5 years ago

  • Affected ArmA II version changed from 1.03.58627 to 1.04.59026

Updated by Fireball over 5 years ago

  • File mission.sqm added
  • Due date changed from 09/25/2009 to 10/25/2009
  • Reproduced by another DH user set to Yes

Repro'ed it; see attached mission.

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by Dwarden over 5 years ago

  • Priority changed from Normal to High

Updated by Dwarden over 5 years ago

  • Priority changed from High to Normal
  • CPU set to Please specify!

workaround is use of setPosASL

Updated by Fireball over 5 years ago

  • Due date changed from 10/25/2009 to 11/25/2009

Updated by kju over 5 years ago

  • Start date deleted (11/28/2009)

Updated by kju over 5 years ago

  • Due date changed from 04/30/2010 to 11/25/2009

Updated by zGuba over 5 years ago

  • Status changed from Assigned to Feedback

Does it appear with latest beta? #5502 seems to be similar and fixed.

Updated by JamesF1 over 5 years ago

Appears to be fixed in 1.04.60902.

Updated by zGuba over 5 years ago

  • Status changed from Feedback to Resolved

Updated by zGuba over 5 years ago

  • Target version set to 1.05 BETA

Updated by kju over 5 years ago

  • Due date deleted (12/28/2009)
  • Assignee deleted (Dwarden)

Updated by solrac42 over 5 years ago

I can confirm that this bug is now fixed in v1.05.62017

Updated by kju over 5 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 1.05 BETA to 1.05.62017

ty!

Also available in: Atom PDF