Bug #2288

Sights misalign in certain stances

Added by RasdenFasden over 6 years ago. Updated over 5 years ago.

Status:Closed Start date:06/25/2009
Priority:Normal Due date:
Assignee:- % Done:


Target version:1.05.62017
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:


When crouching with a rifle or standing with an AT weapon (and possibly more) some sort of animation plays where the character moves the gun around slightly. When using 3D sights this causes them to misalign, preventing you from aiming accurately. This is especially bad when crouching with a rifle because it's supposed to make aiming easier, not harder.

anim.JPG - This is what happens when you crouch still and look through ironsights. (185.3 kB) RasdenFasden, 06/25/2009 14:29

buggedsights.jpg (291.7 kB) Snyp3r, 06/27/2009 16:56

Related issues

related to ARMA2 Community Issue Tracker - Bug #11628: [OA] A10 Warthog weapons and crosshair offset for any uni... Closed 07/02/2010
related to ARMA2 Community Issue Tracker - Feature #5290: Realistic reflex sights Assigned 10/19/2009
duplicated by ARMA2 Community Issue Tracker - Bug #5652: Weapon allignment problems when using 3d sights while cro... Duplicate 11/04/2009
duplicated by ARMA2 Community Issue Tracker - Bug #4864: Weapon ironsights misalign when crouching Duplicate 09/27/2009 12/27/2009


Updated by RasdenFasden over 6 years ago

Updated by kju over 6 years ago

  • Category set to Gameplay
  • Status changed from New to Assigned
  • Priority changed from High to Normal


Updated by Snyp3r over 6 years ago

With rifles at least, this only happens when crouched/kneeling, when standing or prone the sights don't have any such problems. Holding your breath makes absolutely no impact, nor does it seem to be caused by low stamina or any deadzone settings. In the short run at least, you can work around it by standing when you'd usually crouch, but you will be an easier target.

Updated by RasdenFasden over 6 years ago

It seems this happens with pistols at every stance.

Updated by alef over 6 years ago

  • Due date set to 09/25/2009

Updated by zGuba about 6 years ago

  • Due date changed from 09/25/2009 to 12/25/2009
  • Category changed from Gameplay to Animations
  • Affected ArmA II version changed from 1.02.58064 to 1.04.59026

Updated by RasdenFasden about 6 years ago

This bug is both terrible and easily fixable, why does it seem to be so low priority? I really want it fixed quickly and I don't think I'm only speaking for myself here.

Updated by zGuba about 6 years ago

  • Reproduced by another DH user set to Yes

Updated by Dwarden about 6 years ago

  • Assignee set to Dwarden

Updated by RasdenFasden almost 6 years ago

Here's an interesting fact: This bug doesn't happen when you rest your weapon while crouching in ACE mod. However it's still there if you don't rest it. Different animation, perhaps?

Updated by Salah almost 6 years ago

we need more people to vote for this

Updated by shuko almost 6 years ago

This should have high prio. As soon as you become aware of this issue, crouch becomes a "no no" position to shoot from. It has a big effect on gameplay.

The weapon will still shoot straight even when the sights are all over the place, meaning bullets don't go where the sight is pointing at. Easy to test, take one of the rifles with aimpoint, kneel, zoom and fire as the red dot goes from left to right, bullets will always hit in the middle, where the iron sight is pointing.

Updated by RasdenFasden almost 6 years ago

Rifle crouch's fixed in 1.05. Thanks, BIS! Sadly it's not fixed for AT weapons when standing.

Updated by MulleDK19 almost 6 years ago

I've never had this problem.

Updated by kju almost 6 years ago

  • Due date changed from 12/25/2009 to 01/20/2010
  • Status changed from Assigned to Resolved
  • Assignee deleted (Dwarden)
  • Target version set to 1.05.62017

Thanks for the report RasdenFasden. :)

Can you please create a new ticket for AT.

Updated by Fireball almost 6 years ago

  • Category changed from Animations to Weapons

Updated by kju almost 6 years ago

  • Due date deleted (01/20/2010)
  • Status changed from Resolved to Closed

Also available in: Atom PDF