Bug #22509

Shadows not casting on sections of Everon airfield runway

Added by da12thMonkey about 4 years ago. Updated over 3 years ago.

Status:Closed Start date:07/19/2011
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:Textures
Target version:-
Close Reason: I am using some Mods:No
Affected Version: Reproducible for you:Yes
Affected ArmA II version:Please select... Language:Please set for missions

Description

Shadows cast by objects such as vehicles or units do not project on to some sections on the runway at Everon's airfield.

This is most noticeable if you travel along the length of the runway: You will notice that the shadows will start to disappear as they intersect some sections of runway, and return on other sections (such as the pieces with the runway code numbers, and those that link to the taxi-way).

IIRC this rendering problem can be caused by using textures (_co, _smdi, _nohq or otherwise) that don't fully conform to ArmA 2 standards; for example not saving the original .tga as a 32bit image, or using an incorrect naming suffix when converting to .paa.

Everon_rnwy.jpg (120.3 kB) da12thMonkey, 07/19/2011 18:21

History

Updated by W0lle about 4 years ago

  • Status changed from New to In progress

The runway models on Everon / in general are pretty much screwed up. They will be replaced with new models asap.

Updated by Max_Power almost 4 years ago

I have found that the cause of this seems to be dxt5 textures don't receive shadows. Dxt1 format textures must be used instead.

Updated by Max_Power over 3 years ago

This problem is a combination of many factors, and sometimes it's a hardware problem. Some graphics cards are not displaying shadows on large runway objects.

Updated by Bushlurker over 3 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 0 to 100

Updated by Bushlurker over 3 years ago

This issue seems to be resolved - for some people.... I'm currently awaiting feedback - of any kind - from Patch 2 before closing...

Updated by Bushlurker over 3 years ago

  • Status changed from Resolved to Closed

seems this is fixed - for most people at least...

Also available in: Atom PDF