Bug #22455

ACE 1.11 introduces JSRS (probably any soundmod) incompatibility

Added by maturin almost 4 years ago. Updated almost 4 years ago.

Status:Rejected Start date:07/18/2011
Priority:Normal Due date:
Assignee:Robalo % Done:

0%

Category:-
Target version:-
Component: Affected Version:
Close Reason:By design/Not a Bug

Description

After installing ACE 1.11, the AK-74 firing sound in JSRS mod is broken. I hear the JSRS sound when using the weapon myself, but vanilla sounds when it is used by the AI. Strangely, sometimes the sound works and sometimes it does not, and I don't see any pattern.

Only @ACE is necessary to introduce this compatibility error. This applies to the last three versions of JSRS AK-74 sounds, so the problem was triggered by something in ACE 1.11

There's nothing in my RPT, and I have used trial and error to isolate @ACE as the sole cause.

History

Updated by Sickboy almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Robalo
  • Target version set to 1.12

ty

Updated by Sickboy almost 4 years ago

  • Subject changed from ACE 1.11 introduces JSRS incompatibility to ACE 1.11 introduces JSRS (probably any soundmod) incompatibility

Updated by maturin almost 4 years ago

I have heard vanilla sounds at every range from point-blank to around 500m in tests. It is more inconsistent in actual missions, for some reason.

But it's interesting that you mention burst mode. When I run JSRS without ACE, I get a main menu error message complaining about AKS-74U burst mode sounds. Does this suggest that JSRS has a burst mode config error?

The message doesn't show up in RPT, btw,

Updated by VKing almost 4 years ago

I can't reproduce the issue. I hear the JSRS AK sounds correctly.

Updated by maturin almost 4 years ago

Huh. I don't understand what ACE changed, though. AK-74s and AK-74Ms don't have a burst mode.

Updated by Robalo almost 4 years ago

Bad config in JSRS. They are referencing Single, Burst and FullAuto classes as root classes, "cheating" the RPT but it's not correct IMO.
AI is using bursts of full auto in ACE, just like the player would, so yes there are "AI Burst" modes, but properly configured sound mods will not have any problems.

Actually, the problem probably lies elsewhere. We have the additional ACE_Burst_Far class defined only in base classes, which is normal.
But JSRS goes and configs sounds classes further down the inheritance tree.
For example: AK74 sounds should be defined in class AK_Base, like BIS and ACEX_SM did, but JSRS for some reason put the sound configs in class AK_74, class AK_74_GL etc. (like those would sound different :)

Updated by Robalo almost 4 years ago

  • Status changed from Assigned to Rejected
  • Target version deleted (1.12)
  • Close Reason set to By design/Not a Bug

Not a problem with properly configured sound mods

Updated by maturin almost 4 years ago

Do you have a specific line of code I could show to Lord Jarhead?

Updated by Robalo almost 4 years ago

Good examples of sound mods with proper configs are rare, but ACEX_SM is one of them :)
Solution 1 is to only config the AK-74 sounds in class AK_Base.
Solution 2, if he insists on keeping separate configs for AK_74, AKS_74 etc. then he can add a blank class definition under each of those like this:

class ACE_Burst_Far: Burst {};

Also available in: Atom PDF