Bug #22343

Kh-29 laser on Su-34 misaligned from crosshair

Added by maturin almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:07/15/2011
Priority:Normal Due date:07/22/2011
Assignee:Aushilfe % Done:

100%

Category:-
Target version:1.12
Component: Affected Version:
Close Reason:

Description

Flying the Su-34 as pilot, the laser designator does not laze the area covered by the crosshair. The laser target shows up on some random place on the HUD, making aiming impossible. You guys just fixed this with the Su-25.

2011-07-15_00001.jpg (150.7 kB) maturin, 07/15/2011 19:28

acex_ru_m_veh_su34-_22343-fixed.7z (840.5 kB) Sickboy, 07/26/2011 06:43


Related issues

related to A.C.E. for OA - Bug #22340: Kh-29s lasing disrupted by busy CPU Closed 07/15/2011

History

Updated by maturin almost 4 years ago

Be advised, the Su-30 has the same problem.

Updated by Sickboy almost 4 years ago

  • Status changed from New to Assigned
  • Assignee set to q1184
  • Target version set to 1.12

Updated by q1184 almost 4 years ago

  • Status changed from Assigned to Feedback

It worked fine for me last time I checked it. Anyone else can confirm?

Updated by maturin almost 4 years ago

I was using the Su-34 Fullback, by the way (not the other version), as pilot.

Updated by Sickboy almost 4 years ago

  • Due date set to 07/22/2011
  • % Done changed from 0 to 100

Maturin; please attach a repro mission and the exact steps that make the problem apparant.

Updated by Sickboy almost 4 years ago

  • % Done changed from 100 to 0

Updated by q1184 almost 4 years ago

It's probably related to the lasing reliability issue, because it's perfectly aligned on my end.

Updated by maturin almost 4 years ago

I don't think it is related to performance, because if I turn down settings on a blank map, the Su-34 laser will behave perfectly. The laser target will appear reliably, but in the wrong place, beneath where the crosshair is pointing. There are no special circumstances of steps to reproduce this. It simply happens every time on my machine. I'm going to investigate further, and post a screenshot.

Updated by maturin almost 4 years ago

Here is a screenshot of the laser target a split second after acquisition. Note its position in relation to the crosshair.

FPS was 25-30, conditions in which the guidance system works flawlessly.

I don't think posting the mission is necessary, as I simply put an Su-34 in Shapur and pressed Preview. We have already established that this problem occurs without other mods running and that the RPT is clean.

Note that I was using Fire Control and Space to lase.

Updated by VKing almost 4 years ago

Could be because the HUD isn't the same or is offset compared to the Su-25.

Updated by q1184 almost 4 years ago

  • Assignee changed from q1184 to Aushilfe

Ok, I was apparently not running acex_ru and thus was using the BIS Su-34 model. That one works fine, while the acex_ru Su-34 indeed doesn't have the HUD cross aligned with the plane's 'bore', which is what's used as the laser pulse direction. Su-30 lacks the cross altogether. I'll see if I can do a scripted cursor then. Unless Aus wants to add the aiming mark in the models.

Updated by Sickboy almost 4 years ago

Or perhaps model meister Rocko could take a look if Aus not avail.

Updated by rocko almost 4 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Updated by Sickboy almost 4 years ago

Su34 fixed attached.
Su30 missing.

Updated by maturin almost 4 years ago

Yep, the Su-34 is fixed.

Updated by rocko over 3 years ago

Sickboy wrote:

Su34 fixed attached.
Su30 missing.

The Su30 has a custom made HUD by Aushilfe, with modelled HUD symbols etc, therefore not sure wether it can/should be fixed w/o his assistance, regarding the intentions behind the modelled HUD.

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed
  • % Done changed from 90 to 100

Available in the just released ACE for OA 1.11 Update 2.

Also available in: Atom PDF