Bug #22340

Kh-29s lasing disrupted by busy CPU

Added by maturin over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:07/15/2011
Priority:Normal Due date:
Assignee:q1184 % Done:

100%

Category:-
Target version:1.12
Component:sys_missileguidance Affected Version:
Close Reason:

Description

Test #1
Map: Chernarus
VD: 4000m
Situation: Su-25 using Kh-29 attempts to lase multiple targets at various distances, frequently moving and re-aiming the laser.
Results: Buildings, trees, water and randomly-generated land can be lased. I was able to lase at distances ranging from 300m to 7000m (beyond view distance).

Test #2
Map: Chernarus
VD: 4000m
Situation: Su-25 attempts to hit column of a roughly 12 armored vehicles with Kh-29s.
Expected Results: Lasing will work just as it did earlier.
Observed Results: Although FPS is not significantly lower and remains smooth, the CPU is too busy handing the AI to reliably lase targets. Lase keystrokes are ignored, and false Minimum Range readings are received. Lasing has a very high failure rate overall, and can be unavailable for minutes at a time. Spacebar brings up the command menu instead of executing a Lase command.

My RPT has nothing unusual in it. See here: http://dev-heaven.net/issues/20042

CPU: 2.53Ghz dual core

ace_sys_missileguidance.pbo (199.5 kB) Sickboy, 07/15/2011 17:17


Related issues

related to A.C.E. for OA - Bug #19237: Low FPS can disable Tank FCS lazing functionality Closed 04/27/2011
related to A.C.E. for OA - Bug #22343: Kh-29 laser on Su-34 misaligned from crosshair Closed 07/15/2011 07/22/2011

History

Updated by maturin over 3 years ago

Note: In the second test, lasing was unreliable even when the AI vehicles were far off-screen, executing a Move waypoint. Far-off AI have little effect on FPS, but apparently they still put enough of a load on my weak CPU to make lasing unreliable.

Updated by maturin over 3 years ago

Upon further investigation, plain old FPS on an empty map is also a limiting factor. The laser is chronically unreliable when FPS is anywhere in the teens. All symptoms described above can be observed with a framerate in the teens. Given that many people play this game with performance like this, and that using long-range weapons from the air required a performance-unfriendly view distance, I would say that this system is too failure-prone for lower-end users. It's a blast to lase things, though.

Updated by q1184 over 3 years ago

  • Status changed from Feedback to Resolved

I changed spawns to calls in lase key handler and user actions, which should help. I don't think there's anything else left to do to minimize the scheduling lag.

Updated by Sickboy over 3 years ago

  • Assignee set to q1184
  • Target version set to 1.12
  • % Done changed from 0 to 80
  • Component set to sys_missileguidance

Updated by maturin over 3 years ago

Is that something I can download and test? Not sure what to do with .hpp files.

Updated by maturin over 3 years ago

Hold on, I clicked the wrong link. I have now tested your new .pbo

Situation: Su-25 on Chernarus, 3000m view distance, attacking a large body of vehicles and men, around 100 AI.

Results: q1184, you're an absolute wizard. The laser may have possibly failed on me once, but all the other scores of lasings worked perfectly fine.

I was able to paint targets with 100% reliability with FPS in the 15-20 range. The laser remained functional as FPS dipped down to 10-15. I waited for my laptop to start getting too hot, lowering FPS to single digits, and was still lasing dozens of targets in the ocean! So yes, please do implement this in the next build. I know I will be using the new pbo.

If Tank FCS (
http://dev-heaven.net/issues/19237) and SACLOS ATGMS (right now they tend to sag into the ground and explode short of the target) could be made to be this reliable with low FPS, I would be overjoyed.

Updated by Sickboy over 3 years ago

  • % Done changed from 80 to 100

Awesome :) Thanks for your testing and feedback, much appreciated!
The other systems will follow.

Updated by maturin over 3 years ago

Error in expression <(player in [gunner this, driver this]) && (this getVariable 'ace_sys_missilegui>
Error position: <&& (this getVariable 'ace_sys_missilegui>
Error Generic error in expression

I have several hundred of those in my RPT. This occurred with the new .pbo, in a mission in which I was saving and reloading. I was playing as an Su-25 pilot, a Hind pilot and a T-72B commander in the gunner's slot. I was using Kh-29s, Tank FCS, Falangas and barrel-launched ATGMs. So I suppose almost any of the above could be causing it.

But nothing is broken and I don't care about RPT spam. Just giving you a head's up.

Updated by maturin over 3 years ago

Update: I use -showscripterrors, and the latest 'Generic error in expression' message showed up while simply flying the Su-25 (Kh-29). I wasn't using any weapons or ACE systems at the time.

Updated by q1184 over 3 years ago

maturin wrote:

Update: I use -showscripterrors, and the latest 'Generic error in expression' message showed up while simply flying the Su-25 (Kh-29). I wasn't using any weapons or ACE systems at the time.

Can't reproduce that. Might have to do with the way you made the new pbo?

Updated by Sickboy over 3 years ago

Tank FCS improvements available at #19237

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed

Available in the recently released ACE for OA 1.11 Update 1.

Also available in: Atom PDF