Bug #22227

Laggy character animations during cutscenes at low FPS

Added by mati140 over 3 years ago. Updated almost 3 years ago.

Status:Closed Start date:07/11/2011
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:Performance breakdown
Target version:1.60.87580
Affected ArmA II version:1.60.87580 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Repro:
1. Run game at lower-end computer/maximum graphics settings/with other aplications running in background in order to lower framerate to around 30 FPS.
2. Run any of Red Harvest missions (problem is easiest to be noticed when playing mission 8.Bitter Chill or at the end of mission 4.Harvest Red)
3. Get to the point where cutscene starts.

Obs:
Animations are running slower then audio track, and don't match sound. Characters move like in matrix. Ocasionaly they don't appear (though you can hear them) or teleport from one position to another. The lower FPS is, the bigger is lag.

Exp:
In previous versions animation speed was correct and matched sound whatever the framerate was. Character animations and movement should match audio track.

Notes:
- I didn't notice this issue in any other campaign then Harvest Red, but most likely because of lack of cutscenes.
- After lowering video settings to minimum I noticed that animation was sometimes to fast and left audi behind.

History

Updated by mati140 over 3 years ago

- To make sure that bug occurs force FPS to get down to around 20 FPS
- It seems that this issue doesn't show up when playing clear AA2 without OA.

Updated by Suma over 3 years ago

Can you confirm I am reading the affected version correctly and the problem was already present with 79384, before the current experimental betas? If this is correct, which is the last version which has worked fine for you?

Updated by Fireball over 3 years ago

  • Status changed from New to Feedback

Updated by Suma over 3 years ago

  • Status changed from Feedback to Resolved

Some issues with background file loading in low fps situations were fixed in 82699, and some optimizations were made to animation streaming in the same revision. On my system this seems to have fixed the problem.

Updated by zGuba over 3 years ago

  • Target version set to Upcoming version OA

Updated by mati140 over 3 years ago

Suma wrote:

Can you confirm I am reading the affected version correctly and the problem was already present with 79384, before the current experimental betas? If this is correct, which is the last version which has worked fine for you?

Sorry for not responding. I have this in 1.59.79384, and I can't remember exactly which was the last version without this issue but I'm 100% sure it was already there in 1.58. Not sure about previous versions but it was brought here by one of OA patches.

Also I found something new related to this animation bug - I thought it was the same teleport thing I mentioned in ticket, but now I see that characters are sometimes simply disappearing and appearing again during animations, depending on where I am facing (but i still have them/place they should be in in sight without using look-around). It's not related to FPS - I had this issue e.g. during prologue in church on Utes - the affected character was that guy who shouted at me, fired few rounds, got hit, shouted "Kurwa!" and fell dead on the ground. Whenever the direction I faced was to the left from him, he was invisible.

Updated by Fireball over 3 years ago

Mati140, can you confirm the lagging during low FPS is fixed with latest beta?

The other issue is too vague in your current description, please file another ticket, elaborate and make sure you can repro it with the latest beta.

Updated by zGuba over 3 years ago

  • Due date changed from 07/25/2011 to 09/25/2011
  • Status changed from Resolved to Feedback
  • Assignee set to mati140

Updated by alef over 3 years ago

  • Due date changed from 09/25/2011 to 08/27/2011
  • Affected ArmA II version changed from 1.59.79384 to 1.60 BETA

Updated by zGuba over 3 years ago

  • Category changed from Animations to Performance breakdown
  • Status changed from Feedback to Resolved
  • Assignee deleted (mati140)
  • % Done changed from 0 to 100

No reply. I pretend it's fixed.

Updated by kju over 3 years ago

  • Due date deleted (08/27/2011)
  • Target version changed from Upcoming version OA to 1.60 BETA

Updated by Sickboy about 3 years ago

Please confirm fix, so we can close the ticket.

Updated by mati140 about 3 years ago

Sorry for not replying, had some RL issues. As for build 85330 laggy animations' problem is solved, you can close the ticket. For disappearing characters I'm gonna create a new ticket.

Updated by Suma about 3 years ago

  • Status changed from Resolved to Closed

Updated by mati140 almost 3 years ago

  • Affected ArmA II version changed from 1.60 BETA to 1.60.87580
  • Maxmem parameter deleted (Not set)

... it seems that the bug has come back... after installing 1.60 final patch animations became laggy again. Exactly same problem, animations slower than sound. Seen in Pusta mission so far, with Valentina's animations. Hotfix don't solve it. Gonna check other missions as well.

EDIT: OK, nvm, seems that it's singular, other missions aren't affected.

Updated by kju almost 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF