Bug #21957

Wheat fields north of Montignac (Everon) cause a significant performance drop

Added by DiscountAnubis over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:07/07/2011
Priority:Normal Due date:
Assignee:Bushlurker % Done:

0%

Category:Islands
Target version:-
Close Reason: I am using some Mods:No
Affected Version: Reproducible for you:No
Affected ArmA II version:1.59.79384 Language:Please set for missions

Description

Just north of Montignac, surrounding the church, there is a somewhat-small wheat field. When entering the editor and looking at this particular area, there is a noticeable and severe drop in FPS, as well as an overall choppiness to the simulation. There does not appear to be a difference between viewing the position during the day, at night, or in any particular weather condition, so long as there is wheat within the one's sight radius, the performance drop occurs.

History

Updated by Max_Power over 3 years ago

  • Category set to Islands
  • Assignee set to Bushlurker

The fields in question are in Dj 45, Ea-46. I could not reproduce but my graphics card is pretty good.

@Discount Annubis, what are your system specs?

Updated by DiscountAnubis over 3 years ago

I'm running on a stock Gateway FX6840-03e, so all the specs are exactly as described here- ( http://reviews.cnet.com/desktops/gateway-fx6840-03e/4507-3118_7-34121961.html )

It's a fairly decent system; between the Intel Core I7 860 processor and the Ati Radeon HD 5770 it can run CO at a pretty consistent 55-60 FPS on a decent graphical setting, but I'd be a liar if I didn't say it could use some upgrading.

Updated by Max_Power over 3 years ago

It's definitely an overdraw problem then. Your computer kicks mine down the stairs and takes its lunch money on everything but the gcard. I have a q9550 with 4 gigs of ram and a 6870.

Updated by DiscountAnubis over 3 years ago

I'm honestly surprised by that! I thought I was on the lower end of the spectrum, to be honest, but I've never placed much faith in my electronics. Hell, when I brought my first FX home, it wouldn't even turn on! Turns out it had somehow fried its own motherboard in transit, and they replaced it with what I'm running today, but it always gives me pause when the issue might be with my own system.

Overdraw, huh? That's so odd- what would cause it to only affect certain systems, I wonder?

Updated by Max_Power over 3 years ago

Overdraw means you're drawing the same pixels more often than necessary.

When a computer is deciding what to render in 3d, it decides what you can see and what you can't- what is out of your view and what is blocked by other objects. When there is a polyplane with an alpha texture on it, which is tantamount to a sheet of invisible plastic with a picture of, say, a wheat plant stencilled on it, it can't really tell what's blocked and what is not, so it just draws everything behind it like there was nothing in the way. As the computer draws objects from furthest away to nearest, it draws over pixels as you get closer. If you have ten wheat plants in a row plus a background, it is drawing over the same pixels at least 11 times. So, in the field of wheat plants, there is a lot to draw. I think the fact I don't have a noticeable performance drop vs. you having one has to do with the the difference in our graphics cards. Our graphics cards are from the same line but mine is a generation newer (using the old naming convention, my card would be a 6770).

Updated by DiscountAnubis over 3 years ago

Fascinating! And I see how this would be a tricky issue to fix, then; even IF you were capable of telling the system what it can and can't draw behind each wheat plant, you'd still have to determine such instances from every angle and every view distance, probably taking up just as many, or even more resources than with the aforementioned method. It's a real Catch-22.

Updated by Max_Power over 3 years ago

The only way to reduce overdraw from our end it to reduce the number of wheat plants. You can fake the same 'coverage' of wheat plants by decreasing their density and increasing their size. Bushlurker is highly skilled and is on the job, so I'm sure the solution will be functional and effective.

Updated by DiscountAnubis over 3 years ago

Of that, I have little doubt. If something else pops up on my end, I'll keep you guys informed, but otherwise, it sounds like you've got the issue pretty well in hand.

Updated by Bushlurker over 3 years ago

  • Status changed from New to In progress

Updated by Bushlurker over 3 years ago

  • Status changed from In progress to Resolved

Updated by Bushlurker over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF