Bug #2193

Team Switch does not work after death from menu

Added by solrac42 over 5 years ago. Updated over 3 years ago.

Status:Closed Start date:06/21/2009
Priority:Normal Due date:08/17/2009
Assignee:- % Done:

0%

Category:Gameplay
Target version:1.03.58627
Affected ArmA II version:1.02.58134 First affected build:
Reproduced by another DH user: First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

When the player dies the teamswitch button does not function on my 505 games release version 1.02
Teamswitch works fine while the player is alive.
I had 6 playable units in the players group when the player died.

--

  • Repro (see attached mission):
    1. Confirm teamswitch is available.
    2. Head directly north.
    3. Welcome your death.
    4. Try to switch to another team member from death screen.
  • Expected results:
    • On death, another team member can be selected from the menu.
  • Actual results:
    • Although the Teamswitch button is displayed, it does not function when pressed.

Important: Same is true for the editor preview.

If you die and want to use teamswitch from the menu, its not working.
Also when hover over that button you get "Auto Load" hint instead of teamswitch (screen).

Team_respawn_test.utes.pbo (7.2 kB) Squelch, 06/30/2009 03:50


Related issues

duplicated by ARMA2 Community Issue Tracker - Bug #2453: Teamswitch Button is not working when dead Duplicate 07/01/2009
duplicated by ARMA2 Community Issue Tracker - Bug #2237: Team Switch does not work after death Duplicate 06/23/2009
precedes ARMA2 Community Issue Tracker - Bug #3416: Blurred View after teamswitch Closed 08/18/2009 09/30/2009

History

Updated by Squelch over 5 years ago

  • Target version deleted (1.02.58064)

Teamswitch respawn option must be set for it to work on death. You make no mention of what mission this is. The name of the supplied mission or a sample would be useful.

Please do not set the target version.

Updated by solrac42 over 5 years ago

No mission, just a single player setup in the editor.

enableTeamswitch is set to true by default in ArmA 2.

In the "You died" dialog that comes up you have "Restart" and "Teamswitch" buttons, but the "Teamswitch" button just doesn't work after the player dies.

Updated by kju over 5 years ago

  • Status changed from New to Feedback
  • Assignee set to solrac42

More info needed. Please read A2 Community Issue Tracker.

Updated by kju over 5 years ago

  • Status changed from Feedback to New
  • Assignee deleted (solrac42)

oh sorry too late :)

Can someone please confirm this.

Updated by dvolk over 5 years ago

I get the same thing in 1.02. After I die, the teamswitch button is selectable and even depresses, but nothing happens.

Updated by kju over 5 years ago

  • Status changed from New to Assigned

tx

Updated by kju over 5 years ago

  • Subject changed from Teamswitch to Team Switch does not work after death

Updated by brit over 5 years ago

i get this too, updated to version 1.02...play in editor with playable units, when player dies you cant switch to next unit although buttons for teamswitch workable

Updated by Squelch over 5 years ago

I can confirm this bug, contrary to my first thoughts of the mission not being configured for respawn.

  • Repro (see attached mission):
    1. Confirm teamswitch is available.
    2. Head directly north.
    3. Welcome your death.
    4. Try to switch to another team member from death screen.
  • Expected results:
    • On death, another team member can be selected from the menu.
  • Actual results:
    • Although the Teamswitch button is displayed, it does not function when pressed.

Updated by kju over 5 years ago

  • Subject changed from Team Switch does not work after death to Team Switch does not work after death from menu

Updated by kju over 5 years ago

tx Sq!

Updated by colonelwell over 5 years ago

fight until the last soldier is .
Bistudio that you made? what does this mean? solving the problem as quickly as possible, think about the fans who are with you since 2001 for OFP
is much more exciting fight until the last soldier and take up the mission and it is also much more fun .
option was used in ofp arma 1 and 2 before the fucking patch 102

Updated by alef over 5 years ago

Partial patch log available from Placebo Anyway, as 1.03 is out, check its changelog and if this issue is there:
  • download the repro mission here
  • do the same test that shows the bug

If it doesn't show, set to Resolved and set the Target version. Then wait 2 weeks and close if nothing else related to this bug has been noted.
Otherwise, leave it Assigned.

Updated by Fireball over 5 years ago

  • Due date set to 08/17/2009

Updated by Squelch over 5 years ago

  • Status changed from Assigned to Feedback

Addressed in 1.03Fixed: Team switch did not work when player died

Feedback Please

Updated by solrac42 over 5 years ago

I can confirm that teamswitch in SP mode is now fully working in patch 1.03

Updated by Squelch over 5 years ago

  • Status changed from Feedback to Resolved

Thank you

Updated by rothy over 5 years ago

solrac42 wrote:

I can confirm that teamswitch in SP mode is now fully working in patch 1.03

I also can confirm teamswitch is now working. Thanks!

Updated by kju over 5 years ago

  • Status changed from Resolved to Closed
  • Target version set to 1.03.58627

Thanks people for your help. :)

Also available in: Atom PDF