Bug #2185

At night, lights do not improve AI vision

Added by MadDogX about 6 years ago. Updated over 3 years ago.

Status:Closed Start date:06/21/2009
Priority:Normal Due date:10/01/2010
Assignee:Dwarden % Done:

0%

Category:AI Issues
Target version:-
Affected ArmA II version:1.53 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

See the provided test mission. At night, AI without NV Goggles are pretty much blind, even when an enemy is being illuminated by lights.

In the example mission I provided, the player is being illuminated by a search light while an enemy AI is standing just 20-30 meters in front, facing him (turn on NV Goggles to see him). In daytime, the enemy AI kills you instantly, but at night, although you are clearly visible due to the searchlight, the AI will not shoot you unless you move and thus make a sound - upon which the AI will locate and kill you instantly.

Whether or not the moon is in the sky does not seem to affect this behavior.

AI_NightLight.utes.zip - Example mission (809 Bytes) MadDogX, 06/21/2009 15:20


Related issues

related to ARMA2 Community Issue Tracker - Bug #12347: At night, aerial flares do not improve AI vision Assigned 07/26/2010 11/26/2011
related to ARMA2 Community Issue Tracker - Bug #11568: Using a flashlight does not give away your position to th... Assigned 06/30/2010 12/01/2011
duplicated by ARMA2 Community Issue Tracker - Bug #4448: AI night sighting ability Duplicate 09/10/2009

History

Updated by kju about 6 years ago

  • Status changed from New to Feedback
  • Target version deleted (1.03.58627)
  • Affected ArmA II version changed from 1.01.57751 to 1.02.58064

Thanks for the report MDX!

Target version explains the version it is fixed in (no wishful thinking here ;)).

Updated by kju about 6 years ago

  • Status changed from Feedback to Assigned

Updated by alef about 6 years ago

  • Due date set to 09/21/2009

Updated by Fireball almost 6 years ago

  • Affected ArmA II version changed from 1.02.58064 to 1.04 BETA

Confirming this with latest beta patch. Good repro btw., but it's probably an engine limitation.

Updated by Dwarden almost 6 years ago

  • Assignee set to Dwarden

Updated by Fireball almost 6 years ago

  • Due date changed from 09/21/2009 to 10/21/2009
  • Affected ArmA II version changed from 1.04 BETA to 1.04.59026

Updated by Fireball almost 6 years ago

  • Due date changed from 10/21/2009 to 12/21/2009
  • Reproduced by another DH user set to Yes

Updated by kju about 5 years ago

  • Due date changed from 12/21/2009 to 07/14/2010
  • Status changed from Assigned to Feedback
  • Assignee deleted (Dwarden)
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017
  • Audio card set to Please specify!
  • Size of OS swap file set to Please specify!

Still valid in 1.07 / OA?

Updated by MadDogX about 5 years ago

As it happens, I just tested this yesterday. Stood under a lamp post at night, with an AI looking at me from ten meters away. He couldn't see me.

So yes, still valid I'm afraid.

Updated by MadDogX about 5 years ago

Found a bug in OA closely related to this one:

Enemies cannot see you in the dark, even if you have a flashlight on. They will walk right past you, even if you shine the light right in their face.

Units with activated flashlights should light up like a christmas tree at night. The darkness should no longer hide them.

Is this worthy of its own ticket? Should I provide a simple repro mission?

Updated by kju about 5 years ago

  • Due date changed from 07/14/2010 to 07/28/2010
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.05.62017 to 1.52.71816

Yes I think it'd be useful to have it a separate and a demo mission would be most useful.

Updated by kju about 5 years ago

Forgot last time. A new demo mission on desert island would be most useful.
Or a couple with different situations (with/without moon, different night times,
different weather and fog settings).

If anyone feels like, you are welcome to help us here.

Updated by Rommel about 5 years ago

Unit still does not notice me, despite high light conditions and flashlight.

Updated by kju about 5 years ago

  • Due date changed from 07/28/2010 to 10/01/2010
  • Affected ArmA II version changed from 1.52.71816 to 1.53 BETA

Updated by Fireball about 5 years ago

  • Assignee set to Dwarden

Updated by Dwarden about 5 years ago

  • I am using some Mods set to No
  • Reproducible for you set to No

the lit area should now matter

the flashlight on other side might not alarm the AI yet and needs to be rechecked

Updated by BigDawgKS about 5 years ago

Yep it's a lot better now. However, light produced by aerial flares (ex: 40mm flares) doesn't seem to be considered. Would be nice if flares also helped AI see better. I can make a repro mission later today when I get home.

Also, as you said, they do not become alarmed/alerted to the source's presence when lights are shone on them. This one's not such a big deal though and I can't think of many games that do this anyway.

Updated by Dwarden about 5 years ago

  • Status changed from Assigned to Resolved

i get spotted by AI and shortly afterward he will open fire to kill
with b72204

Updated by BigDawgKS about 5 years ago

Please clarify. Do you mean when you shine a flashlight on them, or when you are being illuminated? What about flares, do they now have proper illuminating effects for AI?

Updated by Dwarden about 5 years ago

i cover here only about case presented within the sample mission and the report case

AI see you because You are illuminated by the searchlight and kills You ...

thus this is resolved ...

other cases like flashlight etc. have own ticked and will be delt with accordingly in due time
do flares have own CIT? (not sure now must look)

Updated by BigDawgKS about 5 years ago

Ok, thanks for clarifying. The way you said it sounded like b72204 may have changed something (AI detecting illuminated units was fixed in b71976). I haven't seen a seperate ticket for flares. I have a repro mission for it, so later on today when I get a chance I'll make one (if someone else doesn't first).

And yes, the flashlight thing has it's own ticket.

Updated by Dwarden almost 5 years ago

  • Status changed from Resolved to Closed

closing as fixed

Updated by BigDawgKS almost 5 years ago

What about #12347 though? I haven't been able to test it with the latest build.

Also available in: Atom PDF