Feature #21825

Add define to settings can change the time for the dead BLUFOR bodies

Added by Kol9yN about 4 years ago. Updated almost 4 years ago.

Status:Closed Start date:07/04/2011
Priority:Low Due date:
Assignee:Fireball % Done:

100%

Category:Support
Target version:0.81
Affected Version:0.80 GPU VRAM size:
Operating system: I am using some Mods:
Graphics card: Reproducible for you:
Difficulty: Related to content of DLC:
CPU: Affected ArmA3 version:
System RAM size: Single / Multi Player?:

Description

So many dead bodies on map, eat server RAM, and BLUFOR corpses stay to long, Blufors have "unlimited" ammo and grenades if death!
Plz add a variable to can change bodystay time for bot and players!

***MORE VARIABLES in Mission Settings!!!

Associated revisions

Revision 2b93530e
Added by Fireball almost 4 years ago

Parameter to change player body removal time; fixes #21825

History

Updated by Fireball almost 4 years ago

  • Priority changed from Urgent to Low

Trivial nowadays. A2OA player ought to have >= 3 GB RAM.

Updated by Fireball almost 4 years ago

  • Target version deleted (0.81)

Updated by Kol9yN almost 4 years ago

I propose this for gameplay impromevent...

Or show please part of code where i can change this parameters

Updated by Fireball almost 4 years ago

  • Status changed from New to Feedback
  • Assignee set to Fireball

Currently it's for spawned AI's bodies the way, that 30 seconds after the spawning bots are killed and noone is facing them, they're removed. The countdown stops when you turn towards them, to avoid AIs disappearing in plain sight of the player(s) - as soon you turn away the countdown is continued and the body is removed eventually.

The only thing left after those are vehicle patrols, AIs from static emplacements and BLUFOR - I can't see how these should affect performance.

Any AI units (and vehicles) from vehicle patrols and static emplacements are cleaned up after (all) players move outside the radius of SPAWNRANGE at some time (which differs for each map; 400m for Takistan), but those are not too many anyway.

BLUFOR bodies are removed currently after 180 seconds, just for the reason that OPFOR (and other BLUFOR alike) have the opportunity to take weapons and ammo from them. Unless you limit BLUFOR deaths, they have unlimited ammo (lifes) anyway, plus they can also take weapons from dead OPFORs. So the only thing you do, by reducing this time, is to punish OPFOR - I agree that this has potentially great influence on gameplay if you allow OPFOR, but not so if the mission is played as COOP-only.

I agree to make BLUFOR body removal time a parameter - all other timings make no sense to adjust. Happy with that?

Updated by Kol9yN almost 4 years ago

Yes thanks! :)
You told about OPFOR side, we cut RED side, and play only on BLUFOR side, because we remake Insurgensy to coop
I request for this to set the control variable for the dead body stay.
And ask to show that part of the code which is responsible for cleaning time, we have failed to find it...
Thanks for feedback

If you want, you can look at this
http://filebeam.com/3ddf15f57239ec5330bdb9df44a6c553

Updated by Fireball almost 4 years ago

  • Subject changed from Add define to settings can change the time for the dead bodies to Add define to settings can change the time for the dead BLUFOR bodies
  • Status changed from Feedback to Assigned
  • Target version set to 0.81

It's in common/defines.sqf:

#define REM_PLAYER_BODY 180

Updated by Kol9yN almost 4 years ago

Its not work!
I try set 10,20,30sec, but body continue stay
:(((
Or maby in next version lock inventory if player is dead? (inside define in config)

Updated by Fireball almost 4 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Updated by Fireball almost 4 years ago

  • Tracker changed from Task to Feature

Updated by Fireball almost 4 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF