Bug #21713

"AddWaypoint"-command works rarely correctly for tanks

Added by saok almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:07/02/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:-
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Waypoints created with "AddWaypoint"-command are rarely working correctly for tanks which randomly stop at random waypoint (often on the first) and ingore then the rest.

Reproduce: Place 4 invisible helipads with names pad1, pad2... with around 500m distance separation. And use this code (with function module placed on map):
_tg1 = [position pad1, 0, "M1A2_US_TUSK_MG_EP1", WEST] call BIS_fnc_spawnVehicle;
_wp1= (_tg1 select 2) addWaypoint [position pad2, 0];
_wp2= (_tg1 select 2) addWaypoint [position pad3, 0];
_wp3= (_tg1 select 2) addWaypoint [position pad4, 0];

Then just launch the mission and accelerate time. Repeat this until the tank dosent show up to 3rd waypoint. Shouldnt take long. You could also multiply the tanks with their own waypoints...

This very annoying bug have existed at least a year. The "move"-command work right and it could be used instead, but more unnecessary clumsy code is then required. So it would be great to have this "addWaypoint"-working good. ;)

History

Updated by saok almost 4 years ago

I need to do more testing of the issue. Currently the tanks work good on desert map :S, but they constatly stucked in one my missions last week on takistan map (I was using couple older betas than the current 82448). I will post a testing mission soon, when I found it reproducing the bug.

Updated by saok almost 4 years ago

Okay, I cant reproduce the issue with 82448. Its seem to be fixed (without change log in beta) or its just randomly working now. I report back if the bug again shows up. You can delete this report or just leave it. Sorry for extra hassle.

If it was fixed then big thanks. :)

Updated by Fireball almost 4 years ago

  • Status changed from New to Closed
  • Target version set to 1.60 BETA

Closing as fixed.

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF