Bug #21700

AI helicopters with broken tail rotors dance

Added by kju over 4 years ago. Updated over 3 years ago.

Status:Closed Start date:07/02/2011
Priority:Normal Due date:
Assignee:- % Done:


Category:AI Issues
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:


When the tail rotor gets destroyed, a helicopter can no longer be controlled properly in most cases.
In general AI tries to land ASAP in this situation.
However some choppers, like the UH60 type and to extent also the AH64, have hard times doing so.

Almost all the time shortly before landing, they rise again into the sky.
This is probably as the chopper is not stable enough in the landing procedure and instead is swinging.

This effectively causes AI choppers to dance in the air (rather to land).

  1. AI no longer uses the weapons when the chopper crew has lost control
  2. AI ejects rather trying to land, if the chopper is no longer controllable (probably not realistic though)
  3. Landing skills of AI are improved to avoid the situation
  1. Run attach mission in the editor
  2. Use radio 0-0-1 at any moment to disable the tail rotor of all choppers
  3. Watch
  4. Notice the described effect of AI choppers dancing

brokenTailRotor.desert_e.7z (1.2 kB) kju, 07/02/2011 05:31


Updated by maturin over 4 years ago

There is a simple fix for this. Make AI choppers with disabled tail rotor automatically turn off their engines. This will cancel the spinning and allow them to use their usual autorotation skills.

Updated by CarlGustaffa over 4 years ago

When I loose tailrotor the only way I'm getting out of that one alive is if I glide it in while I'm fast enough to maintain directional authority. At touchdown I'm beginning to loose authority, the chopper will be even more messed up, but we're alive.

If I loose tail while in a hover, I too tend to spin out of control and the only solution is to try to gain some altitude and desperately try to get the situation under control. I'm not a very skilled helicopter pilot either, so it tends to take a while. Reminds me of AI :)

Updated by Suma over 4 years ago

  • Status changed from New to Resolved

Should be a bit improved with 82464. I am not willing to dedicated any more time to it, therefore unless I have caused some other major problems by the fix, I suggest closing it here.

Updated by Fireball over 4 years ago

  • Target version set to Upcoming version

Updated by Fireball about 4 years ago

Is it better now?

Updated by Fireball about 4 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by kju about 4 years ago

It seems somewhat better now.
That said in some situations it still happens.

To me it seems the root cause is that chopper still tries to engage enemies
rather than to concentrate fully on landing safely.

I am fine with closing too if Suma wants to as I handled it with scripting in my game mode.
(damaged EH + check for !canMove => setFuel 0 + crew to eject in some conditions)

Updated by Fireball about 4 years ago

  • Status changed from Resolved to Closed
  • Assignee deleted (Dwarden)

Closing then, as Suma's will is exhausted on the topic. Maybe we come again in A3. :-)

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF