Feature #2106

Enable commands during conversations/cutscenes

Added by Squelch about 6 years ago. Updated over 5 years ago.

Status:Closed Start date:06/16/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Gameplay
Target version:1.05.62017
Affected ArmA II version:1.04.59026 First affected ArmA II version:
Reproduced by another DH user:Yes Single / Multi Player?:
I am using some Mods: BIForumURL:
I am using: NGUrl:
Reproducible for you: WIKIurl:
Related to content of DLC:

Description

During conversations, the command menu for group or high command cannot be opened. This can lead to some unnecessary team deaths by being prevented from commanding while going through the cutscene/conversation. Most annoying when a move order is under way, and the team is heading into known danger.

Also the unexpected cutscenes do not check for the presence of enemies in the immediate area. This leaves the team exposed as sitting ducks while the enemy attacks.

eg Badlands mission Father Fyodor calming the crowd in Novy Sabor. Two enemy riflemen in the churchyard attacked, and there is nothing can be done about it


Related issues

related to ARMA2 Community Issue Tracker - Bug #3069: Unable to control AI when scripted radio messages arrive Duplicate 07/25/2009
duplicated by ARMA2 Community Issue Tracker - Feature #2208: Scripted speech playback is a single task. Duplicate 06/22/2009

History

Updated by Fireball about 6 years ago

Same problem here just happened recently, when I was in the woods and found the hidden main base of the Chedakis and I shall "NOT attack, I repeat, do not attack until group Boomerang arrived to your position".

Problem is that this lenghty radio conversation with Battlemage just happens after an autosave and indeed, the enemy was already coming in with about a dozen people including snipers etc. to attack my posit. If my team was now even in combat mode "danger" or "stealth", I would have been SOL, because they would never retreat with me unless I was able to issue commands during this conversation.

I was lucky enough that they just retreated with me far enough, so I could issue the "disengage" order while pulling back in time, after a few tries. Many times a Razor Team member or I just died still during conversation, resulting into loading the same autosave again and trying again to disengage during that @#! Battlemage convo.

A valid vorkaround would be that only hand signs are given out to my team during the time I speak with Battlemage or at least while I talk. While Battlemage is talking my ears bleedy, I should be able to issue commands.

Updated by Squelch about 6 years ago

  • Subject changed from Commands cannot be performed during converstaions/cutscenes to Commands cannot be performed during conversations/cutscenes

Updated by Fireball about 6 years ago

Problem still exists in patch 1.02.

Updated by kju about 6 years ago

  • Affected ArmA II version changed from 1.01.57751 to 1.02.58064

Updated by Electricleash about 6 years ago

I can confirm having the exact same problem as Fireball described. Patch 1.02.
It also highlights other issues relating to radio coms:
With multiple Story dialogues/commands/contact callouts/radio/news broadcasts etc.
tumbling over each other and creating an inaudible mess.

Updated by kju about 6 years ago

  • Status changed from New to Assigned

I guess its not as easy to solve.. still very annoying. Vote ppl ,)

Updated by xxbbcc about 6 years ago

Still present in latest 1.02 patch (58134.)

Updated by Squelch about 6 years ago

  • Affected ArmA II version changed from 1.02.58064 to 1.02.58134

Updated by alef about 6 years ago

  • Due date set to 09/25/2009

Updated by Armored_Sheep about 6 years ago

  • Status changed from Assigned to Rejected
  • Difficulty set to Not set

That is not BUG but intentional design decision.

Updated by Fireball about 6 years ago

Armored_Sheep wrote:

That is not BUG but intentional design decision.

Well, then we probably need a new Tracker type called "Misfeature". This certainly prevents e.g. a speedy disengagement when in a critical situation.

A prime example is e.g. in Manhatten, when you discover the main Chedaky base and it says "do NOT engage, wait for backup to arrive"; you'll have a lenghty conversation with Battlemage, while your men are maybe in "Danger" mode (because you spotted the enemy) and engaging at will too, so your team will just lay down and shoot until you are past the conversation and tell them to "Disengage" in "Aware" combat mode. This almost made me lose hours of gameplay and needing to restart the mission whole, because it autosaved just before the convo started.

If you can tell me that you will do everything to rule out such situations and fix every individual campaign mission, I'm happy too, but as it stands now, it's very naughty.

Updated by SquelchAdmin about 6 years ago

  • Affected ArmA II version changed from 1.02.58134 to 1.03.58627
  • Difficulty changed from Not set to Regular

Updated by Squelch about 6 years ago

Maybe this issue should be recategorised as mission or campaign to reflect the lack of checks made before calling the cutscene? Should a separate issue be raised for all instances where this design decision causes problems?

Apart from the above quoted occurences, an unexpected cutscene has,

  • Removed my team from a vehicle while at distance from where the cutscene occurs resulting in the loss of a vehicle.
  • Resulted in the loss of team members during a firefight.
  • Cancelled a number of actions being performed such as rearming at a corpse.
  • Prevented movement and mission progression due to a bugged conversation - fixed in a previous patch
  • Caused team members to be run down by AI vehicles while they manoeuvre.

Due to an autosave occurring at roughly the same time as a cutscene, the player is left with the only recourse to save his way through a mission, which removes the immersion and is a style of arcade play I prefer not to indulge.

I contend this is a bug, but concede it may be too general or the category may be incorrect

Updated by Fireball almost 6 years ago

  • Status changed from Rejected to Assigned
  • Affected ArmA II version changed from 1.03.58627 to 1.04 BETA server

I'll keep this around as feature request.

Updated by Fireball almost 6 years ago

  • Due date changed from 09/25/2009 to 12/25/2009
  • Affected ArmA II version changed from 1.04 BETA server to 1.04.59026

Updated by Fireball almost 6 years ago

  • Tracker changed from Bug to Feature

Updated by Fireball almost 6 years ago

  • Subject changed from Commands cannot be performed during conversations/cutscenes to Enable commands during conversations/cutscenes

Updated by kju almost 6 years ago

  • Due date deleted (12/25/2009)
  • Reproduced by another DH user set to No

Updated by kju over 5 years ago

  • Due date set to 12/23/2009
  • Status changed from Assigned to Resolved
  • Target version set to 1.05 BETA
  • Reproduced by another DH user changed from No to Yes

Seems fixed in the latest beta for me.

During a campaign cutscene I can use the action menu and command my team.

Updated by alef over 5 years ago

  • Due date deleted (12/23/2009)
  • Status changed from Resolved to Closed
  • Target version changed from 1.05 BETA to 1.05.62017
  • CPU changed from Please specify! to n/a

Also available in: Atom PDF