Bug #21026

Laser Designator sight and laser misaligned

Added by Buehgler_AS almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:06/28/2011
Priority:Normal Due date:09/28/2011
Assignee:- % Done:

0%

Category:-
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:1.60 BETA
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Since the recent flurry of betas the laser from the laser designator has become significantly misaligned with respect to the optics. Potentially this is related to #13143, but I think the current problem is much more significant, and potentially breaks a number of mods and missions that rely on this functionality (it certainly breaks the rangefinder functions within ACE).

Attached are three images 1.59.81921 (the ones with beta in their name) and three images from stock 1.59. These are all taken at dusk from the East end of desert looking back toward the central hill. You can clearly see the divergence of the laser spot from the sight in the betas, while the two remain properly centered without the beta.

OBS:
When running a beta running the laser from the laser designator is not aligned with the sight

EXP:
The laser spot should stay at the center of the designator sight

REPRO:
Place an actor equipped with a designator on the East side of Desert, set time to dusk (to facilitate seeing the laser spot). Look back at central hill with designator active and slowly pan down toward your feet. Observe the motion of the spot relative to the reticle.

laser-beta-3.jpg - long range horizontal view with 1,59.81921 (128.7 kB) Buehgler_AS, 06/28/2011 04:02

laser-1.jpg - long range horizontal view with 1,59 (112.4 kB) Buehgler_AS, 06/28/2011 04:02

laser-2.jpg - slight down angle view with 1,59 (125.2 kB) Buehgler_AS, 06/28/2011 04:02

laser-3.jpg - steep down angle view with 1,59 (192.6 kB) Buehgler_AS, 06/28/2011 04:02

laser-beta-1.jpg - long range horizontal view with 1,59.81921 (115.8 kB) Buehgler_AS, 06/28/2011 04:02

laser-beta-2.jpg - slight down angle view with 1,59.81921 (127.8 kB) Buehgler_AS, 06/28/2011 04:02


Related issues

related to A.C.E. for OA - Bug #21998: arma beta´s after ARMA2_OA_Build_79600 Duplicate 07/08/2011
related to A.C.E. for OA - Bug #20325: Vector 21 / SOFLAM laser emits below reticle (A2OA Beta 8... Rejected 06/09/2011

History

Updated by tcp almost 4 years ago

Reproduced. The laser is firing at an angle in the betas.
Example Data:
Weapon (weaponDirection): [-0.999981,-0.00440209,-0.00429896]
Laser Target (vectorDir): [-0.999981,-0.00439796,-0.00429531]

Updated by Buehgler_AS almost 4 years ago

I just ran malloc testing with 82282 and confirmed that this problem still exists in that beta.

Updated by barmyarmy almost 4 years ago

  • Due date set to 09/28/2011
  • Status changed from New to Assigned

Updated by Buehgler_AS almost 4 years ago

Just checked with today's beta (82489), and the problem still exists

Updated by Suma almost 4 years ago

  • Status changed from Assigned to Resolved

Strange. What I have seen was even a lot worse misalignment - the laser dot was projected right beneath my feet, making it absolutely unusable. This is fixed in 82503 and I see no misalignment now. I hope this fixes your problem as well.

Updated by Buehgler_AS almost 4 years ago

Just had a chance to test with the 82604 beta, and everything seems to be properly aligned.

Thanks very much for getting this fixed.

Updated by Suma almost 4 years ago

  • Status changed from Resolved to Closed

Updated by Fireball almost 4 years ago

  • Target version set to 1.60 BETA

Updated by admin over 3 years ago

  • First affected ArmA II version set to 1.60 BETA

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF