Bug #20813

SOFLAM Problems

Added by tonci87 over 4 years ago. Updated over 4 years ago.

Status:Closed Start date:06/26/2011
Priority:Normal Due date:
Assignee:tcp % Done:


Target version:1.11
Component:sys_rangefinder Affected Version:
Close Reason:


Problem 1: There is no indicator that the Laser is active. The documentation says that the XMT LEd should light up when the Laser is active. This LED only flashes when activating the SOFLAM, after that it stays off.
Problem 2: No distance to target is beeing displayed-> Makes the SOFLAM useless as Rangefinder

Associated revisions

Revision f37e17e0
Added by tcp over 4 years ago

~FIXED: Laser Target finding

fixes #20813


Updated by Sickboy over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to tcp
  • Target version set to 1.11

Updated by tcp over 4 years ago

  • Category set to Script
  • Component set to sys_rangefinder

These SOFLAM features have been working for a long time. Can you pinpoint what A2 versions or ACE versions it broke at? Please provide the full details of the bug report including mod versions used, conditions, and a RPT file as instructed here

Updated by tonci87 over 4 years ago

I am using the latest Arma 2 CO Version with Beta 81286, together with the latest ACE version.
To reproduce: place yourself with Soflam and battery, try to use it as a rangefinder

RPT from test with USMC Spotter on desert map:

Warning: looped for animation: ca\wheeled\data\anim\uaz_cargo01_v0.rtm differs (looped now 0)! MoveName: kia_uaz_cargo02
Warning: looped for animation: ca\wheeled\data\anim\uaz_cargo01_v0.rtm differs (looped now 1)! MoveName: uaz_cargo02
[5551,143.431,0,"XEH: PreInit Started. v3.0.6"]
[5551,150.504,0,"XEH: PreInit Finished"]
[5551,150.514,0,"XEH: VehicleCrewInit: 0"]
[6453,160.014,0,"XEH: PostInit Started"]
[6453,160.513,0,"XEH: PostInit Finished; [true,false,false,true,false,true,true,true,true,false]"]

Updated by Xeno over 4 years ago

Confirmed, the SOFLAM range finder is not working at all.

Updated by tcp over 4 years ago

I think it's the beta because I tested without and it works. Will see what happens with beta next.

Updated by Xeno over 4 years ago

I've checked it with beta 79600 which was released on the same day as patch 1.59 (some fixes that didn't make it into 1.59)

Updated by RobertHammer over 4 years ago

I have same issue with vector 21b nite - simple can't get the range finder work

Updated by tcp over 4 years ago

Yea, beta breaks it. My guess is that the beta is doing something weird with the magazines associated with the rangefinders because the LED display turns on, you just can't turn turn the laser on with a left-click, even though the weapon name in the HUD turns green to show that it is has ammo.

Updated by tonci87 over 4 years ago

The Laser does turn on, you can paint targets for LGBs, the indicator and the rangefinder are a different story.
Another Thing, I remember that the Soflam had FLIR. I canĀ“t get it to work anymore. Was this removed?

Updated by tcp over 4 years ago

  • % Done changed from 0 to 50

I don't know about the FLIR system. Also, this is a problem with changes made to the laser by BI and not with the rangefinder turning on or bugging out.

I see now that the laser turns on, but on my screen it is not shown correctly. A red dot should appear at the center of the reticle. Instead, it shows variably around the -30 vertical mark when you paint a nearby object like a building. This is purely cosmetic though, and it's not the cause of the problem.

The thing that has changed is that weaponDirection of the player closely, but does not exactly the vectorDir of the laser target since the betas.
WepDir: [-0.999981,-0.00440209,-0.00429896]
LasDir: [-0.999981,-0.00439796,-0.00429531]
The findLT function should probably not have required perfect accuracy to begin with, but it can be fixed easily. I need to fix some other things in that function as well though since it seems to be counting the same laser target twice when facing certain directions.

Updated by tcp over 4 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 50 to 100

Updated by Buehgler_AS over 4 years ago

Very glad to see this being worked (I think this is really a dup of #20325). However, I think there is still and underlying (probably BIS) problem here with the recent betas. If you compare 1.59.79384 vs 1.59.81921 with no mods, you will notice that the laser seems to come from below the LOS of the SOFLAM (or Vector) and that its vertical angle seems to be exaggerated from the horizontal -- is the red dot drawn based on WepDir or LasDir? TCP's fix seems to have helped things (although I am not sure how/why), but now the spot is still misaligned with the device, just not by quite as much.

Since the problem seems to exist without ACE, I opened a CIT bug (#21026) for what I suspect may be the underlying issue.

I suggest comparing three configurations (they all seem to behave differently)
1 - Stock 1.59
2 - Stock 1.59.81921
3 - 1.59.81921 with this fix

To duplicate, drop a SOFLAM equipped unit on any island at dusk (to ease observation of the laser spot), raise the sight and observe the laser spot.

Expected behavior: The laser dot remains centered in the sight no matter where you look.

Observed behavior: When running the stock beta, as you look down the dot remains below center and moves toward you quickly. With fixed ACE & beta the dot stays close to the center, but remains low and is easily "intercepted" by bushes you are sighting over.

Updated by tcp over 4 years ago

Thanks, Beuhgler_AS for making a detailed report of your findings and putting it on the CIT. It is a BIS problem.

Weapon Dir is the direction you are aiming. Finding a fired laser relies on traveling along that path (height does not matter) and finding laser targets until the vectorDir of the laser equals the weaponDirection of the rangefinder. You would expect a laser to fire in a straight line, and this allows you to distinguish lasers even when someone fires a laser directly behind you and at the same angle.

ACE changes the zoom and the reticle so that may change how you perceive the deviation of the laser. I think ACE changes something about the viewpoint on the weapon model, but I don't know how that would affect it. ACE is obviously not changing the laser direction though because you can get exact matches of WepDir and LasDir without the A2 beta.

You can see that the Z- and Y- axis do not match. You could probably figure out the standard angle that the laser diverges on and depending on distance get an exact match again, but the divergence is probably something BI will correct.

Updated by Sickboy over 4 years ago

  • Status changed from Resolved to Closed

Available in latest ACE for OA 1.11 RC3.

Also available in: Atom PDF