Bug #20781

OFP DeRapify enum incorrect order

Added by Faguss over 3 years ago. Updated over 3 years ago.

Status:Closed Start date:06/25/2011
Priority:High Due date:
Assignee:mikero % Done:

0%

Category:DeRapify (Dos Tools)
Target version:-
Affected Version:3.52

Description

DeRapify outputs enum static values in the incorrect order. Using extracted file causes in-game problems.

Steps to reproduce:
1) Start Eliteness.
2) In options select "Resistance".
3) Open binarized file with enum.
4) Check if enum constants are in correct order.

pbodll_20781_resource_output.txt (2.4 kB) Faguss, 06/25/2011 18:23

History

Updated by Faguss over 3 years ago

Attached RESOURCE.BIN output.

Updated by mikero over 3 years ago

  • Status changed from New to In progress

excellent thank you for this, I'm assuming it's from cwa

Updated by Faguss over 3 years ago

No, it's OFP but there's no difference.

Updated by mikero over 3 years ago

fixed at dll 3.53

see enums.txt in the rar package

Updated by mikero over 3 years ago

  • Status changed from In progress to Resolved

Updated by Faguss over 3 years ago

Fix verified for version 3.53.

About the "enums.txt". Enums are necessary because they work globally (for other loaded configs) while preprocessor is obviously local.

Updated by mikero over 3 years ago

another good point. i shall revise txt in next dll release.

Updated by kju over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF