Bug #2067

Killing a UNAWARE AI unit instantly gives knowledge of the approximate shooter position to his groupies, even if they are 10km. away

Added by fabrizioT about 5 years ago. Updated over 2 years ago.

Status:Closed Start date:06/14/2009
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:AI Issues
Target version:1.03.58627
Affected ArmA II version:1.02.58064 First affected build:
Reproduced by another DH user: First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

I've added a sample mission as a repro for this issue when i posted it, it's attached.
Anyway, to keep things simple:

REPRO
-----

1) load the attached mission, you will see a specnaz soldier in front of you.
The specnaz is a member of a group, his mates and group leader have been put far away (10km) NW, in order to simulate a situation in which his groupies can't absolutely see him nor the player, so the current issue can be highlighted. You'll see a looping chat message that simply shows the specnaz "knowsabout" and his group leader "knowsabout" about you, just to check whether they're aware of your presence/position.

2) now kill the specnaz in front of you with a single shot.

3) wait a few seconds and the chat message for the group will show the victim's group has magically gained some "knowsabout" about you, as it's now about 1.4/1.5 (depending on weapon used by the player). They also instantly get as a secondary "gift" your approximate position (i've checked through the "neartargets" function).

SIDENOTE
--------

Let me add that if you swap the sniper rifle with a suppressed weapon the result is the same, the victim's groupies still gain knowledge about you in a impossible way.

EXPECTED RESULTS
----------------

Contrary of what is happening in the attached mission i wold like to see the following:

1) any unaware unit being killed by the player with a single shot should not allow any of his mates to gain any kind of information about the killer, unless they can physically see or hear something (i think a dead man can't use the radio).

2) when an unaware unit is hit and not killed by the player, then the victim should not automatically gain a FIXED knowasbout value (eg. 1.4/1.5) about the player, that should be calculated taking into account the type of weapon used by the player (= audibility) and his class / stance / concealment (= visibility).

Sorry for my bad English, regards.

#########

OLD header

Based on the provided test mission, for sake of simplicity:

When i kill with a single shot an unaware enemy 40m. in front of me (in a church courtyard), then his 10Km. far and completely out of line-of-sight group leader will perceive my position with an average error (radius) of a few meters or dozen meters (That was checked through the position given by "NEARTARGETS").
Also the "KNOWSABOUT" value for both the victim end his squaddies instantly jumps to 1.4 or 1.5 depending on the weapon i used to kill.
Using a suppressed weapon does not change the results.
Changing the AI skill level in editor does not change the results in significative way. So AI groups with maxed skill will perceive player position the same way groups with ZERO skill do.

My points are:

1) I have no problem with the victim gaining knowledge about the shooter, as long as the victim is STILL ALIVE . A single lethal shot should not raise his "KNOWSABOUT".
2) The minimum gained knowasbout value of 1.4-1.5 (for both victim and his groupies) is TOO HIGH and does not take in accout basic info such as shooter concealement, visibility and audibility.
3) Finally, as you can see, the instant broadcasting of knowsabout through groupies leads to undesired/unrealistic effects.

This behaviour of AI vanifies the benefits of docing activities such as sniping, ambushing and saboteur operations.
So it's a major issue to me.

I've also noticed that the value of "KNOWSABOUT" and player perceived position given by a "NEARTARGETS" funcion will vary depending on:

a) distance between player and victim
b) weapon used by the player

Some examples, havind D = distance between player and victim:

D <= 50m.

- kill (bodyshot) with M107: knowsabout = 1.4, player position perceived by far away AI group
- kill (bodyshot) with M249: knowsabout = 1.4, player position perceived by far away AI group
- kill (bodyshot) with M4 scoped: knowsabout = 1.5, player position perceived by far away AI group
- kill (bodyshot) with M4: knowsabout = 1.5, player position perceived by far away AI group

D = 150m.

- kill (bodyshot) with M107: knowsabout = 0, player position perceived not perceived by far away AI group
- kill (bodyshot) with M249: knowsabout = 0, player position perceived not perceived by far away AI group
- kill (bodyshot) with M4 scoped: knowsabout = 1.5, player position perceived by far away AI group
- kill (bodyshot) with M4: knowsabout = 1.5, player position perceived by far away AI group

check_AI_kill_awareness_4.Chernarus.zip - test mission (1.9 kB) fabrizioT, 06/14/2009 09:01


Related issues

related to ARMA2 Community Issue Tracker - Bug #1701: Unrealistic, Impossible Detection mechanism (AI AND Player!) Closed 06/01/2009 11/08/2009
related to ARMA2 Community Issue Tracker - Bug #2417: wounded AI gain a CONSTANT value of "knowledge" about sho... Closed 06/30/2009 08/23/2009

History

Updated by alef about 5 years ago

  • Due date set to 09/14/2009
  • Status changed from New to Assigned
  • Assignee deleted (Suma)
  • Priority changed from High to Normal
  • Target version deleted (1.01.57751)

Updated by BLUFOR about 5 years ago

Why was this changed to Normal? It's a MAJOR issue.

Updated by Spooner about 5 years ago

Both priority and assigned-to were reset because they shouldn't be able to be set by the bug reporter, but instead be applied by the admins. This was our fault for mis-configuring the system which allowed the reporter to set these values.

As to the issue, this seems to be just the same behaviour we all know from Arma 1. Whether it is a bug or just continued bad AI is not something I have any idea of. Always annoyed me before and so I really hope it is a bug rather than intended behaviour.

Updated by Squelch about 5 years ago

The instant knowsabout has been inherited from Arma. Any team member that is hit by enemy fire immediately informs the rest of the group where the attacker is. This completely dispenses with the visiblefire and audiblefire settings in config, because a silenced weapon from cover is useless for a stealthy kill.

Updated by zGuba about 5 years ago

At least satchel charges won't tell victim's team where's the guy that pushed the button... or would they again?

Updated by alef about 5 years ago

  • Affected ArmA II version changed from 1.01.57751 to 1.02.58064

Updated by kju about 5 years ago

  • Status changed from Assigned to Feedback
  • Assignee set to fabrizioT

fabrizioT Suma asked for this information:

Crucial parts of a good issue report are:

- Repro steps
- Results seen (what is the bug)
- Desired results (how should it behave once the bug is fixed)

While the issue contains some description, I cannot see any of above,
which makes understanding the issue quite time consuming. 

Please try to answer 2 and 3 as short and precise as possible.

Repro looks like:
1) Load demo mission
2) Do X
3) Do Y
4) Wait
5) Check via debug console
6) Notice A

Thank you!

Updated by fabrizioT about 5 years ago

Hi Suma,

I've added a sample mission as a repro for this issue when i posted it, it's attached.
Anyway, to keep things simple:

REPRO
-----

1) load the attached mission, you will see a specnaz soldier in front of you.
The specnaz is a member of a group, his mates and group leader have been put far away (10km) NW, in order to simulate a situation in which his groupies can't absolutely see him nor the player, so the current issue can be highlighted. You'll see a looping chat message that simply shows the specnaz "knowsabout" and his group leader "knowsabout" about you, just to check whether they're aware of your presence/position.

2) now kill the specnaz in front of you with a single shot.

3) wait a few seconds and the chat message for the group will show the victim's group has magically gained some "knowsabout" about you, as it's now about 1.4/1.5 (depending on weapon used by the player). They also instantly get as a secondary "gift" your approximate position (i've checked through the "neartargets" function).

SIDENOTE
--------

Let me add that if you swap the sniper rifle with a suppressed weapon the result is the same, the victim's groupies still gain knowledege about you in a impossible way.

EXPECTED RESULTS
----------------

Contrary of what is happening in the attached mission i wold like to see the following:

1) any unaware unit being killed by the player with a single shot should not allow any of his mates to gain any kind of information about the killer, unless they can physically see or hear something (i think a dead man can't use the radio).

2) when an unaware unit is hit and not killed by the player, then the victim should not automatically gain a FIXED knowasbout value (eg. 1.4/1.5) about the player, that should be calculated taking into account the type of weapon used by the player (= audibility) and his class / stance / concealement (= visibility).

Sorry for my bad english, regards.

Updated by kju about 5 years ago

  • Status changed from Feedback to Assigned
  • Assignee deleted (fabrizioT)

Thanks fabrizioT!

Hopefully this will do for Suma.

Still bit much text. :)
Very short bullet point is best.

Updated by Suma about 5 years ago

I have reproduced the issue. I miss repro steps and current result corresponding to issue assumed in Expected results 2], though:

2) when an unaware unit is hit and not killed by the player, then the victim should not automatically gain a FIXED knowasbout value (eg. 1.4/1.5) about the player, that should be calculated taking into account the type of weapon used by the player (= audibility) and his class / stance / concealment (= visibility).

I think the best would be to create a separate issue for this, as while they seem related, they do not seem like the same issue to me.

Updated by Suma about 5 years ago

  • Assignee set to Suma

Updated by Suma about 5 years ago

  • Status changed from Assigned to Resolved
  • Assignee changed from Suma to fabrizioT
  • Target version set to 1.03.58627

The issue is fixed in build 58190 , units killed are unable to report who killed them.

Expected result 1) now observed after fix, both with silenced and non-silenced weapons.

Expected result 2) should be tracked as a separate issue, as noted.

Assigned back for later verification.

Updated by fabrizioT about 5 years ago

That's great news, thanks Suma.

I'll create later a seperate issue for 2),
i am currently at work.

Updated by kju about 5 years ago

Suma fabrizioT posted the 2nd issue here #2417.

Updated by alef almost 5 years ago

  • Due date deleted (09/14/2009)
  • Status changed from Resolved to Closed
  • Assignee deleted (fabrizioT)

Also available in: Atom PDF