Bug #20441

Units when prone take only halve the damage

Added by kju about 4 years ago. Updated over 3 years ago.

Status:Closed Start date:06/16/2011
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Gameplay
Target version:1.60.87580
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Obs
Since OFP units when lying on the ground take only 50% of the normal damage.
At distance of 200-300m units easily can take 3-6 hits, even at the head, before dying due to this.

Exp
This feature should be disabled now and full damage according to projectile and velocity applied.

The damage reduction was to give some alternative benefit when laying down due to the lack of grass/clutter.
However since arma with the introduction of grass/clutter, this old effect should be removed.

Repro
  1. Load attached mission in the editor
  2. Hit a standing AI unit in a given location (head, body, feet, etc)
  3. Watch the overall damage in the chat
  4. Hit a lying AI unit in the same location
  5. Notice that the overall damage is only 50% (the component damage is not modified)
//headshoot - standing
["",0.660177]
["head_hit",4.44889]
["body",0.241686]
["hands",0.338347]

//headshoot - lying
["",0.330864]//50%
["head_hit",4.45412]
["body",0.0913271]
["hands",0.716662]

//legshit - standing
["",0.698003]
["head_hit",0]
["body",0]
["hands",0]
["legs",1.9014]

//legshit - lying
["",0.348945]//50%
["head_hit",0]
["body",0]
["hands",0]
["legs",1.87391]

Note
To reduce the damage for prone units from explosive damage might make sense.

HalveDamageProne.desert_e.7z (1.3 kB) kju, 09/04/2011 14:43


Related issues

related to ARMA2 Community Issue Tracker - Bug #11479: Bullets do not enough damage over distance Closed 06/26/2010
related to ARMA2 Community Issue Tracker - Bug #23553: Infantry weapon model blocks bullets, shields infantry as... Assigned 08/18/2011
related to ARMA2 Community Issue Tracker - Bug #8285: Grass layer doesn't lower "fire LOD" on infantry In progress 01/19/2010 12/01/2010

History

Updated by Hanzu about 4 years ago

I agree that in face to face probe combat head hit is much more likely since most of the body is behing head. So first hit is leathal rule should apply with higher %. But soldier is prone and is hit lets say 3 times to feet or leg damage should not be lethal so easily instead bleeding feature should apply.

Updated by kju about 4 years ago

Hanzu there are different hit zones for infantry, like head, body, hands and legs.
This is unrelated to this issue.

Updated by zGuba about 4 years ago

  • Status changed from New to Assigned

Updated by Fireball about 4 years ago

They take exactly half the damage according to my studies in the target range.

Updated by dslyecxi about 4 years ago

The damage reduction was to give some alternative benefit when laying down due to the lack of grass/clutter.
However since arma with the introduction of grass/clutter, this old effect should be removed.

I seem to recall the stated reason being that it was the simulation of microterrain, not grass/clutter. The terrain grid in A2/OA is not high enough fidelity to represent all of the cover opportunities one would have in the real world - even a seemingly 'flat' field, IRL, offers you subtle microterrain that can be used to protect you.

I personally like this feature insomuch as it's used with explosive damage. It is completely realistic to have explosions do less damage to you if you are in a lower profile, as you offer less of a profile to them and thus are less apt to be struck by shrapnel etc.

Updated by 77 about 4 years ago

kju wrote:

The damage reduction was to give some alternative benefit when laying down due to the lack of grass/clutter.
However since arma with the introduction of grass/clutter, this old effect should be removed.

Grass/clutter has a draw distance of what 20-30m... so I fail to see how it adds anything to this argument cause if you lay down to shoot at those distances you're already dead.
So this really only applies to distances where grass/clutter is not drawn anyway so its still exactly the same as ofp.

OFP at 50-10000m - no grass/clutter
ArmA 2 at 50-10000m - no grass/clutter

Updated by lukrop about 4 years ago

Currently the part of the unit which is covered by grass/clutter is sunken in the ground. See Screenshots of this ticket: #8285.

I think that is what kju means.

Updated by kju about 4 years ago

Right.

At close distance clutter already conceals the unit.
At large distance clutter already hides the unit (sunk into the ground).
Therefore no damage reduction should be applied.

To have less damage taken from explosions/bombs when lying on the ground
sounds like a sensible suggestion to me. Please create a new ticket for it.

Updated by kju almost 4 years ago

  • File HalveDamageProne.desert_e.7z added
  • Subject changed from Units when prone take less damage to Units when prone take only halve the damage
  • Description updated (diff)

Updated by kju almost 4 years ago

  • Description updated (diff)

Updated by Suma almost 4 years ago

  • Status changed from Assigned to Resolved

Implemented in 85420, including note 5 (indirect damage reduced, direct damage not).

Updated by kju almost 4 years ago

  • Due date deleted (09/16/2011)
  • Target version set to Upcoming version

Updated by kju almost 4 years ago

YAY :D

Updated by nkenny almost 4 years ago

Wow. This is a fairly substantial change. I wonder how this will affect the _meta_game and overall 'feel' of 1.60

Updated by kju almost 4 years ago

  • Target version changed from Upcoming version to 1.60 BETA

Updated by kju almost 4 years ago

  • Status changed from Resolved to Closed

works :)

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Also available in: Atom PDF