Bug #20409

AI M2 won't engage M113

Added by maturin almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:06/14/2011
Priority:Normal Due date:06/16/2011
Assignee:Robalo % Done:

100%

Category:-
Target version:1.11
Component: Affected Version:
Close Reason:

Description

The AI won't shoot at enemy M113s on their own initiative, despite the fact that the M2 can turn that vehicle into a colander. I guess it's something wrong with the cost and threat analysis.

Tested with US Army M2 Humvee at 25m, facing the side of a Takistani M113 M2.

I don't know if static M2s and other vehicles have the same result.

ace_c_vehicle.pbo (470.8 kB) Sickboy, 06/20/2011 07:13

Associated revisions

Revision 9b2d32af
Added by Robalo almost 4 years ago

~fixed: AI M2 would not engage M113, fixes #20409

History

Updated by Xeno almost 4 years ago

  • Status changed from New to Feedback

RPT please!

Updated by maturin almost 4 years ago

I tested with a static M2 and Takistani and UNO M113s, but nothing was added to the RPT.

Updated by BlackHawk almost 4 years ago

lol, they don't care about your errors so much in this case, Xeno need it to check if you aren't running conflicting addons, what versions you have, etc.

Updated by maturin almost 4 years ago

I have no reason to think that I have any conflicting addons.

This appears to be the exact same situation as my other ticket regarding Kords and APCs. It's not even an ACE bug, I don't think. Vanilla machinegunners won't engage armor because they can't hurt it. ACE gives us an armor system where 12.7mm rounds go through steel, and the configs for various weapon matchups need to be adjusted in order to make the new system functional.

Updated by Sickboy almost 4 years ago

  • Due date set to 06/16/2011

Please provide requested materials or the ticket will be set to Expired.

Updated by maturin almost 4 years ago

I didn't want to post a RPT full of soundmod errors that I knew to be inconsequential. Here's the RPT with only ACE mods running, same result.

=====================================================================
C:\Program Files\Steam\steamapps\common\arma 2 operation arrowhead\ArmA2OA.exe
"C:\Program Files\Steam\steamapps\common\arma 2 operation arrowhead\ArmA2OA.exe" "-mod=C:\Program Files\Steam\steamapps\common\arma 2;Expansion;ca;@cba;@ace;@acex;@acex_usnavy;@acex_ru" -nosplash -world=empty -showScriptErrors -maxMem=2047 -cpuCount=2 =====================================================================
Exe timestamp: 2011/04/10 17:19:50
Current time: 2011/06/16 19:34:00

Version 1.59.79384
Item str_disp_server_control listed twice
Warning: looped for animation: ca\wheeled\data\anim\uaz_cargo01_v0.rtm differs (looped now 0)! MoveName: kia_uaz_cargo02
Warning: looped for animation: ca\wheeled\data\anim\uaz_cargo01_v0.rtm differs (looped now 1)! MoveName: uaz_cargo02
Warning: Road selection asf3 has wrong name format
Warning: Road selection mud has wrong name format
[4011,102.393,0,"XEH: PreInit Started. v3.0.6"]
[4011,102.725,0,"MISSINIT","","utes",false,true,false]
[4011,129.853,0,"XEH: PreInit Finished"]
[4011,129.933,0,"XEH: VehicleCrewInit: 2"]
[5408,134.061,0,"XEH: PostInit Started"]
[5408,134.344,0,"CBA_VERSIONING",["#CBA_HASH#",["cba","ace","acex","acex_ru","acex_usnavy"],[[[0,7,5,158],-1],[[1,11,0,489],-1],[[1,11,0,333],-1],[[1,11,0,49],-1],[[1,11,0,51],-1]],[[0,0,0],0]]]
[5408,135.455,0,"XEH: PostInit Finished; [true,false,false,true,false,true,true,true,true,false]"]

Updated by Robalo almost 4 years ago

Confirmed.
Reducing armor config value from 120 to 109 for the M113 fixes it.

Updated by Robalo almost 4 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Updated by Sickboy almost 4 years ago

For testing attached fixed pbo

Updated by maturin almost 4 years ago

Yep, fixed

Updated by Sickboy almost 4 years ago

  • Assignee set to Robalo
  • Target version set to 1.11

Cheers!

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed

Available in latest ACE for OA 1.11 RC3.

Also available in: Atom PDF