Feature #20290

Combat Application Torniquet

Added by DaveP almost 4 years ago. Updated almost 3 years ago.

Status:Closed Start date:06/07/2011
Priority:Normal Due date:
Assignee:rocko % Done:

100%

Category:Complex
Target version:1.14
Component:sys_wounds Affected Version:
Close Reason:

Description

In the current ACE Medic system, while there is a way to partially and totally stop bleeding there isn't an option that feels suitable for combat first aid. Bandaging and compresses are fairly fast to put on when all is calm, but once the shit hits the fan and you've been winged in the fire-fight the time and clumsy animation (fatal if you're not in cover) just isn't suitable, and if medical support is unavailable fairly quickly (as in the case of a prolonged engagement or mid assault) you're as good as fucked.

This problem existed in the real world much as it does in ACE and the solution was the CAT -Combat Application Torniquet

For the unaware, here's a quick video showing how it works: Basically it's a simple to use mega-tightening strap that will staunch heavy arterial bleeds, whether it's a deep cut or full blown amputation
http://www.youtube.com/watch?v=Hz9qdjaHLVU

(for the less squeamish and more curious, there are videos floating about of how it looks applied to a casualty, but just imagine a stump with a lot of jam coming out and a big rubber band squeezing what's left like hot pants on a fat hooker and you get the idea)

The Combat Application Torniquet does not treat the wound itself, but rather slows the rate of fatal bleeding that is most likely to kill the patient in the case of an arterial bleed. As in real life, as in ACE: the idea would be that it's a stop-gap item, as easy to apply by the soldier as morphine or epi (or at the least able to apply while in any pose without having to go up to 'crouch up insta grot' mode!) which slows the rate of bleed out until first aid via bandages and the rest is available.

There is always a downside, of course. Applying a torniquet tight enough to stop the bleed, especially on larger limbs, is apparently excruciatingly painful. Stories from the front lines tell of soldiers who were in such agony they attempted to take off or loosen the CAT to try and lessen the pain and nearly bled out as a result. The trade off in ACE would be enhanced pain-blurring effects and/or a movement restriction like keeling over every time you go to run or something to that effect, culminating to the point where you're practically unable to function because of the pain.

As to the work needed to do this, assets wise it should be a fairly simple operation: An icon for the gear menu and a config entry for the item. The scripting itself I can only imagine would be a fairly simple endeavour, something to the effect of "Multiply time left until unconsciousness by X value, increase pain/separate pain effect (as the objective here is to avoid unconsciousness) by Y value"

If needs be I can supply a gear menu icon. I do hope you consider adding this item in, as it would add another link in the chain of a great first aid system and make it more enjoyable for all involved: More chance of survival for the soldier at the front, ergo more people to boss around for the squad leader, more people to deal with for the medic at the back.

History

Updated by DaveP almost 4 years ago

Two other points I forgot to add in:

-With regards to prolonged exposure to the torniquet, my idea would assume that when the soldier is bandaged/compressed or first-aided the torniquet is considered 'removed' and any effects are lost. Generally any longer term effects of prolonged torniquet application (ie. limb death) would not be apparent in the timescale of an average in game mission, or rather not at all fun.

-While my original idea would be that one would be able to apply the CAT to any wound (a more game like aspect that would increase survivability and gameplay), a more hardcore action would be to limit its usage to limb damage only (as much as we'd all like to put a CAT around some people's necks sometimes)

Updated by Xeno almost 4 years ago

  • Target version set to Planned (Needs Contributors)

Updated by DaveP almost 4 years ago

What needs contribution?

Updated by Xeno almost 4 years ago

Needs Contributors = none of us has the time currently to do this and if somebody has the time and motivation he may do it.
But you can always make a patch.

Updated by rye almost 4 years ago

Good post, you should be able to apply it while prone as well.

Updated by rocko almost 4 years ago

  • Category set to Complex

Updated by rocko almost 4 years ago

There is currently no way to tell wether a bleeding is caused by arterial bleeding or just bleeding. Therefore the implementation of CAT makes no sense, though it probably would be THE realistic method to stop a bleeding.

Updated by rocko almost 4 years ago

  • Component set to sys_wounds

Updated by DaveP almost 4 years ago

rocko wrote:

There is currently no way to tell wether a bleeding is caused by arterial bleeding or just bleeding. Therefore the implementation of CAT makes no sense, though it probably would be THE realistic method to stop a bleeding.

If you're going along that line then one could argue not everyone who is unconscious is suffering from heart failure and needs epinephrine, ergo its implementation makes even less sense.

The majority of bleeding episodes in armed assault that this would benefit are situations where not taking any action results in unconsciousness within a minute or two, that certainly sounds like a major arterial bleed to me

Updated by rocko almost 3 years ago

  • Status changed from New to In progress
  • Assignee set to rocko
  • Target version changed from Planned (Needs Contributors) to 1.14
  • % Done changed from 0 to 50

Updated by rocko almost 3 years ago

  • Status changed from In progress to Resolved
  • % Done changed from 50 to 100

CAT added.

The CAT will stop current bloodloss. It does not 'heal' wounds. You still need bandages or trauma bandages (formerly known as 'compress') to heal wounds.
Applying a CAT to yourself or another player will show the message "He is marked with 'T'" along with the option to remove the CAT again.
Removing the CAT without applying bandages will cause the bloodloss to start again. So all wounds need to be treated before the CAT can be taken off.

An applied CAT will start to increase the pain of the casulty after ~3 minutes, so it might happen that even if you or the casulty are stable you fall unconscious.

Note on pain: Pain will now only increase when you move around (as in every step hurts) or when you carry a CAT or when you are shot again.

Updated by rocko almost 3 years ago

  • Status changed from Resolved to Closed

Available on SU.

Also available in: Atom PDF