Bug #20227

[HR] Manhattan mission [Multiplayer] letting Father Fyodor keep weapons results Bitter Chill NAPA Alesh Vokurka saying "...you took those weapons from Father Fyodor..."

Added by Hanzu about 4 years ago. Updated over 3 years ago.

Status:Closed Start date:06/04/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Campaign
Target version:1.11.86734
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:1.54.72888
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Reproduce method 1:

Play Manhattan and Search Gorka at GPS GOORDS 094065
While discussing with Father Fyodor in that location choose "2 I won't report it." and wait for discussion to finish and autosave to happen.
Play all the way to Bitter Chill where NAPA Alesh Vokurka and his men show up to bombed FOB Manhattan

Reproduce method 2:
Place attached savegamefiles to ...Saved\ca\missions\campaign folder
Choose Singleplayer->Campaign->Host->OK->Continue->OK->Resume and walk to GPS GOORDS 094065
While discussing with Father Fyodor in that location choose "2 I won't report it." and wait for discussion to finish and autosave to happen.
Starforce 21 is waiting in the ground noth part of Gorka (with other team members inside) so all you need to do to finish the mission is to fly to FOB Manhattan and report to Cpt. Shaftoe
After that start Bitter Chill and play to a situation where NAPA Alesh Vokurka and his men show up to bombed FOB Manhattan

Observe:
In Bitter Chill after FOB Manhattan is attacked
NAPA fighters will come from east
Go talk to them
NAPA fighter squad leader Alesh Vokurka will say "...you took those weapons from Father Fyodor..."
and after discussion he leaves and says "You'll have to take your chances I guess. If you'd been more understanding of your position, maybe we could have helped more. Farewell marines."
Also if you still decide to follow them they will not lead you to Red Hatchback
Going to Red Hatchback and entering it without NAPA escort will not trigger anything. NAPA civilian driver will not drive.

Expected:
NAPA fighter squad leader Alesh Vokurka should offer their help because you chose not to report Gorka weapons and they should say something like "follow us" and not "farewell marines"
NAPA fighter(s) should offer to lead you to Red Hatchback and entering it should trigger the driver to drive you.

Notes:
This bug appears in Arma2 Combined Operations only. A2 only side works fine
I first noticed it with 1.54 while playing cooperatively with friends
I have also reproduced it with 1.59.79384, 1.59.79600 and 1.59.81423.
Attached multiplayer savegames for Manhattan mission were played with 1.59.81423 (beta), but you need to play at least Bitter Chill part of the repro with 1.59.79384 (full), because 1.59.81423 (beta) made Bitter Chill to not to work which is not at all related to this issue but just for curiousity see my other report for that issue: http://git.dev-heaven.net/issues/15621#note-2

1.59.81423_Manhattan_at_Gorka_before_reporting_cache_savegamefiles.7z - savegamefiles (21.4 MB) Hanzu, 06/04/2011 22:40

arma2oa_2011-05-31_21-41-34-08.jpg - 2 I won't report it. (407.9 kB) Hanzu, 06/04/2011 22:40

arma2oa_2011-05-31_21-41-59-86.jpg - "OK Father, I won't report this, but you have to help me now." (384.2 kB) Hanzu, 06/04/2011 22:40

arma2OA_2011-06-02_01-18-45-79.jpg - ...We know how you took those weapons from Father Fyodor... (318.9 kB) Hanzu, 06/04/2011 22:40

arma2OA_2011-06-02_01-19-03-92.jpg - 2. OK, where's Fyodor? (313.8 kB) Hanzu, 06/04/2011 22:40

arma2OA_2011-06-02_01-19-44-98.jpg - ...Farewell marines." (289.9 kB) Hanzu, 06/04/2011 22:40


Related issues

related to ARMA2 Community Issue Tracker - Bug #15016: [HR] Manhattan mission [Multiplayer] does not recognize c... Closed 11/10/2010

History

Updated by Hanzu about 4 years ago

Tested also now that choosing "1 I must report it." and "2 I won't report it." in Manhattan gives exactly same results in Bitter Chill.

Updated by Fireball about 4 years ago

  • Due date set to 09/04/2011
  • Status changed from New to Assigned
  • Assignee set to Dwarden

Updated by Hanzu about 4 years ago

Discussion about the bug here:
http://forums.bistudio.com/showthread.php?p=1947625

If no time to read above link, I make it short for you:
Bug only occurs with Arma2 Combined Operations multiplayer. With A2 Only there is no such bug.

Updated by Hanzu almost 4 years ago

  • Subject changed from Manhattan letting Father Fyodor keep weapons results Bitter Chill NAPA Alesh Vokurka saying "...you took those weapons from Father Fyodor..." and refuse to escort. to [HR] Manhattan mission [Multiplayer] letting Father Fyodor keep weapons results Bitter Chill NAPA Alesh Vokurka saying "...you took those weapons from Father Fyodor..."
  • Description updated (diff)
  • Due date changed from 09/04/2011 to 01/17/2012
  • Maxmem parameter deleted (Not set)
  • Difficulty deleted (Expert)
  • First affected ArmA II version set to 1.54.72888

Updated by Hanzu almost 4 years ago

  • Status changed from Assigned to In progress

I've finally identified and isolated those skipped debriefing screens and decisions forgotten between campaign missions. Both are MP-only and programmers have been informed.

http://forums.bistudio.com/showpost.php?p=2039860&postcount=22

Updated by Hanzu almost 4 years ago

  • Due date deleted (01/17/2012)
  • Status changed from In progress to Closed
  • Assignee deleted (Dwarden)

ARMA2_OA_Build_85876.zip
changelog.txt
[85737] Fixed: SaveVar did not work in MP Campaign.

Tested and confirmed fixed. Good work BIS!

Updated by kju almost 4 years ago

  • Target version set to 1.60 BETA

Updated by Dwarden over 3 years ago

  • Target version changed from 1.60 BETA to Upcoming version A2

Updated by kju over 3 years ago

  • Target version changed from Upcoming version A2 to 1.11 BETA

Updated by kju over 3 years ago

  • Target version changed from 1.11 BETA to 1.11.86734

Also available in: Atom PDF