Bug #20020

Quote in HK417 12' Shortdot name

Added by Mikhail about 4 years ago. Updated about 4 years ago.

Status:Rejected Start date:05/24/2011
Priority:Trivial Due date:
Assignee:- % Done:

0%

Category:-
Target version:-
Component: Affected Version:
Close Reason:

Description

Bug is minor or may be not a bug at all. But I was really puzzled for some time when my javascript confirmation stopped working while dealing with particularly HK417 12' weapons on my website. I figured out it has this singlequote. I killed this quote in my database, but I guess it can cause somebody trouble someday again.
Btw, it's the only weapon with a singlequote in name in the whole Config Browser weaponset. :)

History

Updated by rocko about 4 years ago

from config:

displayName = "HK417 12'' Shortdot";

Not sure if we can change it, since using " after 12 would break it. Confirmed working substitutes for double single quotas, anyone?

Updated by Sickboy about 4 years ago

  • Status changed from New to Rejected

The problem is in your code, always escape database insertion and before you render the data.

Rocko, normally you'd escape with '\', not sure if that works here.
displayName = "HK417 12\" Shortdot";

Updated by Mikhail about 4 years ago

No problem, I know I should have escaped it, but since it's the only one instance of a singlequote in weapons names in the whole config I decided to inform you. Just in case it matters.

Also available in: Atom PDF