Task #20015

Map zoom limitation feedback

Added by admin almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:05/24/2011
Priority:Normal Due date:06/03/2011
Assignee:Nou % Done:

100%

Category:-
Target version:1.11
Component: Affected Version:
Close Reason:

Description

Please take note that the Map Zoom limitation can be configured,
both per mission and globally / server side: http://dev-heaven.net/issues/19959#note-3


Related issues

related to A.C.E. for OA - Bug #19959: Map zoom limitation override broken Closed 05/22/2011

Associated revisions

Revision 91121981
Added by Sickboy over 3 years ago

~ CHANGED: MapZoomLimitation now optional, enable with ace_sys_map_auto_limit = true. closes #20015

History

Updated by Sickboy almost 4 years ago

  • Status changed from New to Feedback
  • Assignee set to Nou
  • Target version set to 1.11

Updated by Nou almost 4 years ago

My stance on this is that the map is a map, a piece of paper, not-digital, not magical, and it should be treated as such. If people want a more advanced map, suggest pieces of equipment that soldiers carry show this detail, and I will look into modeling them.

Updated by Sickboy almost 4 years ago

By BTK:

  • It's not realistic. It's not enhancing the ACE mod or ArmA in any way. It's just annoying.
  • It's especially annoying for mission makers. Not in the editor but while testing.

By Ugly58:

25,000, Sat Imagery , Aerial Photos , GRGs all of which are way below 50,000 scale are available to near anyone. Geo Teams are down to lower level than ever before. Falconview and Google Earth are in most headquarters, all connected to image libraries with printers. > In fact what wound be more realistic is being able to zoom into Texture View to represent the above.

Yes its disabled by Script but I think its a move away from realism.

Updated by Sickboy almost 4 years ago

Nou wrote:

My stance on this is that the map is a map, a piece of paper, not-digital, not magical, and it should be treated as such. If people want a more advanced map, suggest pieces of equipment that soldiers carry show this detail, and I will look into modeling them.

Good points, there already is the GPS / DAGR, what's next in line?

Updated by Nou almost 4 years ago

Sickboy wrote:

Nou wrote:

My stance on this is that the map is a map, a piece of paper, not-digital, not magical, and it should be treated as such. If people want a more advanced map, suggest pieces of equipment that soldiers carry show this detail, and I will look into modeling them.

Good points, there already is the GPS / DAGR, what's next in line?

Something along the lines of FBCB2 (aka Blue Force Tracker) for vehicles. I've seen some stuff on COTS cellphone tech being upgraded and hardened and used along with Google Android to provide mapping and intelligence.

Really though FBCB2 is the next step, at least IMO in regards to ACE. Its a complete combat logistics platform, capable of handling reported positions of enemies, positions of friendlies, status of assets, etc. It is something that could easily have a simple version made and "modules" added to it if we wrote the systems right.

I have messed around with a few things already a year or so ago: http://www.youtube.com/watch?v=ZiK9A35_RQ0

Updated by Nou almost 4 years ago

For anyone who thinks using a 4 digit map is difficult (and I know UGLY58 doesn't, at least I hope not :P) then watch this: http://youtu.be/sbzwIF0b89A

It's incredibly easy, especially if you are using the map tools.

Updated by tonci87 almost 4 years ago

I don't know if that limitation thing is such a good idea. Yes it may be realistic, but it can become a real Problem when you have to call in Firesupport via Mapclick (Bis Arty module). Sometimes the marker is not set where the mouse points at, but more to the south east (at least for me). It doesn´t happen every time, and when it happens the distance to the original click point also varies. So I always made sure that I zoom in before setting the marker to get it accurate. This obviously doesn't work now.

Updated by Sickboy almost 4 years ago

tonci87 wrote:

I don't know if that limitation thing is such a good idea. Yes it may be realistic, but it can become a real Problem when you have to call in Firesupport via Mapclick (Bis Arty module). Sometimes the marker is not set where the mouse points at, but more to the south east (at least for me). It doesn´t happen every time, and when it happens the distance to the original click point also varies. So I always made sure that I zoom in before setting the marker to get it accurate. This obviously doesn't work now.

Ty for posting, after reconsidartion, if the only argument is the BIS arty, i'd say a BI arty patch should be written for that problem :)

In any case, also check the ticket description - you can easily change the limitation your self mission wide, game wide or even server wide.

Updated by Franklin almost 4 years ago

I'm cool with taking away the smaller grids, but only if you give me a protractor that lets me find a grid the right way. Without that, this is a stupid idea.

http://www.traditioncreek.com/storefront/images/products_supplies/map_protractor.gif

Updated by Nou almost 4 years ago

You can use the current map tools to do it. :)

The below instructions are for the 1:25,000 scale markings (the outermost), after next update they will be for the 1:50,000 (the next markings in).

For finding a grid ref: Just place the upper right hand corner of the map tools on the place you are wanting to find. Find the number of where the left most and bottom most grid lines intersect the map tools. Note these, and then for the easting (the left to right numbers) take the easting number (for example 06) and append the number to it, either rounding any decimals or removing them. Do the same for northings, except if you are on a map that has northings reversed (pre-OA style) subtract the number from 10 first to account for the direction of increment. Balance out the size of the northing and easting, so they have the same number of digits (add 0s basically to the shorter side) and you are done.

For finding a maploc: Do the same as above but in reverse. Find the 4 digit grid ref (the first two from northing and easting), then line up the numbers on the ruler edges to the left most and bottom most grid lines in that grid. The upper right hand corner is the location of the ref.

tonci87 wrote:

I don't know if that limitation thing is such a good idea. Yes it may be realistic, but it can become a real Problem when you have to call in Firesupport via Mapclick (Bis Arty module). Sometimes the marker is not set where the mouse points at, but more to the south east (at least for me). It doesn´t happen every time, and when it happens the distance to the original click point also varies. So I always made sure that I zoom in before setting the marker to get it accurate. This obviously doesn't work now.

You haven't even tried it. It works fine. Like I told you on BIF, it only effects the main map screen, the one you get when you press M, nothing else. Unless there is a way to call in arty via AI on the normal map?

Updated by Cleric2145 almost 4 years ago

Clicking in the arty map and getting a different location than your click is caused by an obstruction. Your round will be aimed at where you click, but the impact will be on the "X." This can be a hill, building, or anything really.

Updated by VKing almost 4 years ago

I think it's fine. You can find your position to 6-8 digits using the map tools, and you can opt-out if you want to.

Updated by rocko almost 4 years ago

  • Due date set to 06/03/2011

Updated by Franklin almost 4 years ago

deleted

Updated by Nou almost 4 years ago

:)

Updated by sgtmoody1944 almost 4 years ago

No more limitation?

Updated by Nou almost 4 years ago

No? Franklin deleted his post. :P I deleted my response since it wasn't relevant anymore. :D

Updated by dslyecxi almost 4 years ago

So long as features like this allow you to perma opt-out, I don't really mind. The day it's forced, though... ;)

Updated by UGLY58 almost 4 years ago

As I tried to say in the earlier thread.

Guys are walking around with printed and annotated aerial photos and stuff these days. Paper maps are no longer just paper maps, they are now annotated and marked GRGs, with all sorts of relevant data on. I stand by my earlier comments, more realistic would be being able turn on textures in map screen like in the editor. I am not talking FBCB2 or any digital pda etc. I am talking paper map here.

What I really wish for is an editor tool where I can permanently make marks whilst creating a mission. If those marks would appear on everyones in game map, now that would be something.

Updated by TheBigHerm almost 4 years ago

The last time 50,000 scale was used in a modern battlefield was probably vietnam...MAYBE SOME 50,000 scale maps were disseminated in Desert Storm in 1991. During my tours in Iraq we left with pre-printed aerial imaging provided by battalion S-2 and Our Vehicles had FBCB2 if we needed grid references. I carried a DAGR but, to be honest, without my map and being able to point out the house that I am looking for...a map is a piece of paper that I might as well light my cigarette with.

Updated by VKing almost 4 years ago

Good thing the in-game maps are 1:25000 then :)

Updated by Nou almost 4 years ago

They are technically 1:50,000 (according to the Map Tools now in repo), but the detail might as well be 1:25,000 at least...

All the 1:25,000 maps I have seen searching are still 4 digit grids (they do have nice little hash marks for the 6 digits though, I might be able to replicate that). See: http://www.lib.utexas.edu/maps/europe/zagreb_1995.jpg

Ugly, GRG = Gridded Reference Graphic I assume? I understand how those would show 6 digits. Actually I had an idea on how to implement something sort of like that... :P It'd be an item (I guess as a GRG book?) that would have more detailed 6 digit views of specific locations in the game (which wouldnt be hard to do because all cities are able to be referenced via the location commands).

That way you could view more detailed areas of specific maps. :P

Also adding in rugged PDA devices would be in the future, along with FBCB2 style things.

Updated by Militantsausage almost 4 years ago

besides all of this Nou, one thign I notice is that in Real life it is much easier to look at finer details on a map and mark precisely, whereas because of the limitations of this being a game having it 'zoomed out' makes marking the map harder and also harder to look at contour lines, and also since you can't look closely it is incredibly hard to get a specific grid.

Updated by TheBigHerm almost 4 years ago

I agree with everything militant had to say. In real life, if I cant make out a land mass or terrain feature I can hold the map up to my face and look a bit more closely. With the limitation being imposed I would have to put my nose on my monitor...and even then things wouldnt come into view anymore because of the limitations of detail at such zoomed levels.

This is an example of the type of photographs a section leader/platoon sgt or Platoon Leaders would walk out of the wire with;

http://www.talkingproud.us/Military/FallujahIntro/FallujahAirPower/files/page54-nov14satimage.jpg

My point being this, I, as a commander of a rather large unit, don't have the time NOR the patience to learn another piece of equipment because someone has a skewed perception of how tactical operations are carried out. Sure, it would be "neat-o mosquito" to have yet another piece of equipment to clog up the ACE boxes but in reality a map and a compass and aerial photographs are all that are used. Yeah, I had a DAGR and FBCB2. I used those things to call in to battalion to let them know my 10 digit.

A map works just fine...well did, anyhow.

Updated by Sickboy over 3 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Updated by Sickboy over 3 years ago

I've made it optional for the time being due to given motivations, while anyone wanting it enabled can enable it by;
ace_sys_map_auto_limit = true;
Even game wide by creating a small config addon, or server wide by putting such addon on the server.

class Extended_PreInit_EventHandlers {
    class my_ace_sys_map_override {
        serverInit = "ace_sys_map_auto_limit = true; publicVariable 'ace_sys_map_auto_limit'";
    };
};

Works from a mission description.ext and addon config.

We can re-evaluate it at a later time if there's a clear plan / set of tools/items that give people what they need.

Updated by Nou over 3 years ago

TheBigHerm wrote:

The last time 50,000 scale was used in a modern battlefield was probably vietnam...MAYBE SOME 50,000 scale maps were disseminated in Desert Storm in 1991. During my tours in Iraq we left with pre-printed aerial imaging provided by battalion S-2 and Our Vehicles had FBCB2 if we needed grid references. I carried a DAGR but, to be honest, without my map and being able to point out the house that I am looking for...a map is a piece of paper that I might as well light my cigarette with.

This is complete BS. What Army is this? I just read this to an actual serving Major in the US Army who plays at UO and said that is total crap. He carried a 1:50,000 map in his front pocket during all his tours.

He said something about a spoon as well.... ;)

The basic facts are that they use 1:50,000 maps still, very often. If you need to hit a specific village then they have reference graphics, satellite photos, etc.

If we can replicate this I think it would be best.

Also for example here are some 1:50,000 maps:
http://www.lib.utexas.edu/maps/topo/texas/txu-pclmaps-topo-tx-barksdale-1947.jpg
http://www.lib.utexas.edu/maps/topo/texas/txu-pclmaps-topo-tx-paris-1948b.jpg <-- Notice, they do not even show most of the buildings in the town. ;)
http://www.lib.utexas.edu/maps/topo/texas/txu-pclmaps-topo-tx-panther_junction-1990.jpg

Updated by VKing over 3 years ago

All the maps I ever used in the (Norwegian) army were 1:50000 as well, very similar to the ones Nou linked (standardization, hey!).

Updated by TheBigHerm over 3 years ago

Thank you, Nou, for showing me what a 1:50,000 map looks like...I didn't know before you showed me /sarcasm

Nou Said -"This is complete BS. What Army is this? I just read this to an actual serving Major in the US Army who plays at UO and said that is total crap. He carried a 1:50,000 map in his front pocket during all his tours"

How many times did he pull it out of his pocket? :) ...and to go even further, being a major How many times did he leave the wire with a fire team to go kicking in doors? My point exactly.

Basically what I am saying here, Nou, is that your decision to take away the commander's ability to Task Organize large groups of guys from a map while looking at buildings and terrain features in depth was both a silly idea and an unrealistic one... But what do I know, I'm not a Major. I was just the guy with aerial recon photos and more detailed maps that was actually kicking in doors while that Major friend of yours did photo ops for Public Affairs.

There is a difference between those who do and those who have the pay grade that don't have to do.

btw, thank you Sickboy for making this horrible addition optional. There really is no reason to reply to my thread as long as this crap is optional. In fact, if it is too abrasive you can delete it. There is realistic and there is being overly realistic beyond the facets of flowing gameplay.

Updated by sgtmoody1944 over 3 years ago

Okay, why don't we just put this to like a public vote and define the green up as being in favor of this option and the red down as being in favor of making this zoom limitation optional/removing it...

Updated by Sickboy over 3 years ago

  • Status changed from Resolved to Closed

Should be available in the earlier released 1.11 RC1.

Also available in: Atom PDF