Bug #19530

Characters holding the weapon too low and too far away?

Added by Titis almost 4 years ago. Updated almost 4 years ago.

Status:Closed Start date:05/05/2011
Priority:Low Due date:
Assignee:smookie % Done:

0%

Category:Config
Target version:Future releases
I am using some Mods:No

Description

When standing still and walking slowly, the character holds his weapon much lower and much further away from his body than when in the tactical jog with the weapon up. This results in the fact than with many weapons, there is a noticeable gap of several centimeters between the character' s body and the weapon' s stock, and it makes the character appear to be looking way above the sights, instead of more or less through them.

Would it be possible, if it' s not too much work from you, to make the character hold his weapon the same way than he does in the tactical jog with the weapon up when standing still and in the slower movement speeds? The drawback would be that there might be a tiny bit of clipping between the weapon' s stock and the character' s body armor' s shoulder pad when using a weapon with a long stock such as an m16 and a character model that has a body armor, and that it would look downright awkward with a few massive weapons such as the m107, but in my opynion the visual benefits with most of the weapons outweight the drawbacks with a few weapons such as the m107, the ksvk...etc.

PS: I made a few vids with fraps to illustrate the problem, but they are massive, what should i do to make them smaller?

History

Updated by smookie almost 4 years ago

You can always post the videos on youtube (it will comperss them automatically). I for one also use Any Video Converter which is free afaik and gets your videos into wmv relatively fast.

I understand your problem and concern about the visual aspect of this thing, but it was done this way to:
- get rid of the "right corner rule" bug (you can use optics to kill enemies without exposing yourself too much)
- increase the field of view of the player.

Updated by Titis almost 4 years ago

Here is a first vid, using an m4 from Robert Hammer' s m4 m16 pack. I found the problem to be particuly obvious using RH weapons: http://www.youtube.com/watch?v=XNrwXKn6kx0

And here is another vid, this time using the mk17 cco from vanilla arrowhead. As you can see the problem is less obvious but there is still a noticeable gap: http://www.youtube.com/watch?v=WHYs7M5f6eE

Thank you for explaining the reasoning behind it.

Updated by Reezo almost 4 years ago

  • Category set to Config
  • Status changed from New to Assigned
  • Assignee set to smookie

Updated by Titis almost 4 years ago

I see that it has been assigned, does that mean that there is going to be changes? Since Smookie explained the reasoning behind it, i thought that it would stay the way it is. If something is being done about it, Thank you! If it' s not the case, thanks any way for takind the time to check it out.

Updated by Reezo almost 4 years ago

Titis wrote:

I see that it has been assigned, does that mean that there is going to be changes? Since Smookie explained the reasoning behind it, i thought that it would stay the way it is. If something is being done about it, Thank you! If it' s not the case, thanks any way for takind the time to check it out.

It only means it has been assigned. It is not in progress. The assignee will then treat the ticket according to his jurisdiction.

Updated by Titis almost 4 years ago

I see, thanks for the explanation.

Updated by Reezo almost 4 years ago

  • Priority changed from Normal to Low

Updated by Reezo almost 4 years ago

  • Status changed from Assigned to Closed
  • Target version set to Future releases

I don't think this will ever be considered for v0.25 as it would imply reworking the animations.

Therefore, closed for now.

Also available in: Atom PDF