Bug #19267

AI Teams: Stuck, Will Not Move

Added by JuggernautOfWar over 4 years ago. Updated about 4 years ago.

Status:Assigned Start date:04/29/2011
Priority:Normal Due date:
Assignee:Benny % Done:

0%

Category:-
Target version:-
Affected Version:2.068 I am using some Mods:No
Affected ArmA II version:Please select... Reproducible for you:Yes

Description

For some reason the AI team leaders are clustering at exactly grid coordinates 000;000. They wont move, respawn, or anything. If I tell them to disband they'll disappear and just respawn in the same spot, thus their entire AI teams are unresponsive.

At first none of the leaders do this, but as the game progresses more and more succumb to the dreaded bug.

This happens in 2.068 and 2.067 ACE Edition.

I am not using any AI mods whatsoever.

Capture.JPG - Example on map. (52.7 kB) JuggernautOfWar, 04/29/2011 22:51

Capture1.JPG - As you can see many squads (opfor and blufor) are at 000;000, even in the water. (70.9 kB) JuggernautOfWar, 05/01/2011 09:23

Capture2.JPG - Because of this bug AI troops within each squad just sit where they are bought waiting for their CO. (154 kB) JuggernautOfWar, 05/01/2011 09:23

Capture3.JPG - This is about half of the tanks just sitting at my base. (120.8 kB) JuggernautOfWar, 05/01/2011 09:23

Capture4.JPG - Image of 000;000 before any AI squads got stuck there, very start of the match. What is that? Might be the problem? (12.1 kB) JuggernautOfWar, 05/01/2011 12:04

History

Updated by Benny over 4 years ago

  • Status changed from New to Assigned
  • Assignee set to Benny

This is on a dedicated server right?

Updated by JuggernautOfWar over 4 years ago

Yes sir, it sure is. I've tried multiple parameter setups and configurations, all the same outcome. I tried hosting locally just to see. Sure enough the problem persists the same whether it's local or dedicated. This happens on Chernarus, Takistan, and Zargabad. I cannot test the other maps.

From more extensive testing I've also noticed the opposing teams leaders spawning in the same exact location and occasionally getting stuck. As a command I can access the HC module and I can see enemy team leader NATO icons mixed in with friendly forces. Neither of them attack one another. Quite strange.

I've also tried giving them manual waypoints, no dice.

Updated by JuggernautOfWar over 4 years ago

Update with some more images. I've tried all maps, dedicated, local, different local host (friend), AI commanding, player commanding, etc. Happens every time. This is pretty game-breaking for us really, and it's too bad. Keep in mind some squads are working perfectly fine, just not many. I have tried with and without mods now, same.\

It's almost like the AI for the squad leaders just "dies" after a while. Maybe it gets too overworked, maybe it gets confused, or possibly there's a loophole in your AI coding causing an infinite loop of respawns or similar?

EDIT: Is there a possibly it's caused by one of the modules? Especially UPSMON or whatever that is. I have no idea what that even does.

Updated by JuggernautOfWar over 4 years ago

Also available in: Atom PDF