Bug #19156

Danger mode: units moving extremely slow when ordered to move / advance, without Bounding Overwatch

Added by fabrizioT about 4 years ago. Updated almost 3 years ago.

Status:Rejected Start date:04/23/2011
Priority:Normal Due date:07/23/2011
Assignee:- % Done:

0%

Category:AI Issues
Target version:-
Affected ArmA II version:1.60 BETA First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Conditions:
  • ArmA2 BETA 1.60 build 59600
  • Player is leader of a infantry group
  • Group is set in danger mode (7-2)
Observed behaviour:
  • if you select multiple units and order them to move or to advance (1-2) they don't use bounding overwatch. Units move all at once in rigid formation, EXTREMELY SLOWLY. They often move in prone stance even if there's no enemy around. This behaviour is useless: no units wait in cover to eventually provide suppressive fire + slow movement in the open make them easy targets.
Expected behaviour:
  • units should move FASTER by properly doing bounding overwatch (the same way they do when they follow the leader in danger mode).
Repro:
  • Run attached mission
  • select all units
  • put them in danger mode (7-2)
  • order them to move far away
  • observe behaviour

_DANGER_BUG.Takistan.zip (1.5 kB) fabrizioT, 04/23/2011 22:29

_DANGER_BUG_OA.Takistan.zip (1.4 kB) fabrizioT, 04/25/2011 20:43


Related issues

related to ARMA2 Community Issue Tracker - Feature #23151: Add new scripting command: combatBehavior and setCombatBe... Assigned 08/05/2011
related to ARMA2 Community Issue Tracker - Feature #12895: Make Danger mode overridable and apply to fireteams only Assigned 08/13/2010

History

Updated by maturin about 4 years ago

In my experience units given Move orders abandon bounding overwatch and move rather quickly. This is by design.

I do not experience them moving extremely slowly. Units ins danger mode will usually choose to run rather than crawl.

And I think at this point the development of this very old issue, we can conclude that the AI is incapable of moving quickly while using bounding overwatch. BIS apparently does not want to overhaul the behavior to allow for fast movement.

Updated by CameronMcDonald about 4 years ago

If memory serves the decision to abandon pepperpotting during "move" and "get in" orders is, as maturin suggests, introduced. This was in order to prevent players offing themselves when they tell their section to board a transport under fire, only for everyone including said transport to be reduced to matchbox-size pieces due to the AI taking an inordinate amount of time to follow their commands.

Updated by kju about 4 years ago

A getIn order or heal AT should be definitely be without bounding overwatch.
A move to order should remain without too IMHO as it is your job as a leader to give sensible orders.

Setting units to advance might be something worth to discuss.

That said in the end it shows that a direct control over bounding overwatch would be the real solution.
Both commanding and scripting wise.

Updated by fabrizioT about 4 years ago

Hi all,

please run the attached repro. As i said, at least for me, units are moving extremely slowly, and often move in prone stance.
If confirmed i think this alone would be an issue.

About bounding overwatch: i agree with kju that direct control would be the ideal solution.
Generally talking about at least advancing i still think bounding overwatch it's needed, unless cover around is just for beauty ;)

Updated by Voyage34 about 4 years ago

My units used to move quickly, but running your repro they effectively are really slow, and they tend to crawl.
By the way that is the same behaviour of the delta formation (please see Bug #19072), just applied to a wedge formation: they avoid bounding overwatch, and tend to go prone (if the leader crawls the rest of the squad crawls, at least until the leader starts running again).

Maybe a compromise would be no bounding overwatch when ordering to move to a single unit, and yes for multiple. If it's not possible I prefer no bounding overwatch at all (at least on move orders), as kju said about "sensible orders".

Updated by Fireball about 4 years ago

  • Subject changed from Danger mode: selected units not using bounding overwatch when orderd to move / advance to Danger mode: selected units moving extremely slow when orderd to move / advance despite of not using bounding overwatch
  • Due date set to 07/23/2011
  • Status changed from New to Assigned

So FabrizioT, lemme bend around that bug subject then: it's about them being extremely slow while in danger mode despite of no bounding overwatch used. Did I get that right?

Updated by Fireball about 4 years ago

  • Reproduced by another DH user changed from No to Yes
  • Reproducible for you changed from No to Yes

Updated by fabrizioT about 4 years ago

@Fireball:
let's put it that way :)
However, as a sidenote, let me insist bounding overwatch is much needed at least when issuing a advance order ;)

On topic: Just an idea, maybe regular ArmA2 units move slow while OA units move fast? Sounds strange but ...

Updated by fabrizioT about 4 years ago

Update: tested with BAF/US ARMY units.

  • when BAF/US ARMY units are ordered to move they exhibit the same problem (slow moving, no BO).
  • when BAF/US ARMY units are ordered to advance they move ok and already use bounding overwatch (so they're 100% right to me).

SO there's some kind of mismatch in "advancing" behaviour between ArmA2 units (bad) and ArmA2 OA units (fine), while "moving" is much slow for both.

Updated by fabrizioT about 4 years ago

Added repro with US ARMY/OA units.

Updated by Fireball about 4 years ago

  • Subject changed from Danger mode: selected units moving extremely slow when orderd to move / advance despite of not using bounding overwatch to Danger mode: units moving extremely slow when ordered to move / advance, without Bounding Overwatch
  • I am using set to A2 only

Updated by Fireball about 4 years ago

  • I am using changed from A2 only to CO (OA+A2)

Updated by fabrizioT almost 4 years ago

Fireball i see this labeled as "Assigned", but no Assignee. Is it intentional?

Updated by Kenquinn about 3 years ago

Tested with beta 1.60.89233. In both tests four AI were ordered to move in danger mode.

Observations:

There are two differing sets of behavior depending on where you order the AI to move to.

Moving SE down the road:

The AI moves down the road forming into a wedge formation.
The AI jogs for a bit, then slows to a walk with their gun up for a few seconds and returns to a jog.
The AI repeats the patter of jogging and walking until they reach their objective.
The AI stop at the end and lie down trying to provide 360° security.
No bounding overwatch is used by the AI and try to stay in a wedge formation.

Moving NW towards a building in the town:

The AI starts moving into the city while forming into a wedge formation.
The AI repeats the jog/walk routine from the first test, but breaks wedge formation in the close quarters of the city.
The AI follows walls and uses cover slightly when moving in the city, but not enough to slow them down.
Once the AI reaches the house they were order to move to they either garrison themselves in it, or create a perimeter outside the house.

Conclusion:

I can not reproduce the issue of AI moving extremely slow without bounding overwatch. In both moving down an open road, or inside the city the AI kept to a jog the majority of the time.

Updated by Fireball about 3 years ago

  • Status changed from Assigned to Rejected

Cheers. Going with your research until proven otherwise.

Also available in: Atom PDF