Feature #19069

Position of units in formation should be relative to leader instead to the preceeding unit

Added by Voyage34 over 4 years ago. Updated almost 4 years ago.

Status:Closed Start date:04/20/2011
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:AI Issues
Target version:-
Affected ArmA II version:1.60 BETA First affected ArmA II version:
Reproduced by another DH user:Yes Single / Multi Player?:
I am using some Mods:No BIForumURL:
I am using:CO (OA+A2) NGUrl:
Reproducible for you:Yes WIKIurl:
Related to content of DLC:

Description

Actually:
The position of an AI unit in formation is relative to the preceeding unit in formation, rather than relative to the leader.

Obs:
This may lead to some unexpected behaviour, like:
-if leader moves fast, formations tend to get stretched forward, due to tendency of the last units in formation to remain back (long delay before move)
-if the preceeding unit is stuck, or simply doesn't move, the rest of the formation gets stuck too
-formation can tend to lose its shape, expecially in urban areas, due to an "error propagation" in finding the right position: example: 1 leads, 2 moves in a position approx. where it should be, 3 moves in a position approx where it should be (but relative to 2 - who has approximated his position), 4 approximates "3 times" the position, and on like that.

Note: the movement order (1 moves, then 2, then 3, ..) works very well for me, so I'm not asking for changing it.

Exp:
Unit position in formation should be relative to the leader, assuring a better shape to the formation itself.

COLUMN_BUG.Takistan.zip (1 kB) Fireball, 04/26/2011 19:20

STRETCHED_FORM_LINE.Takistan.rar (980 Bytes) Voyage34, 04/27/2011 13:03

STRETCHED_FORM_WEDGE.Takistan.rar (967 Bytes) Voyage34, 04/27/2011 13:03


Related issues

related to ARMA2 Community Issue Tracker - Bug #19072: Buggy delta and column formations Assigned 04/20/2011 07/20/2011

History

Updated by BigDawgKS over 4 years ago

  • Status changed from New to Feedback

Since OFP it has always been the case that AI would follow the person directly above them in order, unless that person leaves formation. IMO, it seems like it's by design to keep the formation system more flexible/scalable. If you have formation relative to the formation leader then I suppose it would still work well for small squads, but if you have squads with a lot of entities (or they are spaced out quite a bit) I imagine the result would seem either too perfect (how accuratetly can 20+ guys form a perfect wedge/line shape?) or you would end up with a lot of loner guys who happened to fall behind and were abandoned by their teamates. Specifically, this would be a nightmare for convoys where the current behavior is much more suitable (you definately don't want all the vehicles to try to position themselves relative to the leader; the formation would become far too rigid). Relative positions also better mimics real life behavior; you tend to watch what the guy next to you is doing rather than the guy all the way in the front.

Probably the only way to have the best of both is to make it depend on the situation. For example, column formations should always be relative to the unit directly in front of you, where wedge formations (in close proximity) might opt to use positions relative to someone higher up (perhaps the leader if he's visible). Since it does seem by design though, I'm very hesitant to call it a bug.

Updated by Voyage34 over 4 years ago

It is clearly not a bug, I forgot to change that. Ty.

Well, you are right about the convoys fact.

Both leader position and preceeding unit position have their advantages, so I don't really know wich one can be more suitable.
About the second one:

-right about the "more natural behaviour", and the formation being more flexible, but there is - as said - a general tendency of side units (exp. in big squads) to remain back. This is mainly due to leader moving on again before everyone has moved.

-the AI generally pay attention to less details than a human player (for ex. if you're just on the right side of the leader, you'll never go on his left, or episodes of friendly fire due to bad positioning, ..) that lower the "precision" of the resulting formation; and with precision I'm not meaning the perfect shape being formed by 20+ men (that you can obtain in both cases, just waiting for the AIs to adjust their positions). It's just a matter of formations not being messed up too much.
Only ideas, there's nothing properly wrong to be addressed, just trying to point out some possible changes.

Updated by fabrizioT over 4 years ago

  • File COLUMN_BUG.Takistan.zip added

No there is indeed a bug here.

BigDawgKS you said:

Since OFP it has always been the case that AI would follow the person directly above them in order, unless that person leaves formation

Fine, but the point is that actually when the "person leaves formation" following units don't care and still follow him.

Run the attached repro: you'll see a 9 men squad ordered to move in "compact column". Unit #3 is heavily injured so it dies at mission startup.
Guess what? All units after #3 just stop in place, while #1 and #2 move on.

Not pretending to hijack this report, but due to this wrong behaviour "compact column" and "diamond formation" are bugged.
The problems are:

  • a single unit does not care to check whether the one is preceeding is in formation or not, or at least if it's alive :|
  • a single crawling unit may slow down all units following it
  • a stuck unit may stop all units following it

Updated by Fireball over 4 years ago

  • File deleted (COLUMN_BUG.Takistan.zip)

Updated by Fireball over 4 years ago

  • Tracker changed from Bug to Feature

Thing is, that the preceeding unit can be a sub-leader of some kind.

If we have a Lieutenant, two Sergeants, three Corporals and four Privates, depending on formation (Wedge for example), they form up in a interchanging manner: one left, one right, one left, higher ranks first and the lower ranks who get assigned to the side of a higher rank, will follow that higher above them respectively:

                L
           S1   S2
        C1        C2
     C3             P1
   P2                 P3
P4

If Corporal2 (C2) breaks away, Private1 (P1) and P3 will follow. If Sergeant2 (S2) breaks away, C2, P1 and P3 will follow.

So if S2 dies, they'll stick to him until declared dead (which happens pretty fast if any AI in the squad sees him dead) and will join up the Lieutenant (L) directly (or maybe they'll use some fuzzy logic to re-arrange the squad order, not sure).

Now, this is different for every formation shape and I only figured it for Wedge formation.

If you want to make tickets that are useful, you will have to make a ticket for every available formation with specific repro steps.

Updated by fabrizioT over 4 years ago

@Fireball:

just to clarify my point: if you run my (removed) repro you'll see the problem is that while a dead unit is just in front of 6-7 units in column no one of them cares to move on.
You can wait a bit and they still don't move. It's a clear example of what's broken to me.

The problem with diamond / compact column formation is just a consequence of the buggy behaviour reported in this ticket, once the latter is fixed the former will be ok too.

Sorry again for having messed up tickets, mate.

Updated by Fireball over 4 years ago

Alright, let's have it on both tickets.

Updated by Voyage34 over 4 years ago

Ok, I'll try to point it out clearly on both tickets (#19069 and #19072).

About this one:

there are 2 problems:

-the less important: formations tends to get stretched forward due to tendency of last moving units to remain back, expecially if the squad leader is advancing pretty fast.
About that see STRETCHED_FORM_LINE and STRETCHED_FORM_WEDGE as repro: just observe from above the infantry squad who is advancing (in danger mode) and notice that the line formation tends to became a wedge, while the wedge tends to reduce his angle

-the more important: if a unit breaks formation (for every reason: death, engaging, crawling), all units after that unit in the formation (see Fireball's scheme for a clear explanation) keep following her, breaking formation too.
So, as fabrizioT said:
•a single unit does not care to check whether the one is preceeding is in formation or not, or at least if it's alive :|
•a single crawling unit may slow down all units following it
•a stuck unit may stop all units following it
About that see COLUMN_BUG, where a single dead units stops the rest of the column behind her.

As a little ending note, in my opinion this bug is not related with #19072, as it have nothing to do with the problems delta formation has.

@Fireball: If you want me to make a ticket for every formation I can do it (as soon as possible), but (talking with respect), firstly, fundamentally the logic of the problem is always the same, and secondly, while it takes a lot of time to me to discover the algorithm for every formation, the guys at BI already knows it, so they can have it in a few minutes. Anyway if you think it's needed I'll do it.

Updated by BigDawgKS over 4 years ago

Voyage34 wrote:

•a single unit does not care to check whether the one is preceeding is in formation or not, or at least if it's alive :|

This one's definately a bug.

•a single crawling unit may slow down all units following it

This one's difficult; what is the desired/expected behavior? Leave the crawling guy by himself?

•a stuck unit may stop all units following it

This is a reason for a slight design change. Perhaps after some time, stuck AI should eventually leave formation. In that event, if the first bug is fixed all should be well. Of course, it would also be good if the AI were improved to reduce their frequency of getting stuck in the first place.

Updated by Fireball over 4 years ago

Maybe you should split up 2 problems into two tickets? Or are there even 3 issues?

So, which one does now apply to #19069?

Updated by Voyage34 over 4 years ago

The problems are 2, as I pointed out (the 3 points fabrizioT wrote (and BigDawgKS quoted) were about the second one).

About splitting this in 2 tickets, well, everything depends on how we want to solve those problems: if we link the unit position in formation to the leader position we would solve both problems (formation stretching and problems when breaking formation). The other possibility would be to some-other-way correct the second problem - actually the more important of 2 - while keeping the current logic with both advantages and disadvantages it brings.

I personally prefer the first one, but it's a design choice, so it's not up to me (I think).

Updated by Fireball about 4 years ago

  • Due date set to 10/29/2011
  • Status changed from Feedback to Assigned
  • Reproduced by another DH user changed from No to Yes

Alright, we'll keep this as it is.

Updated by Suma almost 4 years ago

-the more important: if a unit breaks formation (for every reason: death, engaging, crawling),

Those three reasons are each different:

- death - definitely a bug, but I was unable to reproduce. Can someome provide a repro?
- engaging - what kind of engaging do you mean? Once unit calls "ENGAGING", it is no longer considered a part of formation and other units do not follow it (unless they are engaging the same target, it which case they form a "fireteam" and engage together, but then again, other units should not follow them)
- crawling - here I think it is by design. Formations are not expected to leave anyone behind.

Overall, the repro steps and observation are too vague. If this should be worked on, detailed repro is needed for each individual case.

Updated by Voyage34 almost 4 years ago

Suma wrote:

-the more important: if a unit breaks formation (for every reason: death, engaging, crawling),

Those three reasons are each different:

- death - definitely a bug, but I was unable to reproduce. Can someome provide a repro?
- engaging - what kind of engaging do you mean? Once unit calls "ENGAGING", it is no longer considered a part of formation and other units do not follow it (unless they are engaging the same target, it which case they form a "fireteam" and engage together, but then again, other units should not follow them)
- crawling - here I think it is by design. Formations are not expected to leave anyone behind.

Overall, the repro steps and observation are too vague. If this should be worked on, detailed repro is needed for each individual case.

The first two were bugs that were sometimes seen by that time (there were even a relation with another similar ticket I can't remenber now), but I haven't seen them anymore in a while, so they are probably solved by now. And the third one is by design.

So, assuming there are more important things to work on I think this ticket can be closed.
Thanks anyway for asking, really glad to see you worry even about older tickets.

Updated by Fireball almost 4 years ago

  • Due date deleted (10/29/2011)
  • Status changed from Assigned to Closed

Good call. Tickets should be filed for every individual issue, in future.

Updated by Voyage34 almost 4 years ago

Fireball wrote:

Good call. Tickets should be filed for every individual issue, in future.

Sorry about that; I put them in one ticket beacuse I thought it was one issue, just with different ways to be triggered.

Also available in: Atom PDF