Bug #18935

Expression Error (ACE)

Added by friznit almost 4 years ago. Updated over 3 years ago.

Status:Closed Start date:04/15/2011
Priority:High Due date:
Assignee:wolffy.au % Done:

80%

Category:ACE
Target version:MSO v3.45
Component: Reproduced by another DH user:No
Close Reason:Cannot reproduce I am using some Mods:Yes
Affected Version:

Description

Hard to tell if this is an ACE issue or MSO, but it was flooding the Server RPT file in v.3.31 and is still present in 3.4b2

Error in expression < _x getVariable ["ace_w_state", 0];
if (_state > 1 && alive _x && ((side (group >
Error position: <_state > 1 && alive _x && ((side (group >
Error Undefined variable in expression: _state

History

Updated by wolffy.au almost 4 years ago

  • Assignee changed from Rommel to wolffy.au

I have had this issue from the very beginning - there are multiple tickets related to it.

As I haven't spent much time on ACE, I've never resolved it. I'll see what I can do.

Updated by wolffy.au almost 4 years ago

  • Status changed from New to Feedback
  • Priority changed from Low to High
  • % Done changed from 0 to 80

I think I've fixed it. Can you please change your local copy and see if the error reoccurs.
http://dev-heaven.net/projects/mso/repository/revisions/2974d70b35f88ce8c98333244987a4756c278890

Updated by friznit almost 4 years ago

Sadly still reoccuring in the latest version, although not nearly as often. Doesn't seem to be breaking anything that I can tell though. What should I be looking out for in game?

Updated by wolffy.au almost 4 years ago

I have no idea. I thought it was the NOMAD module, but i have a suspicion its Ambient Civilians. Might have to break the MSO back into its 4 components and test individually to find out where its coming from.

If you work out a way to reproduce, please let me know.

Updated by Tupolov almost 4 years ago

  • Target version changed from MSO v3.4 to MSO v4.6

Updated by Jedra over 3 years ago

Just to add to this, I am getting this message, but I am not running MSO!

I have been getting it ever since I implemented wolffy's Unit Caching scripts in a Single Player mission I am currently writing. The mission also uses UPSMON and does create a hell of a lot of units.

I have been testing the mission for a week or so now and only started to get this message when I added the unit Caching today.

If you want me to upload the mission, I will, but it's in a state of dev at the moment and needs a lot of mods to run!

Updated by Sickboy over 3 years ago

This should occur because the "ace_w_state" variable is set to Nil somewhere.
The scripts use _unit getVariable ["ace_w_state", 0]; // this will return 0 if the "ace_w_state" is undefined.
However, if somewhere is executed: _unit setVariable ["ace_w_state", nil] - this will break it, and it will return nil instead of 0.
Perhaps need to look at if and where you set "ace_w_state", and do not set it to nil.

Updated by Tupolov over 3 years ago

  • Status changed from Feedback to Closed
  • Target version changed from MSO v4.6 to MSO v3.45
  • Close Reason set to Cannot reproduce

This error has not been seen recently. The ace_w_state issue was fixed by Wolffy.

Also available in: Atom PDF