Bug #18846

AI vehicles have 360 field of vision when tracking a target

Added by LeadCommando65 over 4 years ago. Updated over 3 years ago.

Status:Closed Start date:04/11/2011
Priority:High Due date:
Assignee:Dwarden % Done:

0%

Category:AI Issues
Target version:1.60.87580
Affected ArmA II version:1.59.79384 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using:CO (OA+A2) BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Repro:
  1. Download and preview the test mission (see below).
  2. Walk left until you can see the T72 tank.
  3. Quickly retreat into cover behind the house.
  4. Make sure the tank has aquired you as target (it will fire more or less constantly at your last known position)
  5. Press 0-0-2. You will get teleported behind the tank and behind tree blocking the tanks line of sight (if it could have one) to you.
  6. Expose yourself by walking left or right until you gain line of sight to the tank again.

Settings:
skillFriendly=1;
skillEnemy=0.55000001;
precisionFriendly=1;
precisionEnemy=0.55000001;

Observed behaviour:
The player is well hidden behind the tree, but after teleportation and exposure of the player, the tank instantly knows where the player is and turns its turret 180 degrees to kill the player.

Tested vehicles:
  • Tunguska
  • BMP3
  • BTR90
  • T72
  • T90
  • Vodnik

all show same behaviour

Expected behaviour:
The tank must not see the player after teleportation and exposure, because it is facing the opposite direction and cannot know where the player has gone. It seems the AI vehicle has 360 degrees view, because the player is not seen by the vehicle behind the tree (after teleporting) but is instantly recognized after exposure of the player again.

This behaviour makes playing as infantry vs. tanks very hard, because they know where you have gone even if you were out sight and reappear at a completely different location.

AItest_tank.Chernarus.zip - repromission (1.6 kB) LeadCommando65, 04/11/2011 14:18

AItest_tanksight.Zargabad.zip - repromission2 (1.6 kB) LeadCommando65, 04/12/2011 10:00


Related issues

related to ARMA2 Community Issue Tracker - Bug #33444: BMP 2 aware of enemys at mission start Duplicate 06/18/2012
related to ARMA2 Community Issue Tracker - Bug #28203: AI vehicles see player through concealment (possible 360 ... Closed 01/28/2012 02/11/2012
related to ARMA2 Community Issue Tracker - Bug #28290: BMP-2 facing away turns its turret in 2 seconds and fires... Feedback
precedes ARMA2 Community Issue Tracker - Feature #23384: Implement some sort of automatic area scanning by AI vehi... Assigned 08/12/2011

History

Updated by maturin over 4 years ago

Then why can I run around behind an unaware tank without it spotting me?

Updated by LeadCommando65 over 4 years ago

Maybe the 360 degree sight is triggered by target aquisition or whatever. If you find it out, tell it and the bug can get a better title.

How about confirming this behaviour? ...

Updated by maturin over 4 years ago

I just ran some tests.

T-72s do not have 360 degree sight. However, they seem to have a field of vision greater than that provided by their optics, only when tracking a single enemy target that has run into cover.

For example, I presented myself to an enemy tank, then looped around behind some buildings and appeared on it's flank. I was a full 90 degrees from the direction of the guns, perpendicular to its line of sight. Yet it turned and acquired me. (I wasn't able to appear completely behind the tank because I lack a teleportation script and the commander will track my movement through cover by estimates.)

However, this enlarged cone of vision only applies to targets that have been seen at some point. I spawned behind a tank, while my infantry commander spawned in front. He was gunned down, yet the alerted tank was unable to see me standing behind it.

Updated by maturin over 4 years ago

I would recommend testing without the teleport script, and change the ticket titles to "AI vehicles have 360 field of vision when tracking a target."

Updated by LeadCommando65 over 4 years ago

You are right. The bug title has to be adapted.

I think it's a very good way to show this behaviour with the teleport (see repromission), because there exist also similar test missions for infantry (and not to mention, that it's a very fast test and does not require you to crawl/travel large distances behind cover/concealment just to reappear somewhere else). In contrast to this test, infantry does not instantly know where you are after you were teleported behind them.

Updated by LeadCommando65 over 4 years ago

I have added another test mission, where you are the gunner of the tank.

Description:

Repro steps:
  1. Watch the street. Do nothing until told so.
  2. Wait until the soldier has crossed the street and is in cover. Make sure your commander has recognized the target (maybe need a few tries).
  3. Change to map. Click teleport on your radio. The soldier will appear behind your tank.

Observed:
The tank commander has somewhat 360 degree sight after the target is recognized. Watch out where his sight cone is placed on the radar while you teleport the soldier. It quickly turns around after teleport.

Expected:
The tank commander should have a sight cone according to the one shown in the radar. Target recognition or locking on target should make no difference. Target acquisition and recognition should be more similar to infantry type.

I have to add to all of the tests, that it could be also the hearing capability of the vehicle related to the target being extremely enhanced after target acquisition.

PS: how can I change the bug title?

Updated by msy over 4 years ago

Set an AT tripod hundreds meters away behind an official modern tank (T72\T90\M1 or others), and because the tank has an unreal 360 degree radar, it can easily find the AT tripod and shoot it.
But, if some tank addons or some MODs (I44 ACE2 etc.) remove the 360 degree radar from the tank, the tank will not atack the threat behind it unless it is under attack.

Updated by Lazyman over 4 years ago

I think this is the same problem with AIs in general: while they are no longer as omniscient as they once were, if they spot something, they will be able to reacquire it quickly when LOS has been re-established, even when they really shouldn't.
And there's still the issue that when an AI spots you, the entire squad notices immediately, like it happened once with me having to headshot a guy with a silenced pistol while the rest of my squad was distracting the AIs from a nearby hill. The moment the suppressed shot killed the AI, its squadmates stopped firing at my squad, turned around and killed me.

Updated by LeadCommando65 over 4 years ago

Lazyman wrote:

[...] they will be able to reacquire it quickly when LOS has been re-established, even when they really shouldn't.

Hm, I did my tests with infantry, too, and didn't notice such a behaviour. The view cone of AI infantry is quite large, so it's true, they will see you again if you step out their view cone is still there. But they won't see you if come out at a completely different position. Just walk left/right behind a view blocking object (house, bush etc.) and hide quickly, come out gain. If the AI does not hear you and has no LOS it won't detect you. But this only applies for infantry. However, vehicles have somewhat 360 degree sight after target aquisition, which should be really fixed.

Lazyman wrote:

And there's still the issue that when an AI spots you, the entire squad notices immediately, [...]

I think this affects another routine ("squad communication" or something like that). A little delay would be nice. You should create a new ticket about that (esp. about the interrupted engagement by the squad if you shoot one), if needed.

Updated by Fireball over 4 years ago

  • Subject changed from AI vehicles have 360 degree sight to AI vehicles have 360 field of vision when tracking a target
  • Status changed from New to Assigned
  • Assignee set to Dwarden
  • Reproduced by another DH user changed from No to Yes

Updated by Suma about 4 years ago

I confirm I can see the problem, and it is really specific to vehicles. With a little luck this should be something to fix easily. Futher info: the problem can be seen also with UAZ with AGS-30 and only a gunner present (no driver), but not with a static AGS-30, which is interesting, as they are both "vehicles" in almost the same configuration.

Updated by Suma about 4 years ago

I attach what I consider to be a minimal repro. Steps to repro stay similar:

- wait 30 seconds (the target should be well behind a cover then)
- switch to map and press Teleport on the radio
- watch the UAZ gunner to turn immediately and open fire at the target

Updated by Suma about 4 years ago

  • Status changed from Assigned to Resolved

Should be fixed in 82939.

The cause was following: for a target recognition a "visibility matrix" is used, followed by a visual cone test, and based on this (and more) information it is tracked what targets are known. As the matrix is not updated frequently enough, when AI attempts firing at a target, it uses additional low-level "visibility tracker". This tracker detected a full visibility and reported a new position. Now this tracker is used only for targets which are already known to be seen recently by the higher levels.

Updated by Fireball about 4 years ago

  • Target version set to 1.60 BETA

Updated by zGuba about 4 years ago

  • Status changed from Resolved to Closed

Updated by kju over 3 years ago

  • Target version changed from 1.60 BETA to 1.60.87580

Updated by maturin over 3 years ago

This isn't fixed. See here: #28203

Brief rundown: If you hit an APC with a bullet and run behind the bush, he will shoot you through the bush.

If you shoot the APC through that same bush, he will never see you.

This is because in the first case, you alerted him and gave him line of sight. Because he has a 360 degree line of sight, wider than his optics. In the second case, you were never exposed at all and remain hidden.

Updated by maturin over 3 years ago

It seems to me that this bug is fixed, but for not all vehicles. For example, BMP-2s do not have 360 degree vision, while Stryker M2s and UAZ DShKm do.

Updated by Dwarden over 3 years ago

  • Status changed from Closed to Assigned
  • Priority changed from Normal to High
  • Target version changed from 1.60.87580 to 1.61 BETA

re-opening until proved wrong ... vehicles in question M2 Stryker, UAZ Dshkm

Updated by Fireball over 3 years ago

  • Due date deleted (07/11/2011)
  • Status changed from Assigned to Closed

I think I'd rather have that one closed and treat the special cases in the new ticket(s).

Updated by Fireball over 3 years ago

  • Target version changed from 1.61 BETA to 1.60.87580

Also available in: Atom PDF