Bug #1828

ArmA 2: C130J - Aircraft Ground Turning Radius Exceeds 300m (984 feet)

Added by Sniper121 almost 6 years ago. Updated about 5 years ago.

Status:Closed Start date:06/04/2009
Priority:Normal Due date:
Assignee:- % Done:

100%

Category:Config
Target version:1.05.62017
Affected ArmA II version:1.04.59026 First affected build:
Reproduced by another DH user:Yes First affected ArmA II version:
I am using some Mods: Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you: NGUrl:
Related to content of DLC: WIKIurl:

Description

At full rudder pedal and/or turn pressed while steering right or left on the airport of Chenarus, the turning radius of the nose wheel steering of the C130J was so poor it took 395 meters (1,295.93176 feet) diameter to turn the aircraft around. The real C-130 aircraft series has a ground turn radius of 122 feet (37.1856 meters). I respectfully request the Dev-Heaven team ensure the ArmA 2 developers see this information.

I discovered this issue, which in my opinion is not a bug, but something that needs to be fixed in the next update. If left unchecked, mission editors might as well just position the C130 on the runway in postion for takeoff or already flying; if the AI or human player/pilot is expected to taxi to the ruway, he will need to back up or reverse taxi the aircraft to avoid trees and other obstacles enroute to the runway. Unfortunately, taxi reverse is a feature in A.C.E. Mod.

In the ArmA 2 Editor, on the Chenarus map, I placed a C130J on the taxiway in front of a hangar at the large airport. I started the engines and taxiied slowly, between 20-30 kmh and applied full right rudder to turn on the taxiway to get me in position lined up on the runway. The aircraft could not make the turn. There are other aircraft in the ArmA 2 inventory that also lack the turning radius and others that have the turning radius of a sports car, the JSF F/X-35. The Su-25/39 and A-10 need improved nose wheel steering as does the AV-8B.

jdc_CAAir2_TurningPatch.pbo - Temporary patch PBO to fix turning radius of the C-130J while on the ground. (478 Bytes) jamie_c, 06/05/2009 16:17

CIT_1828_Utes.sqm - C130 and a marker of 38m radius (1.5 kB) alef, 08/15/2009 22:37


Related issues

related to ARMA2 Community Issue Tracker - Bug #4658: C130 take off is not possible for AI Pilots Closed 09/19/2009
related to ARMA2 Community Issue Tracker - Bug #2169: AI unable to take off on grassy airfields Rejected 06/20/2009 12/18/2010
related to ARMA2 Community Issue Tracker - Bug #1690: Fixed Wing Propeller Aircraft AI Problem Airport north of... Closed 06/01/2009
duplicated by ARMA2 Community Issue Tracker - Bug #4067: C-130 Hercules Duplicate 08/27/2009 09/12/2009
duplicated by ARMA2 Community Issue Tracker - Bug #1628: C-130 ground handling Duplicate 05/29/2009

History

Updated by alef almost 6 years ago

This relates to #1628. C130 and Predator only have wheelSteeringSensitivity set in their configs. Given the name, its value 0.5 is maybe too low/high. I've removed at all and turn fine, but now there is a real radius here (trusting Sniper121), so it's possible to try different values to find the 37m radius.

Updated by jamie_c almost 6 years ago

I created a patch PBO and found that 2.5 roughly adjusts it to what Sniper121 suggested (I didn't fully test it, but it is a LOT better), this seems more inline with what has been observed on these airframes in reality. I am awaiting testers from the C-130J user groups to make themselves available to confirm details. Until then, here's a PBO you can use, I know it's not an official fix, but you're not the first person to request it.

I suggest putting the file in the following folder: C:\Program Files\Bohemia Interactive\ArmA 2\@JDC\Addons
and running A2 with the -mod=@JDC; switch, or modify your mod switch to include it.

Cheers,

Jamie.

Updated by AUS_Twisted almost 6 years ago

This is not the only problem with the C-130, I did a A.I. plane test mission yesterday on the biggest Airport. The C-130 cannot take off without crashing into the trees at the end of the runway turning either left or right, the C-130 does not have enough lift to get high enough before the A.I. banks it over hard into the trees.

From my testing along with the above mentioned the C-130 needs the following config fixes:

*Far smaller turn radius on the ground.
*More power/lift so the A.I. can take off properly.
*Slower rollrate so the A.I. does not bank the plane over so hard on take off and during threats from the ground or air, this also applies to the player.

Updated by PostaL almost 6 years ago

AUS_Twisted wrote:

This is not the only problem with the C-130, I did a A.I. plane test mission yesterday on the biggest Airport. The C-130 cannot take off without crashing into the trees at the end of the runway turning either left or right, the C-130 does not have enough lift to get high enough before the A.I. banks it over hard into the trees.

From my testing along with the above mentioned the C-130 needs the following config fixes:

*Far smaller turn radius on the ground.
*More power/lift so the A.I. can take off properly.
*Slower rollrate so the A.I. does not bank the plane over so hard on take off and during threats from the ground or air, this also applies to the player.

You are indeed right on this one. I also did his before i read this post. The c-130 takes off makes a sharp turn and crashes. I tried to make waypoints to keep the plane straight but that didnt help. I dont know if this can be fixed by adding a command in the innit line else its a bug.
My AI also didnt take off when i put it on the sideroad of the runway and gave a waypoint order to take off. The c-130 couldn't find its route and drove into the grass.
I dont know if others have tried this.
Maybe there should be created bug reports about this, but im not to familiar with the editor so maybe it can be changed in the editor.

cheers,
Chris

Updated by Skeptic almost 6 years ago

I confirm - this is an issue also with at least A-10. Impossible to turn.

Updated by kju almost 6 years ago

  • Status changed from New to Assigned

Thanks. Good report and thanks for the config tweak.

Please next time less text, bullet points and a short video for similar issues.

Again thanks to everyone involved. Now lets hope that BI will tweak it.

Updated by Sniper121 almost 6 years ago

@Jamie_C
Thank you for the pbo fix. I also confirm it's fixed.

Here's the C-130 aircraft characteristics webpage on which the ground steering radius of 122' or approx 38m is posted (See Parking Apron Design Information section).
http://www.uscost.net/AircraftCharacteristics/acc130.htm

By the way, if the airport designer at Chenarus' largest airport could, I wish buildings and other structures were placed a safe distance from the taxiways. I have to back-taxi on the active runway because the air traffic control building and the building closest to it barely provides wingtip clearance for the C-130J.

Sniper121

Updated by Squelch almost 6 years ago

The C130J crashes because of the very early turn out after lift off, and is a product of the island preset waypoints for ils and taxi-ing I believe

Trees on the approach to Utes also bring down any aircraft trying to land on autopilot.

Updated by kju almost 6 years ago

  • Due date set to 07/05/2009
  • Category changed from Model to Config
  • Status changed from Assigned to Feedback
  • Assignee set to Sniper121

From a brief config check I couldn't see a change here.

Ingame gameplay feedback needed please.

PS: Lot of car/trucks have been tweaked though.

Updated by alef almost 6 years ago

  • Due date changed from 07/05/2009 to 10/03/2009
  • Status changed from Feedback to Assigned
  • Assignee deleted (Sniper121)
  • Affected ArmA II version changed from 1.01.57751 to 1.02.58134

Updated by kju over 5 years ago

  • Due date changed from 10/03/2009 to 08/25/2009
  • Status changed from Assigned to Feedback

Still a problem in 1.03 I assume. Can someone please confirm?

Updated by alef over 5 years ago

  • File CIT_1828_Utes.sqm added
  • Due date changed from 08/25/2009 to 11/16/2009
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.02.58134 to 1.03.58627

Confirmed.
Repro attached, SP player only, no AI. A marker of 38m radius, as reported by Sniper, is in there to show the turn.
Slowly taxing with full pedal right, you hit the hangar (Utes).

Updated by kju over 5 years ago

  • Affected ArmA II version changed from 1.03.58627 to 1.04.59026
  • Reproduced by another DH user set to No

config tweak by Gnat

1 class CfgVehicles 2 { 3 class Plane; 4 class C130J: Plane 5 { 6 elevatorSensitivity = 1.1; 7 wheelSteeringSensitivity = 4.2; 8 noseDownCoef = 0; 9 flapsFrictionCoef = 1; 10 landingAoa = "rad 7"; 11 landingSpeed = 210; 12 }; 13 };

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by Gnat over 5 years ago

landingSpeed = 210 (was 200)
This stops the C130 AI going into a long flat turn immediately after takeoff which causes it to crash into the ground or trees.
C130 now turns slightly, then levels and grabs height before doing whatever was asked of it.

Updated by Dwarden over 5 years ago

  • Priority changed from Normal to Urgent

Updated by Dwarden over 5 years ago

  • Status changed from Assigned to In progress
  • Target version set to 1.05 BETA
  • % Done changed from 0 to 10

Updated by Dwarden over 5 years ago

  • % Done changed from 10 to 50
  • Reproduced by another DH user changed from No to Yes

Updated by kju over 5 years ago

  • Target version changed from 1.05 BETA to Upcoming version

Updated by Fireball over 5 years ago

  • Due date changed from 11/16/2009 to 01/16/2010

Updated by Luca over 5 years ago

  • Status changed from In progress to Assigned
  • Assignee changed from Dwarden to Luca

In progress...

Updated by alef over 5 years ago

  • Due date changed from 01/16/2010 to 01/22/2010
  • Status changed from Assigned to Resolved
  • Priority changed from Urgent to Normal
  • Target version changed from Upcoming version to 1.05.62017
  • CPU changed from Please specify! to n/a

Turning radius fixed.

Updated by kju over 5 years ago

  • Assignee deleted (Luca)

Let's how well it works. BI only change this one value

1 wheelSteeringSensitivity = 0.5;

to

1 wheelSteeringSensitivity = 2;

Updated by Dwarden over 5 years ago

  • % Done changed from 50 to 100

Updated by kju about 5 years ago

  • Due date deleted (01/22/2010)
  • Status changed from Resolved to Closed

Also available in: Atom PDF