Feature #17867

Multiple Spawn Points

Added by wobbleyheadedbob about 4 years ago. Updated about 3 years ago.

Status:Closed Start date:02/24/2011
Priority:High Due date:
Assignee:wobbleyheadedbob % Done:

100%

Category:-
Target version:Multi-Session Operations - MSO v4.3
Component:WHB_Multispawn Reproduced by another DH user:No
Close Reason: I am using some Mods:No
Affected Version:

Description

Hi there,

I've been working on a script to allow players to Spawn at an FOB when they die. The way this differs from the normal respawn scripts is that instead of a dialog allowing the player to choose from a number of designated spawn points they are required to "Sign In" at the designated FOB HQ tent (or whatever object).

This means they actually have to travel there first before they'll be able to spawn there upon there death. I aim to make some kind of moveable object that can be 'unpacked' into an HQ tent, with a sufficient delay to prevent it being used as an MHQ.

I'm pretty new to scripting in Arma 2 so if anyone's interested in taking this further I have a load of ideas that can further improve this.

There are still some thing's I'd like to add to it:
  • MSO integration of spawnpoint - so players retain their spawn point upon reconnect
  • Deploy/Undeploy actions with parameter specified delays
  • Automatic creation of JIP Markers for FOB's
  • Deployment dialog - so players can name the FOB
  • Error handling so that if the HQ is destroyed/undeployed the player defaults back to main base.

History

Updated by rye about 4 years ago

Yup I added a point for "spawn on an object" a while ago. Then we could add that object to FOB's.

Updated by wolffy.au about 4 years ago

  • Project changed from MSO Enemy Generation to Multi-Session Operations
  • Reproduced by another DH user set to No
  • I am using some Mods set to No

Updated by wolffy.au about 4 years ago

  • Project changed from Multi-Session Operations to MSO Logistics and Support

Updated by wobbleyheadedbob about 4 years ago

Well I've made some progress on this and will be uploading an example mission sometime this week (when I have a chance to clean up my code, as it looks like it was written by a schizo on crystal meth!).

There are couple of additional features I'd like to include which leads me to another question, is there a function to move the logistics contents from one vehicle/object to another?

Updated by wolffy.au about 4 years ago

  • Assignee set to wolffy.au

Sorry mate - just found this ticket and its download. Will have a look at it now.

Updated by wobbleyheadedbob about 4 years ago

I'll updaload a later version today. The attached one is old I think.

Updated by Tupolov almost 4 years ago

  • Target version set to MSO v5.0

Updated by Tupolov over 3 years ago

  • Assignee changed from wolffy.au to wobbleyheadedbob
  • Priority changed from Low to High
  • Target version changed from MSO v5.0 to MSO v4.6
  • Component set to WHB_Multispawn

Guys,

This sounds like there isn't much left to do. Can we sprint to get this finished?

Updated by wobbleyheadedbob over 3 years ago

Tupolov wrote:

Guys,

This sounds like there isn't much left to do. Can we sprint to get this finished?

Hiya, sorry was on holiday for 3 weeks in South Africa, I'll get back on this ASAP.
Only problem is the bugs being raised are due to a fundamental issue with my design of the solution, so it needs to be reworked (might not be as quick as I hope).

Updated by wobbleyheadedbob over 3 years ago

If anyone in the know has some free time, can you give me a crash coarse in Git as manually integrating my changes into MSO is a pain in the ass.

Updated by wolffy.au over 3 years ago

wobbleyheadedbob wrote:

If anyone in the know has some free time, can you give me a crash coarse in Git as manually integrating my changes into MSO is a pain in the ass.

Get yourself onto Skype Instant Messenger and we can talk you through it in real-time.

Updated by wobbleyheadedbob over 3 years ago

Thanks wolffy, I've kinda got some of the basics down, I can push and pull to my remote repo I setup on GitHub. Just not sure what the steps are to do the same to your dev-heaven repo.

Here's where I've been mucking around:
https://github.com/wobbleyheadedbob/MultiSpawn_Script.utes

Updated by Tupolov over 3 years ago

  • Target version changed from MSO v4.6 to MSO v4.3

Updated by wobbleyheadedbob about 3 years ago

I've got a test version up and have added the creation of a JIPMarker at the FOB position.

I'd like to wrap this up in

 #ifdef RMM_JIPMARKERS
   create/remove jipMarker
 #endif

however RMM_JIPMARKERS is obviously not in scope within my module(and thus the never gets called), how do I #include <modules.hpp> while deeper within the modules directory structure? What's the syntax to reference a file a couple of directories up? or is this not possible?

Updated by wobbleyheadedbob about 3 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Complete and ready for testing. Only the basic functions are available. Extended features will be created as separate tickets.

Updated by Tupolov about 3 years ago

WHB,

Just tested this on Takistan. Drove an MHQ away from base, deployed it, signed in at FOB, then hit respawn. I respawned back at the respawn_west marker?

Tup

Updated by Tupolov about 3 years ago

  • Status changed from Resolved to Closed

Tested again and appears to be working fine.

Also available in: Atom PDF