Bug #17756

"Join" command fails if used soon after mission start on dedi server.

Added by Tankbuster about 4 years ago. Updated about 3 years ago.

Status:Assigned Start date:02/20/2011
Priority:Normal Due date:07/01/2011
Assignee:- % Done:

0%

Category:Scripting: Problem
Target version:-
Affected ArmA II version:1.59.79384 First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:Yes NGUrl:
Related to content of DLC: WIKIurl:

Description

Very odd one this.

On a dedicated server, the join command doesn't work reliably. It started out as a bug fixing a broken Domination side mission, but I distilled it down to a test mission, which I've attached.

The test mission is a BLUFOR guy names player_dude on his own. Next to him is a BLUFOR group, whose leader is called ai_dude. Alpha radio trigger on activation is [ai_dude] join player_dude.

Now, if you do the radio trigger immediately after the mission, ai_dude doesn't join the group. In actual fact, squad icons appear on the player screen for an instant, then disappear

If you wait 10 secs after the mission starts, then do the radio trigger, ai_dude joins player_dudes group.

Server needs to be properly shut down and restarted between tries to observe this behaviour.

Behaviour is ONLY observed on dedicated servers. If you run it locally, ai_dude joins group reliably, every time.

jointest.Desert_E.pbo (4.1 kB) Tankbuster, 02/20/2011 00:21

History

Updated by shuko about 4 years ago

For me, it works each time when hitting the trigger as fast as I can.

Updated by Tankbuster about 4 years ago

Youtube vid. You can clearly see the squad icons momentarily appear.

http://www.youtube.com/watch?v=WzUHw8j0JYE

Updated by kju about 4 years ago

  • Due date set to 03/01/2011
  • Category set to Scripting: Problem
  • Status changed from New to Feedback
  • Affected ArmA II version changed from Please select... to 1.57.76815

Works fine with latest beta on DS here.

What version did you use?

Either this is a non issue or your repro does not work out.

Updated by Tankbuster about 4 years ago

157 on both server and client

Updated by kju about 4 years ago

Retest with latest beta on both server and client please.

Updated by Tankbuster about 4 years ago

Not done it on beta yet, as I haven't managed to get the beta installed on the server yet - my server monkey is absent. :)

Meantime, I have had another user successfully repro this.

It's important to do the steps properly.

1. Shut down server.
2. Start server.
3. Load mission and start mission.
4. Issue radio 11a immediately and they join and quit group instantly.
5. Shut down server.
6. Start server.
7. Load and start mission.
8. Wait 10 sec then radio 11a. They'll join and stay in group.

Updated by Tankbuster about 4 years ago

See new YT vid for a better look.

http://www.youtube.com/watch?v=f4AwGTqcKsU

Updated by Tankbuster about 4 years ago

Kju, I'm gonna wait until the new patch, which I expect within days. Rather than try with beta, would you be happy if I waited and tried with new stable?

Updated by kju about 4 years ago

  • Due date changed from 03/01/2011 to 04/01/2011
  • Reproducible for you changed from No to Yes

Ty. Sure that's fine.

It'd be important to see if others can repro it.
If so, to find out what's the difference for those who cannot.

Updated by Tankbuster almost 4 years ago

  • Language set to Please set for missions

Just tried it on new 1.59.

Still showing same problems.

Updated by kju almost 4 years ago

  • Due date changed from 04/01/2011 to 07/01/2011
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.57.76815 to 1.59.79384
  • I am using deleted (CO (A2+OA))

ty

can someone try to repro it too?

Also available in: Atom PDF