Bug #1771

Textures flickering of objects at distance (z fighting).

Added by Skeptic about 6 years ago. Updated over 3 years ago.

Status:Closed Start date:06/03/2009
Priority:Normal Due date:
Assignee:Dwarden % Done:

0%

Category:Visual
Target version:1.55.75445
Affected ArmA II version:1.55 BETA First affected build:
Reproduced by another DH user:No First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

Sample video:
http://www.youtube.com/watch?v=D3xsbtvHtu0

Repro:
1) Put yourself just outside of Chernagorsk.
2) Use RMB to zoom in.
3) Notice textures of several buildings flicker at distance.


I mostly experienced this in MP, but there are multiple reports of this in SP as well.

In Chernogorsk there are several buildings that have textures flickering between low/high resolution regardless of zooming, moving or optics. Red fence near T-34 monument for example will not load high res texture at all.

http://forums.bistudio.com/showthread.php?t=73323

arma2.rpt.rar (4.2 kB) Skeptic, 06/23/2009 23:21

Skeptic.Arma2Profile.rar (3.1 kB) Skeptic, 06/23/2009 23:25

DxDiag.txt..rar (9.6 kB) Skeptic, 06/23/2009 23:25


Related issues

related to ARMA2 Community Issue Tracker - Bug #13388: Heavy flickering of textures from objects at distance sin... Closed 08/30/2010
related to ARMA2 Community Issue Tracker - Bug #13560: Coastline of Chernarus flickering Closed 09/06/2010
related to ARMA2 Community Issue Tracker - Bug #14276: Z-fighting reappears when player is close to objects Assigned 10/09/2010
related to ARMA2 Community Issue Tracker - Bug #14259: Z-Fighting fix does not work while prone Duplicate 10/08/2010

History

Updated by kju about 6 years ago

  • Priority changed from High to Normal

Updated by basilbrush about 6 years ago

Why has priority been changed to normal?.

Updated by kju about 6 years ago

Priority has no meaning. :)

Updated by INNOCENTandCLUELESS about 6 years ago

I have exactly the same flickering e.g. as around the window frames and inside the glass since ArmA I. Not any Nvidiadriver up to current 190.15 could change anything. Problematic to spot movements far away if environment is restless. I own a 8800 GTX, driver mentioned, OS = WinXP32SP2 DirectX9.26

Updated by kju about 6 years ago

  • Status changed from New to Feedback
  • Assignee set to Skeptic

Skeptic please provide the information requested here:
http://dev-heaven.net/wiki/cis

Updated by Skeptic about 6 years ago

Updated by Skeptic about 6 years ago

kju, sorry for long wait - real life took precedence ;-) Since 1.02 patch I don't have these files appcompact.txt, arma2.exe.mdmp, arma2.exe.bidmp. Also can't seem to locate Arma2.cfg...

So I uploaded DxDiag, Arma2.rpt and Skeptic.Arma2Profile. Let me know how can I further help. Will try to capture video later tonight (fraps didn't cooperate with me last time around). Regards.

EDIT: I quickly put video together, sorry for bad quality - this is my first attempt at video editing and youtube: http://www.youtube.com/watch?v=bz1MIaW2lQ0

And this is someone else's http://www.youtube.com/watch?v=1Ec2jm4o6ko http://www.youtube.com/watch?v=qoozjv-hvgg

Updated by kju about 6 years ago

  • Category set to Visual
  • Status changed from Feedback to Assigned
  • Assignee deleted (Skeptic)
  • Affected ArmA II version changed from 1.01.57751 to 1.02.58064

tx!

Updated by Skeptic about 6 years ago

There are fewer of these bugs in 1.02, but they are still present. As someone speculated - it might be engine can't decide which LOD texture to display: high or low resolution.

Cheers.

Updated by alef almost 6 years ago

  • Due date set to 09/24/2009

Updated by Fireball almost 6 years ago

  • Due date changed from 09/24/2009 to 10/14/2009
  • Reproduced by another DH user set to No

Still happening with current driver/game versions?

Updated by Fireball almost 6 years ago

  • Due date changed from 10/14/2009 to 10/24/2009
  • Status changed from Assigned to Feedback
  • CPU set to Please specify!

Updated by Skeptic almost 6 years ago

Hey Fireball,

My CPU is Intel Core 2 Duo E8400, non-OC'ed. I've noticed that textures load properly, but need to check for flickering in Electrozavodsk.

Thanks.

Updated by kju almost 6 years ago

  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.02.58064 to 1.04.59026

Q6600, 4890. v9.8. XP32. Still very much affected.
Trying v9.9 now. All of my team report the problem too.

Obs:
Once you zoom in with RMB, you get heavy texture flickering on buildings.

Updated by Fireball over 5 years ago

  • Due date changed from 10/24/2009 to 11/24/2009

Updated by Suma over 5 years ago

  • Status changed from Assigned to Feedback

Following fix might have fixed or improved this:
[59842] Reduced town/village stutter (fixed streaming of textures used by Super shader).

Can someone confirm?

Updated by kju over 5 years ago

  • Due date changed from 11/24/2009 to 11/27/2009
  • Target version set to 1.05 BETA

It has been definitely improved for me (ATI 4890), yet it
is still happening for some buildings at distance.

Updated by kju over 5 years ago

KeyCat in BIF.

It happens everywhere on both Utes/Chernarus and as Zeep says it's been discussed quite alot. To see it in full effect all you have to do is place yourself as a sniper/officer 500-600 m away from houses in a city and look at them with scope/binocs, some specific houses/buidlings flickers really bad (look around window frames etc) and sometimes it gets even worse if the bulding has been destroyed and are ruble.

It's visible on others objects as well, like stone hedges, parts of tree trunks, soldiers helmets etc. but it's really obvious on houses/buildings in a city if you look at them from far distance in scope/binocs.

One interesting thing I noticed recently is that if you are are a commander/gunner in a tank (I tested in a M1A1) and the tank was stationary and looking thru the optics (max zoomin) the flickering/Z-fighting was gone while you kept your mouse completely still but as soon you started to move your view just a little it's there again. I'm not smart enough to draw an actual conclusion about why but this may indicate there may be a way to fix/improve it???

Updated by zGuba over 5 years ago

  • Due date changed from 11/27/2009 to 01/01/2010

Updated by bensdale over 5 years ago

this is the z fighting problem http://en.wikipedia.org/wiki/Z-fighting . this problem is since ofp present and i hope it will fixed now ;)

here is another video: http://www.youtube.com/watch?v=D3xsbtvHtu0 (posted in the BI Forum by thedudesam http://forums.bistudio.com/showthread.php?p=1529632#post1529632

can we add in the title "z fighting" ?

many thx

Updated by kju over 5 years ago

  • Subject changed from Textures flickering / high resolution textures not loading to Textures flickering of objects at distance (z fighting).
  • Status changed from Feedback to Assigned
  • Target version deleted (1.05 BETA)
  • Affected ArmA II version changed from 1.04.59026 to 1.05.62017

Updated by Dwarden over 5 years ago

  • Assignee set to Dwarden

Updated by stargun over 5 years ago

The elimination of this annoying "feature" should be the highest priority among all tasks related to ArmA II right now. Z-fighting is not common in today games, and extremely ruins the immersion factor.
Personally I think that no other modification is neccessary until this problem is not solved. Not a single newcoming player will think ArmA II as a serious game until it's plagued by such issues. Any perfect AI algorithm is TOTALLY USELESS if implemented in such a buggy engine.
And Z-fighting is the most obvious bug a 3D game can have. All other minor imperfections are NOTHING compared to this as a game-stopper.

I had no experience with ArmA, I'm new to ArmA II. I bought this extraordinary game, and hoped that the newcoming patches will solve this annoying bug. We're at patch 1.05 right now and Z-fighting is still exists. Please, PLEASE fix it at last!

Updated by stargun over 5 years ago

It's so great to have this thread. Unanswered...

Seriously, is there any news on this issue? Is there any PLAN to solve this issue?!

Updated by kju over 5 years ago

stargun this is a community issue tracker.
While BI is present around here, you will most likely see a response in the way
of the issue being fixed in a future patch or not.

Updated by MavericK96 about 5 years ago

This is a really noticeable issue for me, especially when flying over cities in-game. Almost all the buildings will flicker, and also when you're somewhat high up the border between water and land will flicker horribly.

Is anything being done about this? It's not necessarily a performance issue but it is immersion-breaking and annoying at the very least.

EDIT: It's worth noting that as of the latest beta patch I've tried (70054) this has not been fixed at all.

Updated by kju about 5 years ago

  • Due date changed from 01/01/2010 to 06/05/2010
  • Affected ArmA II version changed from 1.05.62017 to 1.06 BETA

Updated by Pauliesss about 5 years ago

This is really very annoying, newest beta patch(70951) does not fix this at all. :(

Please fix this, I know its probably not possible to remove it completely, but it surely can be improved.

Thanks.

Updated by Vic about 5 years ago

Logarithmic Depth Buffer in Outerra engine
http://outerra.blogspot.com/2009/08/logarithmic-z-buffer.html

(link posted by Stargun on BIS forums)

Updated by kju about 5 years ago

Is this improve in the latest beta patch in OA?

Updated by bensdale about 5 years ago

no sry. it looks like the same.

Updated by kju about 5 years ago

  • Due date changed from 06/05/2010 to 10/01/2010
  • Affected ArmA II version changed from 1.06 BETA to 1.52 BETA

ok

Updated by Suma almost 5 years ago

  • Status changed from Assigned to Resolved
  • Affected ArmA II version deleted (1.52 BETA)

Significantly reduced in 73646.

Updated by kju almost 5 years ago

  • Due date deleted (10/01/2010)
  • Target version set to Upcoming version
  • Affected ArmA II version set to 1.55 BETA

Updated by BigDawgKS almost 5 years ago

Suma wrote:

Significantly reduced in 73646.

Good to hear. :)

Updated by Fireball almost 5 years ago

I hope the resolved flickering is not related with #13388 or #13560, else I would say no, not good yet.

Updated by Suma almost 5 years ago

not good yet.

I do not think 73646 was already released as public beta. As of now, the most recent version is 73643.

Updated by kju almost 5 years ago

  • Target version changed from Upcoming version to 1.55 BETA

Please confirm fixed/improved.

Updated by kju almost 5 years ago

  • Status changed from Resolved to Closed

very beautiful now :)

For the problems still there while prone, go to #14259.

Updated by kju over 4 years ago

  • Target version changed from 1.55 BETA to 1.55.75445

Also available in: Atom PDF