Bug #1770

Performance doesn't scale with graphics options

Added by Skeptic over 5 years ago. Updated over 4 years ago.

Status:Rejected Start date:06/03/2009
Priority:Normal Due date:09/15/2009
Assignee:alef % Done:

0%

Category:Performance breakdown
Target version:-
Affected ArmA II version:1.03.58627 First affected build:
Reproduced by another DH user: First affected ArmA II version:
I am using some Mods:No Single / Multi Player?:
I am using: BIForumURL:
Reproducible for you:No NGUrl:
Related to content of DLC: WIKIurl:

Description

There are multiple reports of getting below 30fps with pretty high end hardware regardless of low/high settings/resolution/view distance.

http://forums.bistudio.com/showpost.php?p=1296975&postcount=18
http://forums.bistudio.com/showpost.php?p=1297132&postcount=19
http://forums.bistudio.com/showpost.php?p=1297221&postcount=23

DxDiag.rar (9.7 kB) Skeptic, 06/26/2009 23:39

Cherno-noAI.Chernarus.rar (772 Bytes) Skeptic, 06/26/2009 23:39

SkepticArmA2Profile.rar (3.1 kB) Skeptic, 06/26/2009 23:39

arma2rpt.rar (11.6 kB) Skeptic, 06/26/2009 23:39

History

Updated by Lee82UK over 5 years ago

I can confirm. On my hardware, video settings make little to no difference. Strangely, Arma 2 does not appear to use all available resources - in Chernogorsk I get around 25fps, yet Everest reports all 4 of my CPU cores are at much less than 50% utilised, and my 2x Radeon 4890 cards are both around 60% utilisation.

All 'Very High', 1920x1200, 150% fill rate, 7500 view distance = 25fps
All 'Low', 800x600, 50% fill rate, 2000 view distance = 26fps.

Hardware: Core i7 920 @ 4.20Ghz, 6GB DDR3, 2xHD 4890 1Gb, 2xSAS 15k Raid-0

Updated by Skeptic over 5 years ago

Here's another report using ArmamarkII benchmark

http://forums.bistudio.com/showthread.php?p=1297417#post1297417

Updated by pufu over 5 years ago

confirm....from my own post on BIS:

confirmed on 2 different rigs.

e6600 @ 3Ghz, GTX 260 216. 4GB ram

e8400 stock, 8800GT, 4GB ram

more or less same results as everyone else above

Editor is one thing even with AI in the scene and the campaign is another. Changing settings doesn't do any good, the FPS difference is around 3 by >>changing from lowest settings to highest (and even messing with fillrate from lower to higher). I got 40+ stable FPS on both machines in the editor >>on everything on High.

Updated by alef over 5 years ago

  • Due date set to 06/26/2009
  • Status changed from New to Feedback

Deep changes are foreseen for 1.02.
With so many posts on BIF and so many votes here, BI should be aware of this. That's why this is in Feedback.
Due date +1wk after 1.02 release. Let see if there will be any improvement with ArmAII-Mark.
Here my post with nVidia 186.08, +300 only because of drivers.

Updated by kju over 5 years ago

  • Assignee set to Skeptic

Updated by Skeptic over 5 years ago

How's FPS in SP vs MP? I'm mostly playing MP Coop. When console version comes out will we be able to play PC/Consoles in the same MP session? I wonder if there is some MP FPS limit.

Yeah, I agree ATI/nVidia should also look at this from their side. I had severe artifacting with 9.4 on XP 32bit, but it is gone on W7 64bit 9.5cat.

Updated by Skeptic over 5 years ago

OK finally got to running the custom benchmark... I created Chernogorsk quick mission "Cherno-noAI" where player drives in M1A at W speed around town in 3rd person view without any AI. Mission will be attached in the post.

I don't know how to reliably test MP session - there are simply too many variables, but client side itself shows different levels of performance at different settings.

Test platform:
Monitor: Spectre x32BV-Full HD
Motherboard: GA-EP45-UD3P F9l
CPU: C2D E8400 stock
RAM: Buffalo Micron D9 DDR2 4x1Gb
GPU: HD4890 1GB 9.5 Cat
Network: Intel Pro 1000PT PCIe
Sound: Creative X-Fi
Storage: OCZ Vertex SSD 2x32Gb RAID-0 and WD1001FALS
PSU: Antec Quattro 850W
OS: WinXP SP3

Arma2 Shortcut switches:
"C:\Program Files\Bohemia Interactive\ArmA 2\arma2.exe" -nosplash -world=empty -mod=@english -profiles=profiles

Test results:

AS you can see without AI there is quite wide range of settings that gives different performance. I will follow up with adding AI.

Test Low settings:

Test Normal settings:

Test High settings:

Updated by kju over 5 years ago

  • Category changed from Visual to Performance breakdown
  • Status changed from Feedback to Assigned
  • Assignee deleted (Skeptic)

Great info there skeptic!

Latest version (1.02 hotfix) right?

Updated by alef over 5 years ago

  • For the 60Hz capped, I suppose you are fullscreen v-sync
  • For video memory, "Default" should use all the available. I'm not sure about "Very high"
  • Why did you added the mdmp/bidmp if reported no crashes?
  • It doesn't seems the 1.02 hotfix becasue the Antialiasing control is disabled

Good job!

Updated by Skeptic over 5 years ago

Hi gents,

For the 60Hz capped, I suppose you are fullscreen v-sync
S: That's correct.

For video memory, "Default" should use all the available. I'm not sure about "Very high"
S: Prior to 1.02 I had severe artifacting, so I set to very high and it somehow made it less frequent. But yes, with default it should use all of 1Gb of VRAM.

Why did you added the mdmp/bidmp if reported no crashes?
S: Well, I thought more info better than less. I have not experienced any crashes since 1.01.

It doesn't seems the 1.02 hotfix becasue the Antialiasing control is disabled
S: That's correct - this is pre 1.02.58134 build.

Was glad to debunk FUD. Regards.

Updated by kju over 5 years ago

Wouldn't it be more useful to show graphs with GPU utilization?

Please attach the demo scenario next time.

Updated by Skeptic over 5 years ago

kju wrote:

Wouldn't it be more useful to show graphs with GPU utilization?

Please attach the demo scenario next time.

Hi, GPU utilization graph might be a good idea.

Do you mean the custom mission that was used in the benchmark? I have attached it "Cherno-noAI.Chernarus" http://dev-heaven.net/attachments/1162/Cherno-noAI.Chernarus.rar It's not camera fly-by - you have to drive M1A in 3rd person view yourself through pre-set way points. I wanted to closer simulate gameplay with user's input.

Updated by kju over 5 years ago

Thanks I missed that. :)

Updated by alef over 5 years ago

  • Due date changed from 06/26/2009 to 07/14/2009
  • Affected ArmA II version changed from 1.01.57751 to 1.02.58064

Updated by Squelch over 5 years ago

  • Due date changed from 07/14/2009 to 08/22/2009
  • Status changed from Assigned to Feedback

Please feedback your experiences with patch 1.03

Updated by Fireball over 5 years ago

  • File deleted (arma2mdmp.rar)

Updated by Fireball over 5 years ago

  • File deleted (arma2bidmp.rar)

Updated by Fireball over 5 years ago

  • Due date changed from 08/22/2009 to 09/15/2009
  • Status changed from Feedback to Assigned
  • Affected ArmA II version changed from 1.02.58064 to 1.03.58627

Giving some more time for feedback, aditionally, I don't think there changed a lot performance-wise.

Updated by Armored_Sheep over 5 years ago

Speed of drawing in the game does not depend only on GPU, but also CPU performance. If you dont see FPS change, you are probably stuck on low CPU performance or slow HDD (streaming) or simply too dense scene.

Updated by Skeptic over 5 years ago

Well, I will check if 4Gz E8400 makes a difference by running my custom level. Anything that can be off-loaded from CPU has been offloaded: Sound and Network. I doubt getting anything faster than 460MB/s sequential read SSD RAID-0 array will help to speed up HDD. See my specs below. And no, I don't see improvement in 1.03.

Monitor: Spectre x32BV-Full HD
Motherboard: GA-EP45-UD3P F9l
CPU: C2D E8400 stock
RAM: Buffalo Micron D9 DDR2 4x1Gb
GPU: HD4890 1GB 9.6 Cat
Network: Intel Pro 1000PT PCIe
Sound: Creative X-Fi
Storage: OCZ Vertex SSD 2x32Gb RAID-0 and WD1001FALS
PSU: Antec Quattro 850W
OS: WinXP SP3

Updated by Armored_Sheep over 5 years ago

  • Status changed from Assigned to Rejected

This report is generic and unrealistic. Arma2 streamed engine uses both GPU and CPU diferent way than average corridor games that have levels loaded in computer memory. If you have specific problem in some scene/mission, report that separately.

Updated by kju over 5 years ago

  • Assignee set to alef

Updated by Dwarden over 5 years ago

may i ask why You still using Catalyst 9.6 instead of 9.8 (ideally hotfixed driver released post 9.8) ?
for example 9.7 contains fixed video memory defragmenter (in XP it's part of drivers, in Vista/7 it's part of OS)
ARMA 2 benefits from that and also other small fixes in both 9.7 and 9.8 ...

Updated by Skeptic over 5 years ago

Armored_Sheep, I respectfully disagree with the rejection. It's possible that other tickets were created that address poor performance especially in cities regardless of low/med/high graphics settings on high end hardware. I of course can tell the difference between huge map streaming game from corridor crawler, and have respect to games that employ SpeedTree and other streaming technologies.

Dwarden, 9.7 broke Empire Total War AA and introduced severe lags. 9.8 didn't fix it. For Arma2 testing purposes I will install it and will report back.

Kind regards,
- Skeptic.

Updated by kju over 5 years ago

Well Skeptic the BI dev just tells you without more specific information,
that cannot take much use of this report.

That said some information from BI how to report FPS related issues
would be very useful too.

Updated by Skeptic over 5 years ago

OK, fair enough. Sorry, I don't necessarily know who is who on Dev-Heaven, and can't tell BIS developer by user ID.

And this ticket probably addresses the issue in more organized fashion: http://dev-heaven.net/issues/show/1745.

Cheers

Also available in: Atom PDF