Bug #17504

"ace_sys_wounds_rev" Event doesn't triger if you die inside a vehicle.

Added by columdrum about 4 years ago. Updated about 4 years ago.

Status:Closed Start date:02/09/2011
Priority:Low Due date:
Assignee:Sickboy % Done:

100%

Category:Script
Target version:1.9
Component:sys_wounds Affected Version:
Close Reason:

Description

Seems that the event that triggers when PMR is activated isn't triggered if you die inside a vehicle :S.

Way to reproduce:
1-Load attached mision.
2-Jump out of the heli, you will die and you will see the message(that means that the event was triggered)
3-Load the mision again, but this time crash yourself in the ground. This time you wouldn't see anything.

PS: there are some undocumented features like this one on the wiki, i tried to add then but seems that login is needed and i don't see the register button :S.
(Here where this feature was added: http://dev-heaven.net/issues/11270 )

event_Test.Desert_E.rar - Repro mission (928 Bytes) columdrum, 02/09/2011 17:47

ace_sys_wounds-_17504-fixed.7z (4.6 MB) Sickboy, 02/11/2011 18:23

Associated revisions

Revision f3a40034
Added by Sickboy about 4 years ago

~ FIXED: Wounds PMR PRInitU function didn't call "rev" event. fixes #17504

History

Updated by columdrum about 4 years ago

Well i think i found the issue, the problem seems to be that the function:

FUNC(PRInitU)

Starts the PMR countdown, but doesn't call the event so it just need the :

[QUOTE(GVAR(rev)), [_unit]] call CBA_fnc_localEvent;

To be added, just after setting the "ace_w_revive" variable (http://dev-heaven.net/projects/ace-mod2/repository/revisions/develop/entry/Addons/sys_wounds/XEH_postClientInit.sqf#L174).

And thanks i have got the mail with the account for the wiki, i will add some more notes on the wounding system that are missing.

Updated by Sickboy about 4 years ago

  • Category set to Script
  • Status changed from New to Assigned
  • Assignee set to Xeno
  • Priority changed from Normal to Low
  • Target version set to 395
  • Component set to sys_wounds

Updated by Sickboy about 4 years ago

Ty columdrum!

Updated by Sickboy about 4 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Updated by Sickboy about 4 years ago

Ehehe, whoops, was my domain :P
Sry for not making it into the release.

Updated by columdrum about 4 years ago

Thx, issue fixed btw :).

Updated by rocko about 4 years ago

  • Status changed from Resolved to Closed

Fixed in todays update

Also available in: Atom PDF